aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/lvm2
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-10-26 16:39:40 -0700
committerKhem Raj <raj.khem@gmail.com>2010-10-26 16:43:07 -0700
commit1b857681e6042d01709efb7279a4945b8d015823 (patch)
tree1c4d6176b47308b6bcd37264f6d7cc2bcdd4cb37 /recipes/lvm2
parent331b3127cb08dc3254fb4b105c3c1f9be67bb042 (diff)
downloadopenembedded-1b857681e6042d01709efb7279a4945b8d015823.tar.gz
lvm2: Add recipe for 2.02.75 version
* Remove the old recipes and unneeded patches Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/lvm2')
-rw-r--r--recipes/lvm2/lvm2.inc6
-rw-r--r--recipes/lvm2/lvm2/crosscompile_fix.patch13
-rw-r--r--recipes/lvm2/lvm2/eglibc-2.12.patch11
-rw-r--r--recipes/lvm2/lvm2/include-limits.patch13
-rw-r--r--recipes/lvm2/lvm2_2.01.09.bb8
-rw-r--r--recipes/lvm2/lvm2_2.01.15.bb8
-rw-r--r--recipes/lvm2/lvm2_2.02.75.bb6
7 files changed, 9 insertions, 56 deletions
diff --git a/recipes/lvm2/lvm2.inc b/recipes/lvm2/lvm2.inc
index dd3f509494..fc1afc3bd2 100644
--- a/recipes/lvm2/lvm2.inc
+++ b/recipes/lvm2/lvm2.inc
@@ -5,9 +5,7 @@ DEPENDS = "device-mapper"
INC_PR = "r3"
S = "${WORKDIR}/LVM2.${PV}"
-SRC_URI = "ftp://sources.redhat.com/pub/lvm2/old/LVM2.${PV}.tgz \
- file://crosscompile_fix.patch \
- file://include-limits.patch \
+SRC_URI = "ftp://sources.redhat.com/pub/lvm2/LVM2.${PV}.tgz \
file://lvm.conf"
# Unset user/group to unbreak install.
@@ -19,3 +17,5 @@ do_install_append() {
# Install machine specific configuration file
install -m 0644 ${WORKDIR}/lvm.conf ${D}${sysconfdir}/lvm/lvm.conf
}
+
+TARGET_CC_ARCH += "${LDFLAGS}"
diff --git a/recipes/lvm2/lvm2/crosscompile_fix.patch b/recipes/lvm2/lvm2/crosscompile_fix.patch
deleted file mode 100644
index 7f54f80072..0000000000
--- a/recipes/lvm2/lvm2/crosscompile_fix.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: LVM2.2.01.15/make.tmpl.in
-===================================================================
---- LVM2.2.01.15.orig/make.tmpl.in 2008-03-26 11:24:50.000000000 +0000
-+++ LVM2.2.01.15/make.tmpl.in 2008-03-26 11:25:02.000000000 +0000
-@@ -72,7 +72,7 @@
- CFLAGS += -DINTL_PACKAGE=\"@INTL_PACKAGE@\" -DLOCALEDIR=\"@LOCALEDIR@\"
- endif
-
--LDFLAGS += -L$(top_srcdir)/lib -L$(libdir)
-+LDFLAGS += -L$(top_srcdir)/lib
-
- #CFLAGS += -DDEBUG_POOL
- #CFLAGS += -DBOUNDS_CHECK
diff --git a/recipes/lvm2/lvm2/eglibc-2.12.patch b/recipes/lvm2/lvm2/eglibc-2.12.patch
deleted file mode 100644
index 0663bd6141..0000000000
--- a/recipes/lvm2/lvm2/eglibc-2.12.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -uNr LVM2.2.01.15.orig//lib/filters/filter-sysfs.c LVM2.2.01.15/lib/filters/filter-sysfs.c
---- LVM2.2.01.15.orig//lib/filters/filter-sysfs.c 2005-03-10 23:34:17.000000000 +0100
-+++ LVM2.2.01.15/lib/filters/filter-sysfs.c 2010-10-22 12:28:36.000000000 +0200
-@@ -20,6 +20,7 @@
- #ifdef linux
-
- #include <dirent.h>
-+#include <sys/stat.h>
-
- static int _locate_sysfs_blocks(const char *proc, char *path, size_t len)
- {
diff --git a/recipes/lvm2/lvm2/include-limits.patch b/recipes/lvm2/lvm2/include-limits.patch
deleted file mode 100644
index 49877666b4..0000000000
--- a/recipes/lvm2/lvm2/include-limits.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff -rpN LVM2.2.01.15-orig/lib/locking/cluster_locking.c LVM2.2.01.15/lib/locking/cluster_locking.c
-*** LVM2.2.01.15-orig/lib/locking/cluster_locking.c 2010-03-16 20:16:45.806355964 +0100
---- LVM2.2.01.15/lib/locking/cluster_locking.c 2010-03-16 20:19:08.946345762 +0100
-***************
-*** 29,34 ****
---- 29,35 ----
- #include <sys/socket.h>
- #include <sys/un.h>
- #include <unistd.h>
-+ #include <limits.h>
-
- #ifndef CLUSTER_LOCKING_INTERNAL
- int lock_resource(struct cmd_context *cmd, const char *resource, int flags);
diff --git a/recipes/lvm2/lvm2_2.01.09.bb b/recipes/lvm2/lvm2_2.01.09.bb
deleted file mode 100644
index 9682fa7d03..0000000000
--- a/recipes/lvm2/lvm2_2.01.09.bb
+++ /dev/null
@@ -1,8 +0,0 @@
-require lvm2.inc
-
-PR = "${INC_PR}.0"
-
-SRC_URI[md5sum] = "ed6fe3b734d05c6497cfa4f9932046e6"
-SRC_URI[sha256sum] = "f72b5868f8ab4c6d5ba4cd470e33ef8d916e9c6c1363a7ae48aefd9361e5fc90"
-
-
diff --git a/recipes/lvm2/lvm2_2.01.15.bb b/recipes/lvm2/lvm2_2.01.15.bb
deleted file mode 100644
index 5036475488..0000000000
--- a/recipes/lvm2/lvm2_2.01.15.bb
+++ /dev/null
@@ -1,8 +0,0 @@
-require lvm2.inc
-
-SRC_URI += "file://eglibc-2.12.patch"
-
-PR = "${INC_PR}.0"
-
-SRC_URI[md5sum] = "c71654baff263254fb5a226624ee8ef3"
-SRC_URI[sha256sum] = "80b47604ace83db4450f43d94a99fdf2ca317323fde8a591f57290d28ece7d3b"
diff --git a/recipes/lvm2/lvm2_2.02.75.bb b/recipes/lvm2/lvm2_2.02.75.bb
new file mode 100644
index 0000000000..bea54d6f47
--- /dev/null
+++ b/recipes/lvm2/lvm2_2.02.75.bb
@@ -0,0 +1,6 @@
+require lvm2.inc
+
+PR = "${INC_PR}.0"
+
+SRC_URI[md5sum] = "30ef29785b0e8cfbc106b5203c08d0e7"
+SRC_URI[sha256sum] = "f63ad083f9e371b4b490e8eaa9645447d456a76ae6a099e0b910e2e1ada75ba4"