aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/lvm2
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-10-22 12:31:16 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-10-22 12:35:05 +0200
commit3f307f24f6e74aa903e0f6479f06392f5460abf3 (patch)
tree9ec90f2775458798e0048d7bdb19ee17cb6d126e /recipes/lvm2
parent2f417a61ef9cece0ccd11d848ebcfd656b073ffe (diff)
downloadopenembedded-3f307f24f6e74aa903e0f6479f06392f5460abf3.tar.gz
lvm2: add patch for build with newer eglibc, drop empty do_stage()
* also rename files to lvm2 for faster FILESPATH lookup Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/lvm2')
-rw-r--r--recipes/lvm2/lvm2.inc7
-rw-r--r--recipes/lvm2/lvm2/crosscompile_fix.patch (renamed from recipes/lvm2/files/crosscompile_fix.patch)0
-rw-r--r--recipes/lvm2/lvm2/eglibc-2.12.patch11
-rw-r--r--recipes/lvm2/lvm2/include-limits.patch (renamed from recipes/lvm2/files/include-limits.patch)0
-rw-r--r--recipes/lvm2/lvm2/lvm.conf (renamed from recipes/lvm2/files/lvm.conf)0
-rw-r--r--recipes/lvm2/lvm2/palmpre/lvm.conf (renamed from recipes/lvm2/files/palmpre/lvm.conf)0
-rw-r--r--recipes/lvm2/lvm2_2.01.15.bb2
7 files changed, 14 insertions, 6 deletions
diff --git a/recipes/lvm2/lvm2.inc b/recipes/lvm2/lvm2.inc
index da7cc9ca7f..dd3f509494 100644
--- a/recipes/lvm2/lvm2.inc
+++ b/recipes/lvm2/lvm2.inc
@@ -2,7 +2,7 @@ SECTION = "utils"
DESCRIPTION = "LVM2 is a set of utilities to manage logical volumes in Linux."
LICENSE = "GPL"
DEPENDS = "device-mapper"
-INC_PR = "r2"
+INC_PR = "r3"
S = "${WORKDIR}/LVM2.${PV}"
SRC_URI = "ftp://sources.redhat.com/pub/lvm2/old/LVM2.${PV}.tgz \
@@ -15,11 +15,6 @@ EXTRA_OECONF = "--with-user= --with-group= --disable-o_direct"
inherit autotools
-# We don't need to stage anything (the executables are no needed at build time by any
-# other recipe)
-do_stage() {
-}
-
do_install_append() {
# Install machine specific configuration file
install -m 0644 ${WORKDIR}/lvm.conf ${D}${sysconfdir}/lvm/lvm.conf
diff --git a/recipes/lvm2/files/crosscompile_fix.patch b/recipes/lvm2/lvm2/crosscompile_fix.patch
index 7f54f80072..7f54f80072 100644
--- a/recipes/lvm2/files/crosscompile_fix.patch
+++ b/recipes/lvm2/lvm2/crosscompile_fix.patch
diff --git a/recipes/lvm2/lvm2/eglibc-2.12.patch b/recipes/lvm2/lvm2/eglibc-2.12.patch
new file mode 100644
index 0000000000..0663bd6141
--- /dev/null
+++ b/recipes/lvm2/lvm2/eglibc-2.12.patch
@@ -0,0 +1,11 @@
+diff -uNr LVM2.2.01.15.orig//lib/filters/filter-sysfs.c LVM2.2.01.15/lib/filters/filter-sysfs.c
+--- LVM2.2.01.15.orig//lib/filters/filter-sysfs.c 2005-03-10 23:34:17.000000000 +0100
++++ LVM2.2.01.15/lib/filters/filter-sysfs.c 2010-10-22 12:28:36.000000000 +0200
+@@ -20,6 +20,7 @@
+ #ifdef linux
+
+ #include <dirent.h>
++#include <sys/stat.h>
+
+ static int _locate_sysfs_blocks(const char *proc, char *path, size_t len)
+ {
diff --git a/recipes/lvm2/files/include-limits.patch b/recipes/lvm2/lvm2/include-limits.patch
index 49877666b4..49877666b4 100644
--- a/recipes/lvm2/files/include-limits.patch
+++ b/recipes/lvm2/lvm2/include-limits.patch
diff --git a/recipes/lvm2/files/lvm.conf b/recipes/lvm2/lvm2/lvm.conf
index c44c6a7a09..c44c6a7a09 100644
--- a/recipes/lvm2/files/lvm.conf
+++ b/recipes/lvm2/lvm2/lvm.conf
diff --git a/recipes/lvm2/files/palmpre/lvm.conf b/recipes/lvm2/lvm2/palmpre/lvm.conf
index 1cf16c68e3..1cf16c68e3 100644
--- a/recipes/lvm2/files/palmpre/lvm.conf
+++ b/recipes/lvm2/lvm2/palmpre/lvm.conf
diff --git a/recipes/lvm2/lvm2_2.01.15.bb b/recipes/lvm2/lvm2_2.01.15.bb
index 0c4d0ea1a9..5036475488 100644
--- a/recipes/lvm2/lvm2_2.01.15.bb
+++ b/recipes/lvm2/lvm2_2.01.15.bb
@@ -1,5 +1,7 @@
require lvm2.inc
+SRC_URI += "file://eglibc-2.12.patch"
+
PR = "${INC_PR}.0"
SRC_URI[md5sum] = "c71654baff263254fb5a226624ee8ef3"