aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/lxt
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/lxt
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/lxt')
-rw-r--r--recipes/lxt/lxt-1.0/lxt.patch38
-rw-r--r--recipes/lxt/lxt_1.0.bb15
2 files changed, 53 insertions, 0 deletions
diff --git a/recipes/lxt/lxt-1.0/lxt.patch b/recipes/lxt/lxt-1.0/lxt.patch
new file mode 100644
index 0000000000..fa92eb15b3
--- /dev/null
+++ b/recipes/lxt/lxt-1.0/lxt.patch
@@ -0,0 +1,38 @@
+diff -urNdb lxt-orig/gui.c lxt/gui.c
+--- lxt-orig/gui.c Sat Mar 31 21:07:05 2001
++++ lxt/gui.c Sun Jan 6 14:50:03 2002
+@@ -133,8 +133,8 @@
+
+ maxx=stdscr->_maxx+1;
+ maxy=stdscr->_maxy+1;
+- if((maxx<75)||(maxy<15)) crapout_nobug("cannot run the program in a window smaller than 75x15");
+- debuglog("maxx=%d, maxy=%d\n",maxx,maxy);
++// if((maxx<75)||(maxy<15)) crapout_nobug("cannot run the program in a window smaller than 75x15");
++// debuglog("maxx=%d, maxy=%d\n",maxx,maxy);
+
+ /* the one window that is always allocated */
+ gui_msbar=newwin(1,maxx,maxy-1,0);
+diff -urNdb lxt-orig/readconfig.c lxt/readconfig.c
+--- lxt-orig/readconfig.c Sun Apr 1 07:15:38 2001
++++ lxt/readconfig.c Mon Jan 7 12:13:48 2002
+@@ -77,7 +77,8 @@
+
+ for(n=0;stropts[n].var;n++) *stropts[n].var=NULL;
+ config_setoption("tmppath:/tmp");
+- config_setoption("editor:vi %p");
++ config_setoption("editor:vi %p");
++/* config_setoption("editor:vi %p"); */
+ config_setoption("archivebranch:tar cvfz %a -C %b .");
+ config_setoption("archivetagged:cd %b && tar cvfz %a -T %c");
+
+--- lxt/help.h.orig 2003-07-28 20:39:46.000000000 -0600
++++ lxt/help.h 2003-07-28 20:38:37.000000000 -0600
+@@ -98,7 +98,7 @@
+ d | dump mode \n\
+ m | toggle mask \n\
+ h | hex mode \n\
+- e | hex editor \n
++ e | hex editor \n\
+ f/p | pipe mode \n\
+ / | search forward \n\
+ | a search of the form /pattern/e will do an extended regex\n\
diff --git a/recipes/lxt/lxt_1.0.bb b/recipes/lxt/lxt_1.0.bb
new file mode 100644
index 0000000000..4cefc60f26
--- /dev/null
+++ b/recipes/lxt/lxt_1.0.bb
@@ -0,0 +1,15 @@
+LICENSE = "GPL"
+SECTION = "console/utils"
+DESCRIPTION = "lxt ncurses filemanager xtree clone"
+PRIORITY = "optional"
+DEPENDS = "ncurses"
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/lxt-1.0"
+
+SRC_URI = "http://www.xtreefanpage.org/download/lxt-1.0.tgz \
+ file://lxt.patch;patch=1"
+S = "${WORKDIR}/lxt"
+
+do_install() {
+ install -d ${D}${bindir}/
+ install -m 755 -D ${S}/lxt ${D}${bindir}/lxt
+}