aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/lyx
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-10-23 09:17:37 +0200
committerKoen Kooi <koen@openembedded.org>2009-10-23 09:17:37 +0200
commitdf4e832331953c2f441ee2449cbb2b8a268c776d (patch)
tree62cd4426b42737fe223bf55d16482f72487f8b10 /recipes/lyx
parenta47b5b92afb708a6b79a568d96219f839e32de55 (diff)
downloadopenembedded-df4e832331953c2f441ee2449cbb2b8a268c776d.tar.gz
lyx: add 1.6.4.1
Deleting libtool.m4 allows us to use autoreconf :)
Diffstat (limited to 'recipes/lyx')
-rw-r--r--recipes/lyx/lyx/qt4tools-detect.diff15
-rw-r--r--recipes/lyx/lyx_1.6.4.1.bb28
2 files changed, 43 insertions, 0 deletions
diff --git a/recipes/lyx/lyx/qt4tools-detect.diff b/recipes/lyx/lyx/qt4tools-detect.diff
new file mode 100644
index 0000000000..3c0110a40d
--- /dev/null
+++ b/recipes/lyx/lyx/qt4tools-detect.diff
@@ -0,0 +1,15 @@
+--- /tmp/qt4.m4 2009-10-22 22:45:15.000000000 +0200
++++ lyx-1.6.4.1/config/qt4.m4 2009-10-22 22:46:23.000000000 +0200
+@@ -138,9 +138,9 @@
+ if test "$pkg_failed" != "no" ; then
+ QT4_DO_MANUAL_CONFIG
+ fi
+- AC_PATH_PROGS(MOC4, [moc-qt4 moc],[],$qt4_cv_bin:$PATH)
+- AC_PATH_PROGS(UIC4, [uic-qt4 uic],[],$qt4_cv_bin:$PATH)
+- AC_PATH_PROGS(RCC4, [rcc-qt4 rcc],[],$qt4_cv_bin:$PATH)
++ AC_PATH_PROGS(MOC4, [moc-qt4 moc4],[],$qt4_cv_bin:$PATH)
++ AC_PATH_PROGS(UIC4, [uic-qt4 uic4],[],$qt4_cv_bin:$PATH)
++ AC_PATH_PROGS(RCC4, [rcc-qt4 rcc4],[],$qt4_cv_bin:$PATH)
+ ])
+
+ AC_DEFUN([QT4_DO_PKG_CONFIG],
diff --git a/recipes/lyx/lyx_1.6.4.1.bb b/recipes/lyx/lyx_1.6.4.1.bb
new file mode 100644
index 0000000000..8f37ceeddc
--- /dev/null
+++ b/recipes/lyx/lyx_1.6.4.1.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "LyX is an advanced type setting processor - a frontend for LaTeX"
+SECTION = "x11/office"
+LICENSE = "GPL"
+HOMEPAGE = "http://www.lyx.org"
+DEPENDS = "qt4-x11-free"
+RSUGGESTS = "tetex"
+RDEPENDS = "python-shell python-textutils"
+
+SRC_URI = "\
+ ftp://ftp.lyx.org/pub/lyx/stable/1.6.x/lyx-${PV}.tar.bz2 \
+ file://no-session-manager.patch;patch=1 \
+ file://qt4tools-detect.diff;patch=1 \
+"
+
+inherit qt4x11 autotools
+
+EXTRA_OECONF = "\
+ --with-qt4-dir=${QTDIR} \
+ --enable-threads=posix \
+"
+
+do_configure_prepend() {
+ rm -f ${S}/config/libtool.m4
+}
+
+EXTRA_QMAKEVARS_POST = "DEFINES+=_LIBC"
+PARALLEL_MAKE = ""
+