summaryrefslogtreecommitdiffstats
path: root/recipes/lyx
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/lyx
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/lyx')
-rw-r--r--recipes/lyx/files/no-session-manager.patch20
-rw-r--r--recipes/lyx/lyx_1.6.1.bb28
2 files changed, 48 insertions, 0 deletions
diff --git a/recipes/lyx/files/no-session-manager.patch b/recipes/lyx/files/no-session-manager.patch
new file mode 100644
index 0000000000..edb8f00f3c
--- /dev/null
+++ b/recipes/lyx/files/no-session-manager.patch
@@ -0,0 +1,20 @@
+Index: lyx-1.6.1/src/frontends/qt4/GuiApplication.cpp
+===================================================================
+--- lyx-1.6.1.orig/src/frontends/qt4/GuiApplication.cpp
++++ lyx-1.6.1/src/frontends/qt4/GuiApplication.cpp
+@@ -1320,6 +1320,7 @@
+
+ void GuiApplication::commitData(QSessionManager & sm)
+ {
++#if 0 // no session manager in OE's Qt4
+ /// The implementation is required to avoid an application exit
+ /// when session state save is triggered by session manager.
+ /// The default implementation sends a close event to all
+@@ -1329,6 +1330,7 @@
+ /// FIXME: verify if the default implementation is enough now.
+ if (sm.allowsInteraction() && !closeAllViews())
+ sm.cancel();
++#endif
+ }
+
+
diff --git a/recipes/lyx/lyx_1.6.1.bb b/recipes/lyx/lyx_1.6.1.bb
new file mode 100644
index 0000000000..d293a081cf
--- /dev/null
+++ b/recipes/lyx/lyx_1.6.1.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "LyX is an advanced type setting processor - a frontend for LaTeX"
+SECTION = "x11/office"
+LICENSE = "GPL"
+HOMEPAGE = "http://www.lyx.org"
+DEPENDS = "qt4-x11-free"
+RSUGGESTS = "tetex"
+RDEPENDS = "python-shell python-textutils"
+PR = "r0"
+
+SRC_URI = "\
+ ftp://ftp.lyx.org/pub/lyx/stable/1.6.x/lyx-${PV}.tar.bz2 \
+ file://no-session-manager.patch;patch=1 \
+"
+
+inherit qt4x11 autotools
+
+EXTRA_OECONF = "\
+ --with-qt4-dir=${QTDIR} \
+ --enable-threads=posix \
+"
+
+EXTRA_QMAKEVARS_POST = "DEFINES+=_LIBC"
+PARALLEL_MAKE = ""
+
+do_configure() {
+ gnu-configize
+ oe_runconf
+}