aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/lzip
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-10-26 12:14:20 -0700
committerChris Larson <chris_larson@mentor.com>2010-10-26 12:15:40 -0700
commite2a741b3d2b4acef820d04efc7a0de96a7e1e2a5 (patch)
tree43deb36cf65a8e9920adf558470fa61d0a532015 /recipes/lzip
parentfe76d1099047579865b343b7eedc175fbe1c8335 (diff)
downloadopenembedded-e2a741b3d2b4acef820d04efc7a0de96a7e1e2a5.tar.gz
lzip: add recipe, version 1.11
Signed-off-by: Chris Larson <chris_larson@mentor.com>
Diffstat (limited to 'recipes/lzip')
-rw-r--r--recipes/lzip/lzip_1.11.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes/lzip/lzip_1.11.bb b/recipes/lzip/lzip_1.11.bb
new file mode 100644
index 0000000000..f1db467201
--- /dev/null
+++ b/recipes/lzip/lzip_1.11.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "Lzip is a lossless data compressor based on the LZMA algorithm"
+HOMEPAGE = "http://lzip.nongnu.org/lzip.html"
+LICENSE = "GPLv3+"
+PR = "0"
+
+SRC_URI = "${SAVANNAH_MIRROR}/releases/lzip/lzip-${PV}.tar.gz"
+SRC_URI[md5sum] = "ba9d0a705e47bcd2b73145d238aa7b58"
+SRC_URI[sha256sum] = "c3cfd2396733f6817b25a2bd1b019447ac2fa692f6fe5dc477631a9dbb31b00b"
+
+CONFIGUREOPTS = "\
+ '--srcdir=${S}' \
+ '--prefix=${prefix}' \
+ '--exec-prefix=${exec_prefix}' \
+ '--bindir=${bindir}' \
+ '--datadir=${datadir}' \
+ '--infodir=${infodir}' \
+ '--sysconfdir=${sysconfdir}' \
+ 'CXX=${CXX}' \
+ 'CPPFLAGS=${CPPFLAGS}' \
+ 'CXXFLAGS=${CXXFLAGS}' \
+ 'LDFLAGS=${LDFLAGS}' \
+"
+EXTRA_OEMAKE = ""
+
+B = "${S}/obj"
+do_configure () {
+ ${S}/configure ${CONFIGUREOPTS}
+}
+
+BBCLASSEXTEND += "native nativesdk"