summaryrefslogtreecommitdiffstats
path: root/recipes/lzma
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/lzma
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/lzma')
-rw-r--r--recipes/lzma/files/lzma-406-zlib-stream.patch405
-rw-r--r--recipes/lzma/lzma-native_4.17.bb25
-rw-r--r--recipes/lzma/lzma_4.17.bb36
3 files changed, 466 insertions, 0 deletions
diff --git a/recipes/lzma/files/lzma-406-zlib-stream.patch b/recipes/lzma/files/lzma-406-zlib-stream.patch
new file mode 100644
index 0000000000..5af976372c
--- /dev/null
+++ b/recipes/lzma/files/lzma-406-zlib-stream.patch
@@ -0,0 +1,405 @@
+diff -BurN lzma406/SRC/7zip/Compress/LZMA/LZMADecoder.cpp lzma/SRC/7zip/Compress/LZMA/LZMADecoder.cpp
+--- lzma406/SRC/7zip/Compress/LZMA/LZMADecoder.cpp 2004-08-25 01:40:48.000000000 +0400
++++ lzma/SRC/7zip/Compress/LZMA/LZMADecoder.cpp 2005-01-20 14:47:45.789801629 +0300
+@@ -288,12 +288,17 @@
+ Byte remainder = (Byte)(properties[0] / 9);
+ int lp = remainder % 5;
+ int pb = remainder / 5;
+- if (pb > NLength::kNumPosStatesBitsMax)
+- return E_INVALIDARG;
+- _posStateMask = (1 << pb) - 1;
+ UInt32 dictionarySize = 0;
+ for (int i = 0; i < 4; i++)
+ dictionarySize += ((UInt32)(properties[1 + i])) << (i * 8);
++ return SetDecoderPropertiesRaw(lc, lp, pb, dictionarySize);
++}
++
++STDMETHODIMP CDecoder::SetDecoderPropertiesRaw(int lc, int lp, int pb, UInt32 dictionarySize)
++{
++ if (pb > NLength::kNumPosStatesBitsMax)
++ return E_INVALIDARG;
++ _posStateMask = (1 << pb) - 1;
+ _dictionarySizeCheck = MyMax(dictionarySize, UInt32(1));
+ UInt32 blockSize = MyMax(_dictionarySizeCheck, UInt32(1 << 12));
+ if (!_outWindowStream.Create(blockSize))
+diff -BurN lzma406/SRC/7zip/Compress/LZMA/LZMADecoder.h lzma/SRC/7zip/Compress/LZMA/LZMADecoder.h
+--- lzma406/SRC/7zip/Compress/LZMA/LZMADecoder.h 2004-08-25 01:40:08.000000000 +0400
++++ lzma/SRC/7zip/Compress/LZMA/LZMADecoder.h 2005-01-20 13:06:59.081297916 +0300
+@@ -234,6 +234,8 @@
+ STDMETHOD(Read)(void *data, UInt32 size, UInt32 *processedSize);
+ STDMETHOD(ReadPart)(void *data, UInt32 size, UInt32 *processedSize);
+
++ STDMETHOD(SetDecoderPropertiesRaw)(int lc, int lp, int pb, UInt32 dictionarySize);
++
+ virtual ~CDecoder() {}
+ };
+
+diff -BurN lzma406/SRC/7zip/Compress/LZMA_Lib/makefile lzma/SRC/7zip/Compress/LZMA_Lib/makefile
+--- lzma406/SRC/7zip/Compress/LZMA_Lib/makefile 1970-01-01 03:00:00.000000000 +0300
++++ lzma/SRC/7zip/Compress/LZMA_Lib/makefile 2005-01-19 13:49:20.000000000 +0300
+@@ -0,0 +1,88 @@
++PROG = liblzma.a
++CXX = g++ -O3 -Wall
++AR = ar
++RM = rm -f
++CFLAGS = -c
++
++OBJS = \
++ ZLib.o \
++ LZMADecoder.o \
++ LZMAEncoder.o \
++ LZInWindow.o \
++ LZOutWindow.o \
++ RangeCoderBit.o \
++ InBuffer.o \
++ OutBuffer.o \
++ FileStreams.o \
++ Alloc.o \
++ C_FileIO.o \
++ CommandLineParser.o \
++ CRC.o \
++ String.o \
++ StringConvert.o \
++ StringToInt.o \
++ Vector.o \
++
++
++all: $(PROG)
++
++$(PROG): $(OBJS)
++ $(AR) r $(PROG) $(OBJS)
++
++ZLib.o: ZLib.cpp
++ $(CXX) $(CFLAGS) ZLib.cpp
++
++LZMADecoder.o: ../LZMA/LZMADecoder.cpp
++ $(CXX) $(CFLAGS) ../LZMA/LZMADecoder.cpp
++
++LZMAEncoder.o: ../LZMA/LZMAEncoder.cpp
++ $(CXX) $(CFLAGS) ../LZMA/LZMAEncoder.cpp
++
++LZInWindow.o: ../LZ/LZInWindow.cpp
++ $(CXX) $(CFLAGS) ../LZ/LZInWindow.cpp
++
++LZOutWindow.o: ../LZ/LZOutWindow.cpp
++ $(CXX) $(CFLAGS) ../LZ/LZOutWindow.cpp
++
++RangeCoderBit.o: ../RangeCoder/RangeCoderBit.cpp
++ $(CXX) $(CFLAGS) ../RangeCoder/RangeCoderBit.cpp
++
++InBuffer.o: ../../Common/InBuffer.cpp
++ $(CXX) $(CFLAGS) ../../Common/InBuffer.cpp
++
++OutBuffer.o: ../../Common/OutBuffer.cpp
++ $(CXX) $(CFLAGS) ../../Common/OutBuffer.cpp
++
++FileStreams.o: ../../Common/FileStreams.cpp
++ $(CXX) $(CFLAGS) ../../Common/FileStreams.cpp
++
++Alloc.o: ../../../Common/Alloc.cpp
++ $(CXX) $(CFLAGS) ../../../Common/Alloc.cpp
++
++C_FileIO.o: ../../../Common/C_FileIO.cpp
++ $(CXX) $(CFLAGS) ../../../Common/C_FileIO.cpp
++
++CommandLineParser.o: ../../../Common/CommandLineParser.cpp
++ $(CXX) $(CFLAGS) ../../../Common/CommandLineParser.cpp
++
++CRC.o: ../../../Common/CRC.cpp
++ $(CXX) $(CFLAGS) ../../../Common/CRC.cpp
++
++MyWindows.o: ../../../Common/MyWindows.cpp
++ $(CXX) $(CFLAGS) ../../../Common/MyWindows.cpp
++
++String.o: ../../../Common/String.cpp
++ $(CXX) $(CFLAGS) ../../../Common/String.cpp
++
++StringConvert.o: ../../../Common/StringConvert.cpp
++ $(CXX) $(CFLAGS) ../../../Common/StringConvert.cpp
++
++StringToInt.o: ../../../Common/StringToInt.cpp
++ $(CXX) $(CFLAGS) ../../../Common/StringToInt.cpp
++
++Vector.o: ../../../Common/Vector.cpp
++ $(CXX) $(CFLAGS) ../../../Common/Vector.cpp
++
++clean:
++ -$(RM) $(PROG) $(OBJS)
++
+diff -BurN lzma406/SRC/7zip/Compress/LZMA_Lib/ZLib.cpp lzma/SRC/7zip/Compress/LZMA_Lib/ZLib.cpp
+--- lzma406/SRC/7zip/Compress/LZMA_Lib/ZLib.cpp 1970-01-01 03:00:00.000000000 +0300
++++ lzma/SRC/7zip/Compress/LZMA_Lib/ZLib.cpp 2005-01-20 15:01:18.439221129 +0300
+@@ -0,0 +1,273 @@
++/*
++ * lzma zlib simplified wrapper
++ *
++ * Copyright (c) 2005 Oleg I. Vdovikin <oleg@cs.msu.su>
++ *
++ * This library is free software; you can redistribute
++ * it and/or modify it under the terms of the GNU Lesser
++ * General Public License as published by the Free Software
++ * Foundation; either version 2.1 of the License, or
++ * (at your option) any later version.
++ *
++ * This library is distributed in the hope that it will be
++ * useful, but WITHOUT ANY WARRANTY; without even the implied
++ * warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
++ * PURPOSE. See the GNU Lesser General Public License
++ * for more details.
++ *
++ * You should have received a copy of the GNU Lesser General
++ * Public License along with this library; if not, write to
++ * the Free Software Foundation, Inc., 59 Temple Place,
++ * Suite 330, Boston, MA 02111-1307 USA
++ */
++
++/*
++ * default values for encoder/decoder used by wrapper
++ */
++
++#include <zlib.h>
++
++#define ZLIB_LC 3
++#define ZLIB_LP 0
++#define ZLIB_PB 2
++
++#ifdef WIN32
++#include <initguid.h>
++#else
++#define INITGUID
++#endif
++
++#include "../../../Common/MyWindows.h"
++#include "../LZMA/LZMADecoder.h"
++#include "../LZMA/LZMAEncoder.h"
++
++#define STG_E_SEEKERROR ((HRESULT)0x80030019L)
++#define STG_E_MEDIUMFULL ((HRESULT)0x80030070L)
++
++class CInMemoryStream:
++ public IInStream,
++ public IStreamGetSize,
++ public CMyUnknownImp
++{
++public:
++ CInMemoryStream(const Bytef *data, UInt64 size) :
++ m_data(data), m_size(size), m_offset(0) {}
++
++ virtual ~CInMemoryStream() {}
++
++ MY_UNKNOWN_IMP2(IInStream, IStreamGetSize)
++
++ STDMETHOD(Read)(void *data, UInt32 size, UInt32 *processedSize)
++ {
++ if (size > m_size - m_offset)
++ size = m_size - m_offset;
++
++ if (size) {
++ memcpy(data, m_data + m_offset, size);
++ }
++
++ m_offset += size;
++
++ if (processedSize)
++ *processedSize = size;
++
++ return S_OK;
++ }
++
++ STDMETHOD(ReadPart)(void *data, UInt32 size, UInt32 *processedSize)
++ {
++ return Read(data, size, processedSize);
++ }
++
++ STDMETHOD(Seek)(Int64 offset, UInt32 seekOrigin, UInt64 *newPosition)
++ {
++ UInt64 _offset;
++
++ if (seekOrigin == STREAM_SEEK_SET) _offset = offset;
++ else if (seekOrigin == STREAM_SEEK_CUR) _offset = m_offset + offset;
++ else if (seekOrigin == STREAM_SEEK_END) _offset = m_size;
++ else return STG_E_INVALIDFUNCTION;
++
++ if (_offset < 0 || _offset > m_size)
++ return STG_E_SEEKERROR;
++
++ m_offset = _offset;
++
++ if (newPosition)
++ *newPosition = m_offset;
++
++ return S_OK;
++ }
++
++ STDMETHOD(GetSize)(UInt64 *size)
++ {
++ *size = m_size;
++ return S_OK;
++ }
++protected:
++ const Bytef *m_data;
++ UInt64 m_size;
++ UInt64 m_offset;
++};
++
++class COutMemoryStream:
++ public IOutStream,
++ public CMyUnknownImp
++{
++public:
++ COutMemoryStream(Bytef *data, UInt64 maxsize) :
++ m_data(data), m_size(0), m_maxsize(maxsize), m_offset(0) {}
++ virtual ~COutMemoryStream() {}
++
++ MY_UNKNOWN_IMP1(IOutStream)
++
++ STDMETHOD(Write)(const void *data, UInt32 size, UInt32 *processedSize)
++ {
++ if (size > m_maxsize - m_offset)
++ size = m_maxsize - m_offset;
++
++ if (size) {
++ memcpy(m_data + m_offset, data, size);
++ }
++
++ m_offset += size;
++
++ if (m_offset > m_size)
++ m_size = m_offset;
++
++ if (processedSize)
++ *processedSize = size;
++
++ return S_OK;
++ }
++
++ STDMETHOD(WritePart)(const void *data, UInt32 size, UInt32 *processedSize)
++ {
++ return Write(data, size, processedSize);
++ }
++
++ STDMETHOD(Seek)(Int64 offset, UInt32 seekOrigin, UInt64 *newPosition)
++ {
++ UInt64 _offset;
++
++ if (seekOrigin == STREAM_SEEK_SET) _offset = offset;
++ else if (seekOrigin == STREAM_SEEK_CUR) _offset = m_offset + offset;
++ else if (seekOrigin == STREAM_SEEK_END) _offset = m_size;
++ else return STG_E_INVALIDFUNCTION;
++
++ if (_offset < 0 || _offset > m_maxsize)
++ return STG_E_SEEKERROR;
++
++ m_offset = _offset;
++
++ if (newPosition)
++ *newPosition = m_offset;
++
++ return S_OK;
++ }
++
++ STDMETHOD(SetSize)(Int64 newSize)
++ {
++ if ((UInt64)newSize > m_maxsize)
++ return STG_E_MEDIUMFULL;
++
++ return S_OK;
++ }
++protected:
++ Bytef *m_data;
++ UInt64 m_size;
++ UInt64 m_maxsize;
++ UInt64 m_offset;
++};
++
++ZEXTERN int ZEXPORT compress2 OF((Bytef *dest, uLongf *destLen,
++ const Bytef *source, uLong sourceLen,
++ int level))
++{
++ CInMemoryStream *inStreamSpec = new CInMemoryStream(source, sourceLen);
++ CMyComPtr<ISequentialInStream> inStream = inStreamSpec;
++
++ COutMemoryStream *outStreamSpec = new COutMemoryStream(dest, *destLen);
++ CMyComPtr<ISequentialOutStream> outStream = outStreamSpec;
++
++ NCompress::NLZMA::CEncoder *encoderSpec =
++ new NCompress::NLZMA::CEncoder;
++ CMyComPtr<ICompressCoder> encoder = encoderSpec;
++
++ PROPID propIDs[] =
++ {
++ NCoderPropID::kDictionarySize,
++ NCoderPropID::kPosStateBits,
++ NCoderPropID::kLitContextBits,
++ NCoderPropID::kLitPosBits,
++ NCoderPropID::kAlgorithm,
++ NCoderPropID::kNumFastBytes,
++ NCoderPropID::kMatchFinder,
++ NCoderPropID::kEndMarker
++ };
++ const int kNumProps = sizeof(propIDs) / sizeof(propIDs[0]);
++
++ PROPVARIANT properties[kNumProps];
++ for (int p = 0; p < 6; p++)
++ properties[p].vt = VT_UI4;
++ properties[0].ulVal = UInt32(1 << (level + 14));
++ properties[1].ulVal = UInt32(ZLIB_PB);
++ properties[2].ulVal = UInt32(ZLIB_LC); // for normal files
++ properties[3].ulVal = UInt32(ZLIB_LP); // for normal files
++ properties[4].ulVal = UInt32(2);
++ properties[5].ulVal = UInt32(128);
++
++ properties[6].vt = VT_BSTR;
++ properties[6].bstrVal = (BSTR)(const wchar_t *)L"BT4";
++
++ properties[7].vt = VT_BOOL;
++ properties[7].boolVal = VARIANT_TRUE;
++
++ if (encoderSpec->SetCoderProperties(propIDs, properties, kNumProps) != S_OK)
++ return Z_MEM_ERROR; // should not happen
++
++ HRESULT result = encoder->Code(inStream, outStream, 0, 0, 0);
++ if (result == E_OUTOFMEMORY)
++ {
++ return Z_MEM_ERROR;
++ }
++ else if (result != S_OK)
++ {
++ return Z_BUF_ERROR; // should not happen
++ }
++
++ UInt64 fileSize;
++ outStreamSpec->Seek(0, STREAM_SEEK_END, &fileSize);
++ *destLen = fileSize;
++
++ return Z_OK;
++}
++
++ZEXTERN int ZEXPORT uncompress OF((Bytef *dest, uLongf *destLen,
++ const Bytef *source, uLong sourceLen))
++{
++ CInMemoryStream *inStreamSpec = new CInMemoryStream(source, sourceLen);
++ CMyComPtr<ISequentialInStream> inStream = inStreamSpec;
++
++ COutMemoryStream *outStreamSpec = new COutMemoryStream(dest, *destLen);
++ CMyComPtr<ISequentialOutStream> outStream = outStreamSpec;
++
++ NCompress::NLZMA::CDecoder *decoderSpec =
++ new NCompress::NLZMA::CDecoder;
++ CMyComPtr<ICompressCoder> decoder = decoderSpec;
++
++ if (decoderSpec->SetDecoderPropertiesRaw(ZLIB_LC,
++ ZLIB_LP, ZLIB_PB, (1 << 23)) != S_OK) return Z_DATA_ERROR;
++
++ UInt64 fileSize = *destLen;
++
++ if (decoder->Code(inStream, outStream, 0, &fileSize, 0) != S_OK)
++ {
++ return Z_DATA_ERROR;
++ }
++
++ outStreamSpec->Seek(0, STREAM_SEEK_END, &fileSize);
++ *destLen = fileSize;
++
++ return Z_OK;
++}
diff --git a/recipes/lzma/lzma-native_4.17.bb b/recipes/lzma/lzma-native_4.17.bb
new file mode 100644
index 0000000000..24664b32e4
--- /dev/null
+++ b/recipes/lzma/lzma-native_4.17.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "LZMA is a general compression method. LZMA provides high compression ratio and very fast decompression."
+HOMEPAGE = "http://www.7-zip.org/"
+LICENSE = "LGPL"
+DEPENDS = "zlib-native"
+PR = "r3"
+
+PVNODOT = "${@bb.data.getVar('PV',d,1).split('.')[0]}${@bb.data.getVar('PV',d,1).split('.')[1]}"
+SRC_URI = "${SOURCEFORGE_MIRROR}/sevenzip/lzma${PVNODOT}.tar.bz2 \
+ file://lzma-406-zlib-stream.patch;patch=1;pnum=2"
+
+S = "${WORKDIR}/SRC"
+
+inherit native
+
+CFLAGS += "-c -I${S}"
+
+do_compile() {
+ oe_runmake -C 7zip/Compress/LZMA_Alone
+ oe_runmake -C 7zip/Compress/LZMA_Lib
+}
+
+do_stage () {
+ install -m 0755 7zip/Compress/LZMA_Alone/lzma ${STAGING_BINDIR}
+ oe_libinstall -a -C 7zip/Compress/LZMA_Lib liblzma ${STAGING_LIBDIR}
+}
diff --git a/recipes/lzma/lzma_4.17.bb b/recipes/lzma/lzma_4.17.bb
new file mode 100644
index 0000000000..f83ddd587e
--- /dev/null
+++ b/recipes/lzma/lzma_4.17.bb
@@ -0,0 +1,36 @@
+DESCRIPTION = "LZMA is a general compression method. LZMA provides high compression ratio and very fast decompression."
+HOMEPAGE = "http://www.7-zip.org/"
+LICENSE = "LGPL"
+DEPENDS = "zlib"
+PR = "r1"
+
+SRC_URI = "http://www.7-zip.org/dl/lzma417.tar.bz2 \
+ file://lzma-406-zlib-stream.patch;patch=1;pnum=2"
+
+S = "${WORKDIR}/SRC"
+
+EXTRA_OEMAKE += "CXX_C='${CC}'"
+
+CFLAGS += "-c -I${S}"
+
+# If you run into "internal compiler error" failures with gcc, disable optimization
+# using -O0, or use -O1 or -O2 instead of -Os. (reported failure: gcc 3.4.4 for sh4)
+#FULL_OPTIMIZATION = "-O0"
+
+# One such reported failure is a cross-gcc 3.4.4 for sh4:
+FULL_OPTIMIZATION_sh4 = "-O1"
+
+do_compile() {
+ oe_runmake -C 7zip/Compress/LZMA_Alone
+ oe_runmake -C 7zip/Compress/LZMA_Lib
+}
+
+do_install() {
+ install -d ${D}${bindir} ${D}${libdir}
+ install -m 0755 7zip/Compress/LZMA_Alone/lzma ${D}${bindir}
+ oe_libinstall -a -C 7zip/Compress/LZMA_Lib liblzma ${D}${libdir}
+}
+
+do_stage () {
+ oe_libinstall -a -C 7zip/Compress/LZMA_Lib liblzma ${STAGING_LIBDIR}
+}