summaryrefslogtreecommitdiffstats
path: root/recipes/lzma
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-03-23 15:28:51 -0700
committerKhem Raj <raj.khem@gmail.com>2010-03-23 15:28:51 -0700
commitca018970a82eedd563bd485c9be322484fd306bf (patch)
treeec57ac287c99cd15e92921382c8d1d7a3091f723 /recipes/lzma
parentef6e7b308e3cafdd7edb3d392996b0dec833089c (diff)
downloadopenembedded-ca018970a82eedd563bd485c9be322484fd306bf.tar.gz
lzma: Use BBCLASSEXTEND to get native recipe.
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/lzma')
-rw-r--r--recipes/lzma/lzma-native_4.65.bb6
-rw-r--r--recipes/lzma/lzma.inc3
2 files changed, 3 insertions, 6 deletions
diff --git a/recipes/lzma/lzma-native_4.65.bb b/recipes/lzma/lzma-native_4.65.bb
deleted file mode 100644
index da05dfa7e0..0000000000
--- a/recipes/lzma/lzma-native_4.65.bb
+++ /dev/null
@@ -1,6 +0,0 @@
-inherit native
-NATIVE_INSTALL_WORKS = "1"
-
-require lzma.inc
-PR = "${INC_PR}.1"
-DEPENDS = "zlib-native"
diff --git a/recipes/lzma/lzma.inc b/recipes/lzma/lzma.inc
index e51de9596a..fb34e0baac 100644
--- a/recipes/lzma/lzma.inc
+++ b/recipes/lzma/lzma.inc
@@ -36,3 +36,6 @@ do_install() {
install -m 0755 CPP/7zip/Compress/LZMA_Alone/lzma ${D}${bindir}
oe_libinstall -a -C C/LzmaUtil liblzma ${D}${libdir}
}
+
+NATIVE_INSTALL_WORKS = "1"
+BBCLASSEXTEND = "native"