summaryrefslogtreecommitdiffstats
path: root/recipes/madwifi/files
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/madwifi/files
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/madwifi/files')
-rw-r--r--recipes/madwifi/files/10-sh4-le-elf-copts.patch12
-rw-r--r--recipes/madwifi/files/10-xscale-be-elf-copts.patch10
-rw-r--r--recipes/madwifi/files/10-xscale-le-elf-copts.patch8
-rw-r--r--recipes/madwifi/files/20-xscale-VFP-wackelf-v2.patch20
-rw-r--r--recipes/madwifi/files/20-xscale-VFP-wackelf.patch20
-rw-r--r--recipes/madwifi/files/30-define-ioreadwrite32be-for-little-endian-too.patch13
6 files changed, 83 insertions, 0 deletions
diff --git a/recipes/madwifi/files/10-sh4-le-elf-copts.patch b/recipes/madwifi/files/10-sh4-le-elf-copts.patch
new file mode 100644
index 0000000000..f6a9e0020b
--- /dev/null
+++ b/recipes/madwifi/files/10-sh4-le-elf-copts.patch
@@ -0,0 +1,12 @@
+The -mno-implicit-fp is for gcc 4.x while for gcc 3.x we need -m4-nofpu.
+Since kernels built with gcc 4.x don't work on sh4 anwyay we patch this
+unconditionally for building with gcc 3.x
+
+--- madwifi-ng-r1527-20060425/hal/public/sh4-le-elf.inc~ 2006-07-25 13:41:29.000000000 +1000
++++ madwifi-ng-r1527-20060425/hal/public/sh4-le-elf.inc 2006-07-25 13:41:29.000000000 +1000
+@@ -59,4 +59,4 @@
+
+ LDOPTS= -EL
+ COPTS+= -DAH_BYTE_ORDER=AH_LITTLE_ENDIAN
+-COPTS+= -ml -m4 -mno-implicit-fp
++COPTS+= -ml -m4 -m4-nofpu
diff --git a/recipes/madwifi/files/10-xscale-be-elf-copts.patch b/recipes/madwifi/files/10-xscale-be-elf-copts.patch
new file mode 100644
index 0000000000..1a08f3756e
--- /dev/null
+++ b/recipes/madwifi/files/10-xscale-be-elf-copts.patch
@@ -0,0 +1,10 @@
+--- madwifi.orig/hal/public/xscale-be-elf.inc 2007-01-03 23:42:09.000000000 -0600
++++ madwifi/hal/public/xscale-be-elf.inc 2007-01-03 23:48:50.000000000 -0600
+@@ -77,5 +77,5 @@
+
+ LDOPTS= -EB
+ COPTS+= -DAH_BYTE_ORDER=AH_BIG_ENDIAN
+-COPTS+= -march=armv4 -mbig-endian -fno-strict-aliasing -fno-common -mapcs-32 \
+- -mtune=xscale -mshort-load-bytes
++COPTS+= -march=armv4 -mbig-endian -fno-strict-aliasing -fno-common \
++ -mtune=xscale
diff --git a/recipes/madwifi/files/10-xscale-le-elf-copts.patch b/recipes/madwifi/files/10-xscale-le-elf-copts.patch
new file mode 100644
index 0000000000..c4d9937220
--- /dev/null
+++ b/recipes/madwifi/files/10-xscale-le-elf-copts.patch
@@ -0,0 +1,8 @@
+--- madwifi.orig/hal/public/xscale-le-elf.inc 2007-01-03 23:42:06.000000000 -0600
++++ madwifi/hal/public/xscale-le-elf.inc 2007-01-03 23:48:50.000000000 -0600
+@@ -79,4 +79,4 @@
+ LDOPTS= -EL
+ COPTS+= -DAH_BYTE_ORDER=AH_LITTLE_ENDIAN
+ COPTS+= -march=armv4 -mlittle-endian -fno-strict-aliasing -fno-common \
+- -mapcs-32 -mtune=xscale -mshort-load-bytes
++ -mtune=xscale
diff --git a/recipes/madwifi/files/20-xscale-VFP-wackelf-v2.patch b/recipes/madwifi/files/20-xscale-VFP-wackelf-v2.patch
new file mode 100644
index 0000000000..ed805575ba
--- /dev/null
+++ b/recipes/madwifi/files/20-xscale-VFP-wackelf-v2.patch
@@ -0,0 +1,20 @@
+--- madwifi-trunk-r3837-20080802/ath_hal/Makefile.orig 2008-09-06 22:23:21.000000000 -0500
++++ madwifi-trunk-r3837-20080802/ath_hal/Makefile 2008-09-06 22:29:50.000000000 -0500
+@@ -82,12 +82,16 @@ endif
+ quiet_cmd_uudecode = UUDECODE $@
+ cmd_uudecode = $(obj)/uudecode -o $@ $<
+
+-$(filter-out ./,$(obj)/)$(HALBIN): $(HAL)/public/$(TARGET).hal.o.uu $(obj)/uudecode
++$(obj)/wackelf: $(HAL)/public/wackelf.c
++ $(HOSTCC) $(HOSTCFLAGS) -o $@ $<
++
++$(filter-out ./,$(obj)/)$(HALBIN): $(HAL)/public/$(TARGET).hal.o.uu $(obj)/uudecode $(obj)/wackelf
+ ifdef LINUX24
+ $(cmd_uudecode)
+ else
+ $(call if_changed,uudecode)
+ endif
++ $(obj)/wackelf -fpa $@
+
+ # Replace as many hashed names as possible with meaningful
+ # ones in the symbol table of the binary kernel module for HAL.
diff --git a/recipes/madwifi/files/20-xscale-VFP-wackelf.patch b/recipes/madwifi/files/20-xscale-VFP-wackelf.patch
new file mode 100644
index 0000000000..a47eed79e7
--- /dev/null
+++ b/recipes/madwifi/files/20-xscale-VFP-wackelf.patch
@@ -0,0 +1,20 @@
+--- madwifi.orig/ath_hal/Makefile 2007-01-03 23:44:10.000000000 -0600
++++ madwifi/ath_hal/Makefile 2007-01-03 23:47:55.000000000 -0600
+@@ -81,12 +81,16 @@
+ quiet_cmd_uudecode = UUDECODE $@
+ cmd_uudecode = $(obj)/uudecode -o $@ $<
+
+-$(obj)/$(TARGET).hal.o: $(HAL)/public/$(TARGET).hal.o.uu $(obj)/uudecode
++$(obj)/wackelf: $(HAL)/public/wackelf.c
++ $(HOSTCC) $(HOSTCFLAGS) -o $@ $<
++
++$(obj)/$(TARGET).hal.o: $(HAL)/public/$(TARGET).hal.o.uu $(obj)/uudecode $(obj)/wackelf
+ ifdef LINUX24
+ $(Q)$(obj)/uudecode -o $@ $<
+ else
+ $(call if_changed,uudecode)
+ endif
++ $(Q)$(obj)/wackelf -fpa $@
+
+ install:
+ test -d $(DESTDIR)/$(KMODPATH) || mkdir -p $(DESTDIR)/$(KMODPATH)
diff --git a/recipes/madwifi/files/30-define-ioreadwrite32be-for-little-endian-too.patch b/recipes/madwifi/files/30-define-ioreadwrite32be-for-little-endian-too.patch
new file mode 100644
index 0000000000..3752a554cd
--- /dev/null
+++ b/recipes/madwifi/files/30-define-ioreadwrite32be-for-little-endian-too.patch
@@ -0,0 +1,13 @@
+Reported as http://madwifi.org/ticket/1783 ...
+
+--- madwifi-ng-r3314-20080131/ath_hal/ah_os.h~ 2007-11-23 20:08:18.000000000 +1030
++++ madwifi-ng-r3314-20080131/ath_hal/ah_os.h 2008-02-11 23:12:11.000000000 +1030
+@@ -168,7 +168,7 @@
+ * for the second time, so the native implementations should be preferred.
+ */
+ #if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,12)) && \
+- !defined(CONFIG_GENERIC_IOMAP) && (AH_BYTE_ORDER == AH_BIG_ENDIAN) && \
++ !defined(CONFIG_GENERIC_IOMAP) && \
+ !defined(__mips__) && !defined(__hppa__) && !defined(__powerpc__)
+ # ifndef iowrite32be
+ # define iowrite32be(_val, _addr) iowrite32(swab32((_val)), (_addr))