aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/makeself
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/makeself
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/makeself')
-rw-r--r--recipes/makeself/makeself-native_cvs.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes/makeself/makeself-native_cvs.bb b/recipes/makeself/makeself-native_cvs.bb
new file mode 100644
index 0000000000..47f6ef2f15
--- /dev/null
+++ b/recipes/makeself/makeself-native_cvs.bb
@@ -0,0 +1,16 @@
+SECTION = "devel"
+DESCRIPTION = "makeself.sh is a small shell script that generates a \
+self-extractable tar.gz archive from a directory. The resulting file \
+appears as a shell script (many of those have a .run suffix), and \
+can be launched as is. The archive will then uncompress itself to a \
+temporary directory and an optional arbitrary command will be executed \
+(for example an installation script)."
+LICENSE = "GPL"
+SRC_URI = "cvs://anonymous:anonymous@cvs.icculus.org/cvs/cvsroot;module=loki_setup/makeself"
+S = "${WORKDIR}/makeself"
+
+inherit native
+
+do_stage() {
+ install -m 0755 makeself.sh makeself-header.sh ${STAGING_BINDIR}/
+}