aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mamona
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-04-12 16:35:00 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-04-12 16:51:36 +0200
commit1699e27f6642a97adf23fafc74fd6ccc9d5d3d55 (patch)
tree539b8259dd387cc00ddb10be2a297b6b29e0972a /recipes/mamona
parent0a2d1e13ec1cc334aaa5dfd6be7a668723388279 (diff)
downloadopenembedded-1699e27f6642a97adf23fafc74fd6ccc9d5d3d55.tar.gz
recipes: add missing checksums
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/mamona')
-rw-r--r--recipes/mamona/cx3110x-770he_0.8.1.bb13
-rw-r--r--recipes/mamona/cx3110x-chinooke_2.0.15.bb17
-rw-r--r--recipes/mamona/cx3110x-diablo_2.0.15.bb13
-rw-r--r--recipes/mamona/uinput_2.6.21.bb54
4 files changed, 86 insertions, 11 deletions
diff --git a/recipes/mamona/cx3110x-770he_0.8.1.bb b/recipes/mamona/cx3110x-770he_0.8.1.bb
index 8e78ccf208..781a0546e0 100644
--- a/recipes/mamona/cx3110x-770he_0.8.1.bb
+++ b/recipes/mamona/cx3110x-770he_0.8.1.bb
@@ -10,9 +10,9 @@ SKERNEL = "${WORKDIR}/kernel-source-${KERVER}"
# The following require must be after S{S}, ${SKERNEL}, ${KERVER}
require cx3110x.inc
-SRC_URI += "https://garage.maemo.org/frs/download.php/2443/cx3110x-0.8.1.tar.gz \
- http://www.codesourcery.com/public/gnu_toolchain/arm-none-eabi/arm-2005q3-2-arm-none-eabi-i686-pc-linux-gnu.tar.bz2 \
- http://dev.openbossa.org/mamona/sources/kernel-source-${KERVER}.tar.gz \
+SRC_URI += "https://garage.maemo.org/frs/download.php/2443/cx3110x-0.8.1.tar.gz;name=archive \
+ http://www.codesourcery.com/public/gnu_toolchain/arm-none-eabi/arm-2005q3-2-arm-none-eabi-i686-pc-linux-gnu.tar.bz2;name=arm \
+ http://dev.openbossa.org/mamona/sources/kernel-source-${KERVER}.tar.gz;name=kernel \
file://defconfig \
file://fix_mem_corruption.patch;patch=1 \
file://fix_mem_allign.patch;patch=1 \
@@ -24,6 +24,13 @@ SRC_URI += "https://garage.maemo.org/frs/download.php/2443/cx3110x-0.8.1.tar.gz
file://fix_opps_while_connecting_with_nm.patch;patch=1 \
"
+SRC_URI[archive.md5sum] = "85c115a81fa4429bee2cd16bfe961d44"
+SRC_URI[archive.sha256sum] = "8fcdeb785c94a7f2408c0a0dd365db6b1a01347e386bb68ffa1886c1f62239db"
+SRC_URI[arm.md5sum] = "1709df05ed8572c6d2457af0076b867c"
+SRC_URI[arm.sha256sum] = "dd754383ae40bbdc9917f26deae6d6aaff4060d7be79b5d6c3f7f5c6f98cfadc"
+SRC_URI[kernel.md5sum] = "23845bce13640ea14183e29e4dc968cc"
+SRC_URI[kernel.sha256sum] = "d3985217367845f3b7725e522d24d109d00c087037f1512e17b4c6c815656fd4"
+
do_compile() {
cp ${WORKDIR}/defconfig ${SKERNEL}/.config
KERNEL_SRC_DIR=${SKERNEL} PATH=${WORKDIR}/bin/:$PATH CROSS_COMPILE=arm-none-eabi- make modules
diff --git a/recipes/mamona/cx3110x-chinooke_2.0.15.bb b/recipes/mamona/cx3110x-chinooke_2.0.15.bb
index 50de7460fe..24536a9671 100644
--- a/recipes/mamona/cx3110x-chinooke_2.0.15.bb
+++ b/recipes/mamona/cx3110x-chinooke_2.0.15.bb
@@ -11,15 +11,24 @@ SKERNEL = "${WORKDIR}/kernel-source-rx-34-2.6.21.0"
require cx3110x.inc
SRC_URI += "\
- http://repository.maemo.org/pool/maemo4.1/free/c/cx3110x-module-src/cx3110x-module-src_2.0.15-1.tar.gz \
- http://www.codesourcery.com/public/gnu_toolchain/arm-none-eabi/arm-2005q3-2-arm-none-eabi-i686-pc-linux-gnu.tar.bz2 \
- http://repository.maemo.org/pool/chinook/free/k/kernel-source-rx-34/kernel-source-rx-34_2.6.21.0.orig.tar.gz \
- http://repository.maemo.org/pool/chinook/free/k/kernel-source-rx-34/kernel-source-rx-34_2.6.21.0-osso71.diff.gz \
+ http://repository.maemo.org/pool/maemo4.1/free/c/cx3110x-module-src/cx3110x-module-src_2.0.15-1.tar.gz;name=archive \
+ http://www.codesourcery.com/public/gnu_toolchain/arm-none-eabi/arm-2005q3-2-arm-none-eabi-i686-pc-linux-gnu.tar.bz2;name=arm \
+ http://repository.maemo.org/pool/chinook/free/k/kernel-source-rx-34/kernel-source-rx-34_2.6.21.0.orig.tar.gz;name=kernel \
+ http://repository.maemo.org/pool/chinook/free/k/kernel-source-rx-34/kernel-source-rx-34_2.6.21.0-osso71.diff.gz;name=kernelpatch \
file://cx3110x.patch;patch=1 \
file://create_sysfs_link_for_wlan0.patch;patch=1 \
file://fix_old_include.patch;patch=1 \
"
+SRC_URI[archive.md5sum] = "6ac5db5e602ef205200428a6612b4036"
+SRC_URI[archive.sha256sum] = "20416248378cb42cb294584d9c5e4359d3d309ab8e104d62b09848f88bc7fe10"
+SRC_URI[arm.md5sum] = "1709df05ed8572c6d2457af0076b867c"
+SRC_URI[arm.sha256sum] = "dd754383ae40bbdc9917f26deae6d6aaff4060d7be79b5d6c3f7f5c6f98cfadc"
+SRC_URI[kernel.md5sum] = "5f486ccc78c3f4c378a831a6b791961c"
+SRC_URI[kernel.sha256sum] = "e445c3ad44d5b3c934a877c8d24d0e674d9bae914f08151caf9882af9cd3e62d"
+SRC_URI[kernelpatch.md5sum] = "f2a893efdc2712b70ee8fbb65da2a70e"
+SRC_URI[kernelpatch.sha256sum] = "f219303e60f81b3cf6206b6c1851bd42069bd018ed18482ab04dded0b4339f8a"
+
do_compile() {
cd ${SKERNEL}
patch -p1 < ${WORKDIR}/kernel-source-rx-34_2.6.21.0-osso71.diff
diff --git a/recipes/mamona/cx3110x-diablo_2.0.15.bb b/recipes/mamona/cx3110x-diablo_2.0.15.bb
index 17bb1f4412..73e684c54c 100644
--- a/recipes/mamona/cx3110x-diablo_2.0.15.bb
+++ b/recipes/mamona/cx3110x-diablo_2.0.15.bb
@@ -11,14 +11,21 @@ SKERNEL = "${WORKDIR}/kernel-source-diablo-${KERVER}/kernel-source"
require cx3110x.inc
SRC_URI += "\
- http://repository.maemo.org/pool/maemo4.1/free/c/cx3110x-module-src/cx3110x-module-src_2.0.15-1.tar.gz \
- http://www.codesourcery.com/public/gnu_toolchain/arm-none-eabi/arm-2005q3-2-arm-none-eabi-i686-pc-linux-gnu.tar.bz2 \
- http://repository.maemo.org/pool/maemo4.1/free/k/kernel-source-diablo/kernel-source-diablo_2.6.21-200823maemo6.tar.gz \
+ http://repository.maemo.org/pool/maemo4.1/free/c/cx3110x-module-src/cx3110x-module-src_2.0.15-1.tar.gz;name=archive \
+ http://www.codesourcery.com/public/gnu_toolchain/arm-none-eabi/arm-2005q3-2-arm-none-eabi-i686-pc-linux-gnu.tar.bz2;name=arm \
+ http://repository.maemo.org/pool/maemo4.1/free/k/kernel-source-diablo/kernel-source-diablo_2.6.21-200823maemo6.tar.gz;name=kernel \
file://cx3110x.patch;patch=1 \
file://create_sysfs_link_for_wlan0.patch;patch=1 \
file://fix_old_include.patch;patch=1 \
"
+SRC_URI[archive.md5sum] = "6ac5db5e602ef205200428a6612b4036"
+SRC_URI[archive.sha256sum] = "20416248378cb42cb294584d9c5e4359d3d309ab8e104d62b09848f88bc7fe10"
+SRC_URI[arm.md5sum] = "1709df05ed8572c6d2457af0076b867c"
+SRC_URI[arm.sha256sum] = "dd754383ae40bbdc9917f26deae6d6aaff4060d7be79b5d6c3f7f5c6f98cfadc"
+SRC_URI[kernel.md5sum] = "e1108e92bd0b6bed0bcc375bbfb4e45c"
+SRC_URI[kernel.sha256sum] = "0f2c8307d67e17f682f73a6f801021f74fb9da5a5a8d49084879945ee91b3e90"
+
do_compile() {
PATH=${WORKDIR}/bin/:$PATH make -C ${SKERNEL} CROSS_COMPILE=arm-none-eabi- nokia_2420_defconfig prepare scripts
KERNEL_SRC_DIR=${SKERNEL} PATH=${WORKDIR}/bin/:$PATH CROSS_COMPILE=arm-none-eabi- make modules
diff --git a/recipes/mamona/uinput_2.6.21.bb b/recipes/mamona/uinput_2.6.21.bb
index c2ec71dab2..8877146b62 100644
--- a/recipes/mamona/uinput_2.6.21.bb
+++ b/recipes/mamona/uinput_2.6.21.bb
@@ -1,3 +1,4 @@
+<<<<<<< HEAD
DESCRIPTION = "uinput support to Nokia 770/8*0 using Nokia kernel"
SECTION = "kernel/modules"
LICENSE = "GPL"
@@ -40,4 +41,55 @@ do_install() {
pkg_postinst () {
update-rc.d uinput defaults 10
-} \ No newline at end of file
+}
+=======
+DESCRIPTION = "uinput support to Nokia 770/8*0 using Nokia kernel"
+SECTION = "kernel/modules"
+LICENSE = "GPL"
+PR = "r0"
+
+PACKAGES = "${PN}"
+
+FILES_${PN} += "/lib/modules/uinput.ko /etc/init.d/uinput"
+
+COMPATIBLE_MACHINE = "(nokia770|nokia800)"
+
+SRC_URI = "http://www.codesourcery.com/public/gnu_toolchain/arm-none-eabi/arm-2005q3-2-arm-none-eabi-i686-pc-linux-gnu.tar.bz2;name=arm \
+ http://dev.openbossa.org/mamona/sources/kernel-source-rx-34_2.6.21.0.tar.gz;name=kernel \
+ file://defconfig \
+ file://uinput \
+"
+
+SRC_URI[arm.md5sum] = "1709df05ed8572c6d2457af0076b867c"
+SRC_URI[arm.sha256sum] = "dd754383ae40bbdc9917f26deae6d6aaff4060d7be79b5d6c3f7f5c6f98cfadc"
+SRC_URI[kernel.md5sum] = "cadab6847034b8d305c9b876211220c4"
+SRC_URI[kernel.sha256sum] = "66640580fbb4bc34ecec45a00fe08ff330aa501407556921a345bec5e1921e36"
+
+
+LDFLAGS=""
+BUILD_LDFLAGS=""
+CFLAGS=""
+BUILD_CFLAGS=""
+TARGET_LDFLAGS=""
+
+S = "${WORKDIR}/kernel-source-rx-34-2.6.21.0"
+
+do_configure() {
+}
+
+do_compile() {
+ cp ${WORKDIR}/defconfig ${S}/.config
+ PATH=${WORKDIR}/bin/:$PATH CROSS_COMPILE=arm-none-eabi- make modules
+}
+
+do_install() {
+ install -d ${D}/lib/modules/
+ install -m 0644 ${S}/drivers/input/misc/uinput.ko ${D}/lib/modules/
+ install -d ${D}/etc/init.d/
+ install -m 0755 ${WORKDIR}/uinput ${D}/etc/init.d/
+}
+
+pkg_postinst () {
+ update-rc.d uinput defaults 10
+}
+>>>>>>> b6d0763... recipes: add missing checksums