summaryrefslogtreecommitdiffstats
path: root/recipes/maradns/files
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/maradns/files
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/maradns/files')
-rwxr-xr-xrecipes/maradns/files/init35
-rw-r--r--recipes/maradns/files/rng-makefile-build-cc.patch11
2 files changed, 46 insertions, 0 deletions
diff --git a/recipes/maradns/files/init b/recipes/maradns/files/init
new file mode 100755
index 0000000000..0e4d1b8418
--- /dev/null
+++ b/recipes/maradns/files/init
@@ -0,0 +1,35 @@
+PATH=/sbin:/bin:/usr/sbin:/usr/bin
+DAEMON=/usr/sbin/maradns
+NAME="maradns"
+DESC="DNS server"
+CONF="/etc/maradns/mararc"
+
+test -f $DAEMON || exit 0
+
+set -e
+
+case "$1" in
+ start)
+ echo -n "Starting $DESC: "
+ start-stop-daemon -S -x $DAEMON -- -f $CONF 2>&1 | logger -p daemon.notice -t $NAME &
+ echo "$NAME."
+ ;;
+ stop)
+ echo -n "Stopping $DESC: "
+ start-stop-daemon -K -x $DAEMON
+ echo "$NAME."
+ ;;
+ restart)
+ echo -n "Restarting $DESC: "
+ $0 stop
+ sleep 3
+ $0 start
+ ;;
+ *)
+ N=/etc/init.d/$NAME
+ echo "Usage: $N {start|stop|restart}" >&2
+ exit 1
+ ;;
+esac
+
+exit 0
diff --git a/recipes/maradns/files/rng-makefile-build-cc.patch b/recipes/maradns/files/rng-makefile-build-cc.patch
new file mode 100644
index 0000000000..55f95ab1cd
--- /dev/null
+++ b/recipes/maradns/files/rng-makefile-build-cc.patch
@@ -0,0 +1,11 @@
+--- rng/Makefile.orig 2004-09-24 16:10:44.550378128 +0200
++++ rng/Makefile 2004-09-24 16:11:02.147702928 +0200
+@@ -20,7 +20,7 @@
+ $(CC) -c $(FLAGS) -o rng-api-fst.o rng-api-fst.c
+
+ make_32bit_tables: make_32bit_tables.c
+- $(CC) -o make_32bit_tables make_32bit_tables.c
++ $(BUILD_CC) -o make_32bit_tables make_32bit_tables.c
+
+ rng-32bit-tables.h: make_32bit_tables
+ ./make_32bit_tables > rng-32bit-tables.h