aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/masqmail
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/masqmail
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/masqmail')
-rw-r--r--recipes/masqmail/masqmail_0.2.21.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/masqmail/masqmail_0.2.21.bb b/recipes/masqmail/masqmail_0.2.21.bb
new file mode 100644
index 0000000000..05f377e4e5
--- /dev/null
+++ b/recipes/masqmail/masqmail_0.2.21.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "MasqMail is a mail server designed for hosts that do not have \
+a permanent internet connection eg. a home network or a single host at home. \
+It has special support for connections to different ISPs. It replaces sendmail \
+or other MTAs such as qmail or exim."
+HOMEPAGE = "http://innominate.org/kurth/masqmail/"
+SECTION = "console/network"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "glib-2.0"
+
+SRC_URI = "${DEBIAN_MIRROR}/main/m/${PN}/${PN}_${PV}.orig.tar.gz"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF += "--disable-glibtest"
+EXTRA_OECONF += "--disable-resolver"
+
+# These are the standard Debian values for ownership of the programs,
+# this stuff fakes out the install script chown operations then replicates
+# them by setting the ipkg owner/group to the desired values - everything
+# ends up owned by the nominated user.
+MAIL_USER ?= "mail"
+MAIL_GROUP ?= "mail"
+
+EXTRA_OECONF += "--with-user=$(id -u)"
+EXTRA_OECONF += "--with-group=$(id -g)"
+
+IPKGBUILDCMD = "ipkg-build -o ${MAIL_USER} -g ${MAIL_GROUP}"