aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/matchbox-applet-tasks
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/matchbox-applet-tasks
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/matchbox-applet-tasks')
-rw-r--r--recipes/matchbox-applet-tasks/mb-applet-tasks_1.0.0.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes/matchbox-applet-tasks/mb-applet-tasks_1.0.0.bb b/recipes/matchbox-applet-tasks/mb-applet-tasks_1.0.0.bb
new file mode 100644
index 0000000000..6193067bfa
--- /dev/null
+++ b/recipes/matchbox-applet-tasks/mb-applet-tasks_1.0.0.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "Tasks applet switcher for matchbox"
+LICENSE = "GPLv2"
+DEPENDS = "gtk+ libwnck libmatchbox"
+
+PR = "r1"
+
+CFLAGS += "-I${STAGING_INCDIR} \
+ -I${STAGING_INCDIR}/gtk-2.0 \
+ -I${STAGING_INCDIR}/glib-2.0 \
+ -I${STAGING_INCDIR}/freetype2 \
+ -I${STAGING_INCDIR}/atk-1.0 \
+ -I${STAGING_INCDIR}/libwnck-1.0 \
+ -I${STAGING_LIBDIR}/gtk-2.0/include \
+ -I${STAGING_INCDIR}/cairo \
+ -DWNCK_I_KNOW_THIS_IS_UNSTABLE"
+
+SRC_URI = "http://www.pdaxrom.org/download/1.1.0beta4/src/${P}.tar.bz2"
+
+do_install() {
+install -d ${D}/${datadir}/applications
+install -d ${D}/${bindir}
+
+install -m 755 mb-applet-tasks ${D}/${bindir}
+install -m 644 mb-applet-tasks.desktop ${D}/${datadir}/applications
+}
+
+
+
+
+
+