aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/matchbox-session/matchbox-session.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@koansoftware.com>2009-08-28 18:38:53 +0200
committerMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>2009-08-28 18:45:25 +0200
commitedc60166ad6d3d9192fe5a60dfa2ead6ef5a9d5d (patch)
treeac5075ecd9fda425e87165c0aba76c63469431e7 /recipes/matchbox-session/matchbox-session.bb
parent862583337c19466ea4dd685d141b62fc722e63a1 (diff)
downloadopenembedded-edc60166ad6d3d9192fe5a60dfa2ead6ef5a9d5d.tar.gz
matchbox-session: simple provider of Matchbox session for X11 startup
In GPE images we use gpe-session-scripts to provide Xsession init scripts for launching Matchbox components. But what if someone do not want GPE but want Matchbox? Poky has it cleaned in other way.
Diffstat (limited to 'recipes/matchbox-session/matchbox-session.bb')
-rw-r--r--recipes/matchbox-session/matchbox-session.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/recipes/matchbox-session/matchbox-session.bb b/recipes/matchbox-session/matchbox-session.bb
new file mode 100644
index 0000000000..c9014f9000
--- /dev/null
+++ b/recipes/matchbox-session/matchbox-session.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "Matchbox session support"
+RDEPENDS = "matchbox-common"
+# they do the same in other way
+RCONFLICTS = "gpe-session-scripts"
+
+do_install() {
+ install -d ${D}${sysconfdir}/X11/Xsession.d/
+ ln -sf ${bindir}/matchbox-session ${D}${sysconfdir}/X11/Xsession.d/90matchbox-session
+}
+
+PACKAGE_ARCH = "all"
+PACKAGES = "${PN}"
+
+FILES_${PN} = "${sysconfdir}"