aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/matchbox-wm
diff options
context:
space:
mode:
authorStanislav Brabec <utx@penguin.cz>2009-09-19 21:30:06 +0000
committerutx@penguin.cz <utx@penguin.cz>2009-09-19 21:30:06 +0000
commit103e2071354d88a1fd6ea34469fd972123350b72 (patch)
tree62beea575c4412f76b3c9e6cb2235ef027724d0a /recipes/matchbox-wm
parentfdbb57d061fab29f3517b43b96e0e16a2bd77902 (diff)
downloadopenembedded-103e2071354d88a1fd6ea34469fd972123350b72.tar.gz
matchbox-wm: Easy fix for crash when clicking on the app switcher (openedhand#1343).
Diffstat (limited to 'recipes/matchbox-wm')
-rw-r--r--recipes/matchbox-wm/matchbox-wm/select-client-crash.patch14
-rw-r--r--recipes/matchbox-wm/matchbox-wm_1.2.bb3
2 files changed, 16 insertions, 1 deletions
diff --git a/recipes/matchbox-wm/matchbox-wm/select-client-crash.patch b/recipes/matchbox-wm/matchbox-wm/select-client-crash.patch
new file mode 100644
index 0000000000..0af225b471
--- /dev/null
+++ b/recipes/matchbox-wm/matchbox-wm/select-client-crash.patch
@@ -0,0 +1,14 @@
+http://bugzilla.openedhand.com/show_bug.cgi?id=1343
+Index: matchbox-window-manager-1.2/src/select_client.c
+===================================================================
+--- matchbox-window-manager-1.2.orig/src/select_client.c
++++ matchbox-window-manager-1.2/src/select_client.c
+@@ -49,6 +49,8 @@ select_client_new(Wm *w)
+
+ if (width == 0 || height == 0) return NULL;
+
++ if (w->stack_top_app == NULL) return NULL;
++
+ dbg("%s() got valid size\n", __func__);
+
+ button_x = theme_frame_button_get_x_pos(w->mbtheme, FRAME_MAIN,
diff --git a/recipes/matchbox-wm/matchbox-wm_1.2.bb b/recipes/matchbox-wm/matchbox-wm_1.2.bb
index 36ddae3c7c..afa26e67a2 100644
--- a/recipes/matchbox-wm/matchbox-wm_1.2.bb
+++ b/recipes/matchbox-wm/matchbox-wm_1.2.bb
@@ -3,10 +3,11 @@ require matchbox-wm.inc
DEPENDS = "libmatchbox virtual/libx11 libxext libxcomposite libxfixes libxdamage libxrender startup-notification expat gconf gconf-native "
RDEPENDS = ""
-PR ="r4"
+PR ="r5"
SRC_URI = "http://matchbox-project.org/sources/matchbox-window-manager/1.2/matchbox-window-manager-${PV}.tar.bz2 \
file://configure_fix.patch;patch=1 \
+ file://select-client-crash.patch;patch=1 \
file://gconf-2.m4 \
file://kbdconfig"