summaryrefslogtreecommitdiffstats
path: root/recipes/matchbox2/matchbox-panel-2_svn.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/matchbox2/matchbox-panel-2_svn.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/matchbox2/matchbox-panel-2_svn.bb')
-rw-r--r--recipes/matchbox2/matchbox-panel-2_svn.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/matchbox2/matchbox-panel-2_svn.bb b/recipes/matchbox2/matchbox-panel-2_svn.bb
new file mode 100644
index 0000000000..79fafff202
--- /dev/null
+++ b/recipes/matchbox2/matchbox-panel-2_svn.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "matchbox-panel-2 is a lightweight dock (system tray) application based on Gtk+"
+LICENSE = "GPL"
+SECTION = "x11/panels"
+DEPENDS = "gtk+ apmd startup-notification"
+PV = "0.1+svnr${SRCREV}"
+PR = "r8"
+
+SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=${PN};proto=http"
+S = "${WORKDIR}/${PN}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--enable-startup-notification --disable-libnotify"
+
+# matchbox-<anything>-2 aims to replace their -1 counterpart, but at this point in time it's unfinished and unusable, so make it parallel installable
+do_install_append() {
+ mv ${D}${bindir}/matchbox-panel ${D}${bindir}/matchbox-panel-2
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+PACKAGES += "${PN}-applets"
+FILES_${PN}-applets = "${libdir}/matchbox-panel/lib*.so* ${datadir}/*"
+FILES_${PN}-dev += "${libdir}/matchbox-panel/lib*.a ${libdir}/matchbox-panel/lib*.la"
+