aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/matchbox2/matchbox-wm-2_svn.bb
diff options
context:
space:
mode:
authorStanislav Brabec <utx@penguin.cz>2009-09-22 23:36:32 +0000
committerutx@penguin.cz <utx@penguin.cz>2009-09-22 23:36:32 +0000
commit3bcf3726467d678126952436b80f4a10c2184c4d (patch)
treedec42459f0732cb88b54aac55afd7ac8431d5c4e /recipes/matchbox2/matchbox-wm-2_svn.bb
parent1e4dc820bb189c367daddd07643c0146122823c0 (diff)
downloadopenembedded-3bcf3726467d678126952436b80f4a10c2184c4d.tar.gz
matchbox2: Make it working:
* fixed known crashers * created usable icon theme * provided session script
Diffstat (limited to 'recipes/matchbox2/matchbox-wm-2_svn.bb')
-rw-r--r--recipes/matchbox2/matchbox-wm-2_svn.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/matchbox2/matchbox-wm-2_svn.bb b/recipes/matchbox2/matchbox-wm-2_svn.bb
new file mode 100644
index 0000000000..e5aefc02ab
--- /dev/null
+++ b/recipes/matchbox2/matchbox-wm-2_svn.bb
@@ -0,0 +1,22 @@
+DEPENDS = "gtk+ startup-notification dbus dbus-glib"
+PV = "0.1.0+svnr${SRCREV}"
+PR = "r0"
+
+SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=matchbox-window-manager-2;proto=http \
+ file://fix-timeout-handler-free.patch;patch=1 \
+ file://makefile-vars.patch;patch=1;pnum=0 \
+"
+S = "${WORKDIR}/matchbox-window-manager-2"
+
+inherit autotools pkgconfig
+
+# FIXME: --enable-glib-main-loop causes hard grab-freeze
+EXTRA_OECONF = "--with-gtk --with-pango --enable-matchbox-remote --enable-png-theme --enable-maemo-manager"
+
+do_install_append() {
+ mv ${D}${bindir}/matchbox-remote ${D}${bindir}/matchbox-remote-2
+ # Without libmatchbox there are no includes and no libraries, just empty directories:
+ rm -r ${D}${includedir} ${D}${libdir}
+}
+
+FILES_${PN} += "${datadir}/themes/*"