aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/matchbox2
diff options
context:
space:
mode:
authorStanislav Brabec <utx@penguin.cz>2009-10-08 18:47:30 +0000
committerutx@penguin.cz <utx@penguin.cz>2009-10-08 18:47:30 +0000
commit6cb4ec0ce54893315e1822c02581246e915aaea7 (patch)
tree6722cc9cd7d2181c2fd7f42661704b2ede74000e /recipes/matchbox2
parent8b1f4dc04f9d81a78b741d0f90f0fc9e0f31bb1f (diff)
downloadopenembedded-6cb4ec0ce54893315e1822c02581246e915aaea7.tar.gz
matchbox-desktop-2: Make fallback folder compatible with current matchbox-common.
Diffstat (limited to 'recipes/matchbox2')
-rw-r--r--recipes/matchbox2/matchbox-desktop-2/fallback-folder.patch15
-rw-r--r--recipes/matchbox2/matchbox-desktop-2_svn.bb8
2 files changed, 19 insertions, 4 deletions
diff --git a/recipes/matchbox2/matchbox-desktop-2/fallback-folder.patch b/recipes/matchbox2/matchbox-desktop-2/fallback-folder.patch
new file mode 100644
index 0000000000..2d3b9f9a57
--- /dev/null
+++ b/recipes/matchbox2/matchbox-desktop-2/fallback-folder.patch
@@ -0,0 +1,15 @@
+matchbox-desktop-2 wants "meta-fallback", but matchbox-common-0.9.x
+defines "fallback" and there is no matchbox-common-2.
+Index: libtaku/taku-menu-desktop.c
+===================================================================
+--- libtaku/taku-menu-desktop.c (revision 2096)
++++ libtaku/taku-menu-desktop.c (working copy)
+@@ -239,7 +239,7 @@
+ /* Find a fallback category */
+ if (priv->fallback_category == NULL)
+ for (l = matches; *l; l++)
+- if (strcmp (*l, "meta-fallback") == 0)
++ if (strcmp (*l, "fallback") == 0)
+ priv->fallback_category = category;
+
+ done:
diff --git a/recipes/matchbox2/matchbox-desktop-2_svn.bb b/recipes/matchbox2/matchbox-desktop-2_svn.bb
index 21581e911b..f0261f9ea1 100644
--- a/recipes/matchbox2/matchbox-desktop-2_svn.bb
+++ b/recipes/matchbox2/matchbox-desktop-2_svn.bb
@@ -4,13 +4,13 @@ SECTION = "x11/panels"
DEPENDS = "gtk+ startup-notification"
RDEPENDS = "matchbox-common"
PV = "2.0+svnr${SRCREV}"
-PR = "r0"
+PR = "r1"
inherit autotools_stage pkgconfig
-SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=${PN};proto=http"
+SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=${PN};proto=http \
+ file://fallback-folder.patch;patch=1;pnum=0 \
+"
S = "${WORKDIR}/${PN}"
-#PARALLEL_MAKE = ""
-
EXTRA_OECONF = "--program-transform-name='s/$/-2/'"