aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/matchbox2
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/matchbox2
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/matchbox2')
-rw-r--r--recipes/matchbox2/files/glib-2.8-backport.patch110
-rw-r--r--recipes/matchbox2/matchbox-desktop-2_svn.bb27
-rw-r--r--recipes/matchbox2/matchbox-panel-2_svn.bb27
3 files changed, 164 insertions, 0 deletions
diff --git a/recipes/matchbox2/files/glib-2.8-backport.patch b/recipes/matchbox2/files/glib-2.8-backport.patch
new file mode 100644
index 0000000000..339477de70
--- /dev/null
+++ b/recipes/matchbox2/files/glib-2.8-backport.patch
@@ -0,0 +1,110 @@
+Index: matchbox-panel-2/applets/windowselector/windowselector.c
+===================================================================
+--- matchbox-panel-2.orig/applets/windowselector/windowselector.c 2007-01-24 19:24:27.000000000 +0100
++++ matchbox-panel-2/applets/windowselector/windowselector.c 2007-01-25 02:34:21.000000000 +0100
+@@ -56,7 +56,7 @@
+ applet);
+ }
+
+- g_slice_free (WindowSelectorApplet, applet);
++ g_free (applet);
+ }
+
+ /* Retrieves the UTF-8 property @atom from @window */
+@@ -673,7 +673,7 @@
+ GtkWidget *menu_bar, *menu_item, *image;
+
+ /* Create applet data structure */
+- applet = g_slice_new (WindowSelectorApplet);
++ applet = g_new (WindowSelectorApplet,1);
+
+ applet->root_window = NULL;
+ applet->menu = NULL;
+Index: matchbox-panel-2/applets/battery/battery.c
+===================================================================
+--- matchbox-panel-2.orig/applets/battery/battery.c 2007-01-24 19:24:28.000000000 +0100
++++ matchbox-panel-2/applets/battery/battery.c 2007-01-25 02:34:21.000000000 +0100
+@@ -24,7 +24,7 @@
+ {
+ g_source_remove (applet->timeout_id);
+
+- g_slice_free (BatteryApplet, applet);
++ g_free (applet);
+ }
+
+ /* Called every 5 minutes */
+@@ -97,7 +97,7 @@
+ }
+
+ /* Create applet data structure */
+- applet = g_slice_new (BatteryApplet);
++ applet = g_new (BatteryApplet,1);
+
+ applet->last_icon = NULL;
+
+Index: matchbox-panel-2/applets/showdesktop/showdesktop.c
+===================================================================
+--- matchbox-panel-2.orig/applets/showdesktop/showdesktop.c 2007-01-24 19:24:28.000000000 +0100
++++ matchbox-panel-2/applets/showdesktop/showdesktop.c 2007-01-25 02:34:21.000000000 +0100
+@@ -36,7 +36,7 @@
+ applet);
+ }
+
+- g_slice_free (ShowDesktopApplet, applet);
++ g_free (applet);
+ }
+
+ /* Sync @applet with the _NET_SHOWING_DESKTOP root window property */
+@@ -180,7 +180,7 @@
+ GtkWidget *button, *image;
+
+ /* Create applet data structure */
+- applet = g_slice_new (ShowDesktopApplet);
++ applet = g_new (ShowDesktopApplet,1);
+
+ applet->block_toggle = FALSE;
+ applet->root_window = NULL;
+Index: matchbox-panel-2/applets/launcher/launcher.c
+===================================================================
+--- matchbox-panel-2.orig/applets/launcher/launcher.c 2007-01-24 19:24:27.000000000 +0100
++++ matchbox-panel-2/applets/launcher/launcher.c 2007-01-25 02:35:40.000000000 +0100
+@@ -36,7 +36,7 @@
+ g_free (applet->name);
+ g_strfreev (applet->argv);
+
+- g_slice_free (LauncherApplet, applet);
++ g_free (applet);
+ }
+
+ /* Convert command line to argv array, stripping % conversions on the way */
+@@ -335,7 +335,7 @@
+ gtk_container_add (GTK_CONTAINER (event_box), image);
+
+ /* Set up applet structure */
+- applet = g_slice_new (LauncherApplet);
++ applet = g_new (LauncherApplet,1);
+
+ applet->image = GTK_IMAGE (image);
+
+Index: matchbox-panel-2/applets/clock/clock.c
+===================================================================
+--- matchbox-panel-2.orig/applets/clock/clock.c 2007-01-24 19:24:28.000000000 +0100
++++ matchbox-panel-2/applets/clock/clock.c 2007-01-25 02:35:25.000000000 +0100
+@@ -21,7 +21,7 @@
+ {
+ g_source_remove (applet->timeout_id);
+
+- g_slice_free (ClockApplet, applet);
++ g_free (applet);
+ }
+
+ /* Called every minute */
+@@ -67,7 +67,7 @@
+ struct tm *local_time;
+
+ /* Create applet data structure */
+- applet = g_slice_new (ClockApplet);
++ applet = g_new (ClockApplet,1);
+
+ /* Create label */
+ label = gtk_label_new (NULL);
diff --git a/recipes/matchbox2/matchbox-desktop-2_svn.bb b/recipes/matchbox2/matchbox-desktop-2_svn.bb
new file mode 100644
index 0000000000..8dc74ef509
--- /dev/null
+++ b/recipes/matchbox2/matchbox-desktop-2_svn.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Matchbox Window Manager Desktop"
+LICENSE = "GPL"
+SECTION = "x11/panels"
+DEPENDS = "gtk+ startup-notification"
+
+PV = "0.1+svnr${SRCREV}"
+PR = "r0"
+
+SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=${PN};proto=http"
+S = "${WORKDIR}/${PN}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--enable-startup-notification --disable-libnotify"
+
+PARALLEL_MAKE = ""
+
+# matchbox-<anything>-2 aims to replace their -1 counterpart, but at this point in time it's unfinished and unusable, so make it parallel installable
+do_install_append() {
+ mv ${D}${bindir}/matchbox-desktop ${D}${bindir}/matchbox-desktop-2
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+
diff --git a/recipes/matchbox2/matchbox-panel-2_svn.bb b/recipes/matchbox2/matchbox-panel-2_svn.bb
new file mode 100644
index 0000000000..79fafff202
--- /dev/null
+++ b/recipes/matchbox2/matchbox-panel-2_svn.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "matchbox-panel-2 is a lightweight dock (system tray) application based on Gtk+"
+LICENSE = "GPL"
+SECTION = "x11/panels"
+DEPENDS = "gtk+ apmd startup-notification"
+PV = "0.1+svnr${SRCREV}"
+PR = "r8"
+
+SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=${PN};proto=http"
+S = "${WORKDIR}/${PN}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--enable-startup-notification --disable-libnotify"
+
+# matchbox-<anything>-2 aims to replace their -1 counterpart, but at this point in time it's unfinished and unusable, so make it parallel installable
+do_install_append() {
+ mv ${D}${bindir}/matchbox-panel ${D}${bindir}/matchbox-panel-2
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+PACKAGES += "${PN}-applets"
+FILES_${PN}-applets = "${libdir}/matchbox-panel/lib*.so* ${datadir}/*"
+FILES_${PN}-dev += "${libdir}/matchbox-panel/lib*.a ${libdir}/matchbox-panel/lib*.la"
+