summaryrefslogtreecommitdiffstats
path: root/recipes/matchbox2
diff options
context:
space:
mode:
authorSebastian Spaeth <Sebastian@SSpaeth.de>2009-12-04 08:17:55 +0100
committerSebastian Spaeth <Sebastian@SSpaeth.de>2009-12-04 08:17:55 +0100
commit49d5f70658ab0386bee5869656d0405a6d416e35 (patch)
treeeb05cb5f3f5f6dcb3510032d1e8843823660d04a /recipes/matchbox2
parenta5f31b42d1dbdeb252b73cf0dd260d94de8bb4e9 (diff)
downloadopenembedded-49d5f70658ab0386bee5869656d0405a6d416e35.tar.gz
task-base: Introduce DISTRO_apm and convert recipes to use it.
* This allows distros to override the apm provider with an DISTRO_apm variable * The change should be transparent and invisible for other distros * This could also be done with a virtual/apm package, and a PREFERED_PROVIDER set to apm Signed-off-by: Sebastian Spaeth <Sebastian@SSpaeth.de>
Diffstat (limited to 'recipes/matchbox2')
-rw-r--r--recipes/matchbox2/matchbox-panel-2_svn.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/recipes/matchbox2/matchbox-panel-2_svn.bb b/recipes/matchbox2/matchbox-panel-2_svn.bb
index a2a807f28a..9d1781baa6 100644
--- a/recipes/matchbox2/matchbox-panel-2_svn.bb
+++ b/recipes/matchbox2/matchbox-panel-2_svn.bb
@@ -1,13 +1,15 @@
DESCRIPTION = "matchbox-panel-2 is a lightweight dock (system tray) application based on Gtk+"
LICENSE = "GPLv2"
SECTION = "x11/panels"
+
+DISTRO_apm ?= "apm"
DEPENDS = "gtk+ startup-notification dbus dbus-glib matchbox-panel-2-icon-themes"
DEPENDS += " ${@base_contains("MACHINE_FEATURES", "acpi", "libacpi", "",d)}"
-DEPENDS += " ${@base_contains("MACHINE_FEATURES", "apm", "apmd", "",d)}"
+DEPENDS += " ${@base_contains("MACHINE_FEATURES", "${DISTRO_apm}", "apmd", "",d)}"
RDEPENDS_${PN} = "matchbox-panel-2-icon-theme"
PACKAGE_ARCH = "${MACHINE_ARCH}"
PV = "2.0+svnr${SRCPV}"
-PR = "r0"
+PR = "r1"
inherit autotools_stage pkgconfig