aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/matrixssl
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/matrixssl
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/matrixssl')
-rw-r--r--recipes/matrixssl/matrixssl-1.1.1/cross.patch55
-rw-r--r--recipes/matrixssl/matrixssl.inc5
-rw-r--r--recipes/matrixssl/matrixssl_1.1.1.bb17
3 files changed, 77 insertions, 0 deletions
diff --git a/recipes/matrixssl/matrixssl-1.1.1/cross.patch b/recipes/matrixssl/matrixssl-1.1.1/cross.patch
new file mode 100644
index 0000000000..05ae0523e8
--- /dev/null
+++ b/recipes/matrixssl/matrixssl-1.1.1/cross.patch
@@ -0,0 +1,55 @@
+--- src/Makefile.porig 2004-06-10 15:03:25.000000000 -0400
++++ src/Makefile 2004-06-11 20:16:30.701134886 -0400
+@@ -6,7 +6,7 @@
+ #
+
+ CC = gcc
+-STRIP = strip
++STRIP = -s
+ O = .o
+ SO = .so
+ E =
+@@ -37,17 +37,17 @@
+ #
+ ifdef MATRIXSSL_DEBUG
+ DFLAGS = -g -Wall -DDEBUG
+-STRIP = test
++STRIP =
+ else
+-DFLAGS = -O3
++DFLAGS = -O2
+ endif
+
+ #
+ # Compile options
+ #
+-SHARED = -shared
+-CFLAGS = $(DFLAGS) -DLINUX
+-LDFLAGS = -nostdlib -lc -lpthread
++SHARED = -shared
++CFLAGS = $(DFLAGS) $(STRIP) -DLINUX
++LDLIBS = -nostdlib -lc -lpthread
+
+ #
+ # Override variables for compilation on Mac OS X (Darwin)
+@@ -57,8 +57,8 @@
+ SO = .dylib
+ SHARED = -dynamiclib
+ CFLAGS += -DOSX -isystem -I/usr/include
+-LDFLAGS = -flat_namespace -install_name @executable_path/../src/$(LIBRARY)
+-STRIP = test
++LDLIBS = -flat_namespace -install_name @executable_path/../src/$(LIBRARY)
++STRIP =
+ endif
+
+ all: compile
+@@ -77,8 +77,7 @@
+ # Build the library
+ #
+ $(LIBRARY): $(OBJECTS)
+- $(CC) $(SHARED) -o $@ $^ $(LDFLAGS)
+- $(STRIP) $(LIBRARY)
++ $(CC) $(SHARED) -o $@ $^ $(LDFLAGS) $(LDLIBS)
+
+ #
+ # Clean up all generated files
diff --git a/recipes/matrixssl/matrixssl.inc b/recipes/matrixssl/matrixssl.inc
new file mode 100644
index 0000000000..bb6b8e0bdc
--- /dev/null
+++ b/recipes/matrixssl/matrixssl.inc
@@ -0,0 +1,5 @@
+def define_os (d):
+ import bb
+ if bb.data.getVar('TARGET_OS', d, 1).startswith('linux'):
+ return "-DLINUX"
+ return ""
diff --git a/recipes/matrixssl/matrixssl_1.1.1.bb b/recipes/matrixssl/matrixssl_1.1.1.bb
new file mode 100644
index 0000000000..b90ef341c0
--- /dev/null
+++ b/recipes/matrixssl/matrixssl_1.1.1.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "A secure sockets library"
+SECTION = "libs"
+LICENSE = "GPL"
+PR = "r1"
+SRC_URI = "http://wiki.openembedded.org/dl/matrixssl-1-1-1.tar.gz \
+ file://cross.patch;patch=1"
+S = "${WORKDIR}/matrixssl/src"
+
+require matrixssl.inc
+
+CFLAGS_append = " ${@define_os(d)}"
+
+do_install () {
+ install -d ${D}${includedir}
+ install -m 0644 ${S}/../matrixSsl.h ${D}${includedir}/
+ oe_libinstall -so libmatrixssl ${D}${libdir}/
+}