aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/matroska
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2010-10-01 01:17:32 +0000
committerKhem Raj <raj.khem@gmail.com>2010-10-06 15:25:01 -0700
commit0741f11dcba3aae5d1e26361730ea32e8f078916 (patch)
tree18b8f29bd027874e344d2b3aac97e5e0fc055dc0 /recipes/matroska
parentf2e95d221a4b642b67aeca2ecf0a93b6a3271710 (diff)
downloadopenembedded-0741f11dcba3aae5d1e26361730ea32e8f078916.tar.gz
lib{ebml,matroska}-1.0.0: intitial recipes
Signed-off-by: Andreas Oberritter <obi@opendreambox.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/matroska')
-rw-r--r--recipes/matroska/libebml.inc3
-rw-r--r--recipes/matroska/libebml_1.0.0.bb4
-rw-r--r--recipes/matroska/libmatroska.inc4
-rw-r--r--recipes/matroska/libmatroska_1.0.0.bb4
-rw-r--r--recipes/matroska/matroska.inc16
5 files changed, 31 insertions, 0 deletions
diff --git a/recipes/matroska/libebml.inc b/recipes/matroska/libebml.inc
new file mode 100644
index 0000000000..8472a11077
--- /dev/null
+++ b/recipes/matroska/libebml.inc
@@ -0,0 +1,3 @@
+DESCRIPTION = "access library for the EBML format"
+
+require matroska.inc
diff --git a/recipes/matroska/libebml_1.0.0.bb b/recipes/matroska/libebml_1.0.0.bb
new file mode 100644
index 0000000000..89bcad406a
--- /dev/null
+++ b/recipes/matroska/libebml_1.0.0.bb
@@ -0,0 +1,4 @@
+require ${PN}.inc
+
+SRC_URI[md5sum] = "6d438f03d8928d83a2d120ed02705f03"
+SRC_URI[sha256sum] = "72480dec736cd5df5bc9e8c3864a58d17715542c83ff1b2095dca46cc1b8b178"
diff --git a/recipes/matroska/libmatroska.inc b/recipes/matroska/libmatroska.inc
new file mode 100644
index 0000000000..4f1e2ccab1
--- /dev/null
+++ b/recipes/matroska/libmatroska.inc
@@ -0,0 +1,4 @@
+DESCRIPTION = "extensible open standard audio/video container format"
+DEPENDS = "libebml"
+
+require matroska.inc
diff --git a/recipes/matroska/libmatroska_1.0.0.bb b/recipes/matroska/libmatroska_1.0.0.bb
new file mode 100644
index 0000000000..b0ee88699c
--- /dev/null
+++ b/recipes/matroska/libmatroska_1.0.0.bb
@@ -0,0 +1,4 @@
+require ${PN}.inc
+
+SRC_URI[md5sum] = "4efcf3945b17a6f0320cf1aaa326a4de"
+SRC_URI[sha256sum] = "dc000523df508e457ead6447b2d9a2c549fbff525783c13a96d19bbd61137b88"
diff --git a/recipes/matroska/matroska.inc b/recipes/matroska/matroska.inc
new file mode 100644
index 0000000000..5ce8fa5da0
--- /dev/null
+++ b/recipes/matroska/matroska.inc
@@ -0,0 +1,16 @@
+HOMEPAGE = "http://www.matroska.org/"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "LGPLv2.1"
+
+SRC_URI = "http://dl.matroska.org/downloads/${PN}/${P}.tar.bz2"
+
+EXTRA_OEMAKE = "CROSS=${TARGET_PREFIX} prefix=${D}${prefix} -C make/linux"
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ oe_runmake install
+}