aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mc
diff options
context:
space:
mode:
authorStanislav Brabec <utx@penguin.cz>2009-04-16 13:00:56 +0000
committerutx@penguin.cz <utx@penguin.cz>2009-04-16 13:00:56 +0000
commita873d2ce9842923b8d0abae7e4cdfca606b3dd90 (patch)
tree9637d5d7926c35f53624bb1520a579ebecc2eef4 /recipes/mc
parent7eec526f3c6ca8eaa5e655ae706d66e565c1a738 (diff)
downloadopenembedded-a873d2ce9842923b8d0abae7e4cdfca606b3dd90.tar.gz
mc: Fixed invalid references to staging bindir.
Diffstat (limited to 'recipes/mc')
-rw-r--r--recipes/mc/mc.inc6
-rw-r--r--recipes/mc/mc_4.6.0.bb2
-rw-r--r--recipes/mc/mc_4.6.1.bb2
-rw-r--r--recipes/mc/mc_4.6.2.bb10
4 files changed, 14 insertions, 6 deletions
diff --git a/recipes/mc/mc.inc b/recipes/mc/mc.inc
index 6bd3ebeb99..9d00aca664 100644
--- a/recipes/mc/mc.inc
+++ b/recipes/mc/mc.inc
@@ -12,7 +12,11 @@ SRC_URI = "http://www.ibiblio.org/pub/Linux/utils/file/managers/mc/mc-${PV}.tar.
inherit autotools
EXTRA_OECONF = "--disable-glibtest --without-x --without-samba \
---without-nfs --without-gpm-mouse --with-screen=ncurses"
+--without-nfs --without-gpm-mouse --with-screen=ncurses \
+ac_cv_path_PERL=${bindir}/perl \
+ac_cv_path_ZIP=${bindir}/zip \
+ac_cv_path_UNZIP=${bindir}/unzip \
+"
PACKAGES += "${PN}-extfs ${PN}-hilite"
FILES_${PN} = "${bindir}/ ${libexecdir}/mc ${datadir}/mc/*.charsets ${datadir}/mc/*.ext ${datadir}/mc/*.hint ${datadir}/mc/*.hlp ${datadir}/mc/*.lib ${datadir}/mc/*.menu ${datadir}/mc/*.rc ${datadir}/mc/bin /etc/profile.d"
diff --git a/recipes/mc/mc_4.6.0.bb b/recipes/mc/mc_4.6.0.bb
index e5c18784be..f060fff4bc 100644
--- a/recipes/mc/mc_4.6.0.bb
+++ b/recipes/mc/mc_4.6.0.bb
@@ -1,2 +1,2 @@
require mc.inc
-PR = "r2"
+PR = "r3"
diff --git a/recipes/mc/mc_4.6.1.bb b/recipes/mc/mc_4.6.1.bb
index e5c18784be..f060fff4bc 100644
--- a/recipes/mc/mc_4.6.1.bb
+++ b/recipes/mc/mc_4.6.1.bb
@@ -1,2 +1,2 @@
require mc.inc
-PR = "r2"
+PR = "r3"
diff --git a/recipes/mc/mc_4.6.2.bb b/recipes/mc/mc_4.6.2.bb
index 75d2a1b551..10da272f79 100644
--- a/recipes/mc/mc_4.6.2.bb
+++ b/recipes/mc/mc_4.6.2.bb
@@ -1,5 +1,5 @@
require mc.inc
-PR = "r2"
+PR = "r3"
HOMEPAGE = "http://www.midnight-commander.org/"
# most of these fixes were copied from openSUSE Factory.
@@ -23,8 +23,12 @@ SRC_URI = "http://www.midnight-commander.org/downloads/${P}.tar.gz \
file://mc-cursor-appearance.patch;patch=1 \
file://mc-esc-seq.patch;patch=1"
-EXTRA_OECONF = "--without-x --without-samba \
---without-nfs --without-gpm-mouse --enable-charset"
+EXTRA_OECONF = "--without-x --without-samba \
+--without-nfs --without-gpm-mouse --enable-charset \
+ac_cv_path_PERL=${bindir}/perl \
+ac_cv_path_ZIP=${bindir}/zip \
+ac_cv_path_UNZIP=${bindir}/unzip \
+"
do_unpack_append() {
bb.build.exec_func('do_utf8_conversion', d)