aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mc
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2009-09-24 13:05:24 +0200
committerHenning Heinold <heinold@inf.fu-berlin.de>2009-09-24 13:07:08 +0200
commit246c9f70a3832ab1efcef84b0d14fd96be489d44 (patch)
tree24e0b1881f80a05801de99a0d84464c2c950db1e /recipes/mc
parent4de2e3a057436f3377270a0f806364654fd8096c (diff)
downloadopenembedded-246c9f70a3832ab1efcef84b0d14fd96be489d44.tar.gz
mc: fix configure
* delete all auto-config files in config * inherit gettext in .inc * bump PR
Diffstat (limited to 'recipes/mc')
-rw-r--r--recipes/mc/mc.inc2
-rw-r--r--recipes/mc/mc_4.6.2.bb11
2 files changed, 11 insertions, 2 deletions
diff --git a/recipes/mc/mc.inc b/recipes/mc/mc.inc
index 9d00aca664..f7db53ffd0 100644
--- a/recipes/mc/mc.inc
+++ b/recipes/mc/mc.inc
@@ -9,7 +9,7 @@ RDEPENDS = "ncurses-terminfo"
SRC_URI = "http://www.ibiblio.org/pub/Linux/utils/file/managers/mc/mc-${PV}.tar.gz"
-inherit autotools
+inherit autotools gettext
EXTRA_OECONF = "--disable-glibtest --without-x --without-samba \
--without-nfs --without-gpm-mouse --with-screen=ncurses \
diff --git a/recipes/mc/mc_4.6.2.bb b/recipes/mc/mc_4.6.2.bb
index 10da272f79..387187dc52 100644
--- a/recipes/mc/mc_4.6.2.bb
+++ b/recipes/mc/mc_4.6.2.bb
@@ -1,5 +1,5 @@
require mc.inc
-PR = "r3"
+PR = "r4"
HOMEPAGE = "http://www.midnight-commander.org/"
# most of these fixes were copied from openSUSE Factory.
@@ -78,3 +78,12 @@ do_utf8_conversion() {
popd
popd
}
+
+do_configure_prepend() {
+
+AUTOFOO="config.guess config.rpath config.sub depcomp install-sh missing mkinstalldirs"
+
+ for i in ${AUTOFOO}; do
+ rm config/${i}
+ done
+}