aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mc
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2010-09-29 10:36:21 +0000
committerKhem Raj <raj.khem@gmail.com>2010-10-06 15:30:33 -0700
commitbb2ba59d81dc96919cb95f869ec288b78816f63b (patch)
tree057a13b6e2eab94f979bf147d6791af8dab8ad54 /recipes/mc
parent20fc2d19db911a9b6841916959c3defeababd6b1 (diff)
downloadopenembedded-bb2ba59d81dc96919cb95f869ec288b78816f63b.tar.gz
mc-4.6.2: use cd instead of pushd and popd
* pushd and popd aren't compatible with dash. Signed-off-by: Andreas Oberritter <obi@opendreambox.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/mc')
-rw-r--r--recipes/mc/mc_4.6.2.bb27
1 files changed, 9 insertions, 18 deletions
diff --git a/recipes/mc/mc_4.6.2.bb b/recipes/mc/mc_4.6.2.bb
index 85a2cce9e3..18aea7021a 100644
--- a/recipes/mc/mc_4.6.2.bb
+++ b/recipes/mc/mc_4.6.2.bb
@@ -1,5 +1,5 @@
require mc.inc
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
HOMEPAGE = "http://www.midnight-commander.org/"
# most of these fixes were copied from openSUSE Factory.
@@ -34,8 +34,7 @@ do_unpack_append() {
bb.build.exec_func('do_utf8_conversion', d)
}
do_utf8_conversion() {
- pwd
- pushd lib
+ cd ${S}/lib
iconv -f iso8859-1 -t utf-8 -o mc.hint.tmp mc.hint && mv mc.hint.tmp mc.hint
iconv -f iso8859-1 -t utf-8 -o mc.hint.es.tmp mc.hint.es && mv mc.hint.es.tmp mc.hint.es
iconv -f iso8859-1 -t utf-8 -o mc.hint.it.tmp mc.hint.it && mv mc.hint.it.tmp mc.hint.it
@@ -48,35 +47,27 @@ do_utf8_conversion() {
iconv -f koi8-u -t utf8 -o mc.hint.uk.tmp mc.hint.uk && mv mc.hint.uk.tmp mc.hint.uk
iconv -f big5 -t utf8 -o mc.hint.zh.tmp mc.hint.zh && mv mc.hint.zh.tmp mc.hint.zh
iconv -f iso8859-5 -t utf-8 -o mc.menu.sr.tmp mc.menu.sr && mv mc.menu.sr.tmp mc.menu.sr
- popd
# convert docs to utf-8
- pushd doc
- pushd es
+ cd ${S}/doc/es
iconv -f iso8859-1 -t utf-8 -o mc.1.in.tmp mc.1.in && mv mc.1.in.tmp mc.1.in
iconv -f iso8859-1 -t utf-8 -o xnc.hlp.tmp xnc.hlp && mv xnc.hlp.tmp xnc.hlp
- popd
- pushd hu
+ cd ${S}/doc/hu
iconv -f iso8859-2 -t utf-8 -o mc.1.in.tmp mc.1.in && mv mc.1.in.tmp mc.1.in
iconv -f iso8859-2 -t utf-8 -o xnc.hlp.tmp xnc.hlp && mv xnc.hlp.tmp xnc.hlp
- popd
- pushd it
+ cd ${S}/doc/it
iconv -f iso8859-1 -t utf-8 -o mc.1.in.tmp mc.1.in && mv mc.1.in.tmp mc.1.in
iconv -f iso8859-1 -t utf-8 -o xnc.hlp.tmp xnc.hlp && mv xnc.hlp.tmp xnc.hlp
- popd
- pushd pl
+ cd ${S}/doc/pl
iconv -f iso8859-2 -t utf-8 -o mc.1.in.tmp mc.1.in && mv mc.1.in.tmp mc.1.in
iconv -f iso8859-2 -t utf-8 -o xnc.hlp.tmp xnc.hlp && mv xnc.hlp.tmp xnc.hlp
- popd
- pushd ru
+ cd ${S}/doc/ru
iconv -f koi8-r -t utf-8 -o mc.1.in.tmp mc.1.in && mv mc.1.in.tmp mc.1.in
iconv -f koi8-r -t utf-8 -o xnc.hlp.tmp xnc.hlp && mv xnc.hlp.tmp xnc.hlp
- popd
- pushd sr
+ cd ${S}/doc/sr
iconv -f iso8859-5 -t utf-8 -o mc.1.in.tmp mc.1.in && mv mc.1.in.tmp mc.1.in
iconv -f iso8859-5 -t utf-8 -o xnc.hlp.tmp xnc.hlp && mv xnc.hlp.tmp xnc.hlp
iconv -f iso8859-5 -t utf-8 -o mcserv.8.in.tmp mcserv.8.in && mv mcserv.8.in.tmp mcserv.8.in
- popd
- popd
+ cd ${S}
}
do_configure_prepend() {