aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mdadm
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/mdadm
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/mdadm')
-rw-r--r--recipes/mdadm/mdadm-1.12.0/build_flags.patch19
-rw-r--r--recipes/mdadm/mdadm-1.12.0/install.patch17
-rw-r--r--recipes/mdadm/mdadm.inc24
-rw-r--r--recipes/mdadm/mdadm_1.12.0.bb4
-rw-r--r--recipes/mdadm/mdadm_2.5.5.bb3
5 files changed, 67 insertions, 0 deletions
diff --git a/recipes/mdadm/mdadm-1.12.0/build_flags.patch b/recipes/mdadm/mdadm-1.12.0/build_flags.patch
new file mode 100644
index 0000000000..38e1051d6f
--- /dev/null
+++ b/recipes/mdadm/mdadm-1.12.0/build_flags.patch
@@ -0,0 +1,19 @@
+--- mdadm-1.12.0/Makefile 2005-08-22 17:30:21.000000000 -0700
++++ mdadm-1.12.0/Makefile~ 2005-08-22 17:30:14.000000000 -0700
+@@ -37,13 +37,13 @@
+
+ KLIBC_GCC = gcc -nostdinc -iwithprefix include -I$(KLIBC)/klibc/include -I$(KLIBC)/linux/include -I$(KLIBC)/klibc/arch/i386/include -I$(KLIBC)/klibc/include/bits32
+
+-CC = gcc
+-CXFLAGS = -ggdb
++CC := $(CC)
++CXFLAGS =
+ CWFLAGS = -Wall -Werror -Wstrict-prototypes
+ SYSCONFDIR = /etc
+ CONFFILE = $(SYSCONFDIR)/mdadm.conf
+ MAILCMD =/usr/sbin/sendmail -t
+-CFLAGS = $(CWFLAGS) -DCONFFILE=\"$(CONFFILE)\" $(CXFLAGS) -DSendmail=\""$(MAILCMD)"\"
++CFLAGS := $(CFLAGS) $(TARGET_CFLAGS) $(CWFLAGS) -DCONFFILE=\"$(CONFFILE)\" $(CXFLAGS) -DSendmail=\""$(MAILCMD)"\"
+
+ # If you want a static binary, you might uncomment these
+ # LDFLAGS = -static
diff --git a/recipes/mdadm/mdadm-1.12.0/install.patch b/recipes/mdadm/mdadm-1.12.0/install.patch
new file mode 100644
index 0000000000..e778f9a3b9
--- /dev/null
+++ b/recipes/mdadm/mdadm-1.12.0/install.patch
@@ -0,0 +1,17 @@
+--- mdadm-1.12.0/Makefile 2005-08-22 16:53:26.000000000 -0700
++++ mdadm-1.12.0/Makefile~ 2005-08-22 16:53:04.000000000 -0700
+@@ -119,10 +119,10 @@
+ $(OBJS) : mdadm.h
+
+ install : mdadm mdadm.8 md.4 mdadm.conf.5
+- $(INSTALL) -D $(STRIP) -m 755 mdadm $(DESTDIR)$(BINDIR)/mdadm
+- $(INSTALL) -D -m 644 mdadm.8 $(DESTDIR)$(MAN8DIR)/mdadm.8
+- $(INSTALL) -D -m 644 md.4 $(DESTDIR)$(MAN4DIR)/md.4
+- $(INSTALL) -D -m 644 mdadm.conf.5 $(DESTDIR)$(MAN5DIR)/mdadm.conf.5
++ $(INSTALL) -D -s -m 755 mdadm $(DESTDIR)$(BINDIR)
++ $(INSTALL) -D -m 644 mdadm.8 $(DESTDIR)$(MAN8DIR)
++ $(INSTALL) -D -m 644 md.4 $(DESTDIR)$(MAN4DIR)
++ $(INSTALL) -D -m 644 mdadm.conf.5 $(DESTDIR)$(MAN5DIR)
+
+ clean :
+ rm -f mdadm $(OBJS) core *.man mdadm.tcc mdadm.uclibc mdadm.static *.orig *.porig *.rej *.alt \
diff --git a/recipes/mdadm/mdadm.inc b/recipes/mdadm/mdadm.inc
new file mode 100644
index 0000000000..a944e0b190
--- /dev/null
+++ b/recipes/mdadm/mdadm.inc
@@ -0,0 +1,24 @@
+SECTION = "utils"
+DESCRIPTION = "mdadm is a tool for creating, managing and monitoring \
+device arrays using the "md" driver in Linux, also \
+known as Software RAID arrays."
+LICENSE = "GPL"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/raid/mdadm/${PN}-${PV}.tar.bz2"
+
+CFLAGS += "-fno-strict-aliasing"
+
+
+inherit autotools
+
+INHIBIT_AUTO_STAGE = "1"
+
+do_compile() {
+ export CROSS_COMPILE="${TARGET_PREFIX}"
+ oe_runmake
+}
+
+do_install() {
+ export STRIP=""
+ autotools_do_install
+}
diff --git a/recipes/mdadm/mdadm_1.12.0.bb b/recipes/mdadm/mdadm_1.12.0.bb
new file mode 100644
index 0000000000..3519f91c37
--- /dev/null
+++ b/recipes/mdadm/mdadm_1.12.0.bb
@@ -0,0 +1,4 @@
+require mdadm.inc
+PR = "r3"
+
+SRC_URI += " file://build_flags.patch;patch=1 "
diff --git a/recipes/mdadm/mdadm_2.5.5.bb b/recipes/mdadm/mdadm_2.5.5.bb
new file mode 100644
index 0000000000..0219b12f61
--- /dev/null
+++ b/recipes/mdadm/mdadm_2.5.5.bb
@@ -0,0 +1,3 @@
+require mdadm.inc
+PR = "r0"
+