aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/memtester
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/memtester
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/memtester')
-rw-r--r--recipes/memtester/files/Makefile.patch15
-rw-r--r--recipes/memtester/memtester_4.0.5.bb22
-rw-r--r--recipes/memtester/memtester_4.0.6.bb22
3 files changed, 59 insertions, 0 deletions
diff --git a/recipes/memtester/files/Makefile.patch b/recipes/memtester/files/Makefile.patch
new file mode 100644
index 0000000000..57a04642a6
--- /dev/null
+++ b/recipes/memtester/files/Makefile.patch
@@ -0,0 +1,15 @@
+Index: memtester-4.0.5/Makefile
+===================================================================
+--- memtester-4.0.5.orig/Makefile 2005-03-14 06:02:30.000000000 -0800
++++ memtester-4.0.5/Makefile 2006-07-08 23:53:42.000000000 -0700
+@@ -24,8 +24,8 @@
+ auto-ccld.sh: \
+ conf-cc conf-ld warn-auto.sh
+ ( cat warn-auto.sh; \
+- echo CC=\'`head -1 conf-cc`\'; \
+- echo LD=\'`head -1 conf-ld`\' \
++ echo CC=\'`head -n 1 conf-cc`\'; \
++ echo LD=\'`head -n 1 conf-ld`\' \
+ ) > auto-ccld.sh
+
+ compile: \
diff --git a/recipes/memtester/memtester_4.0.5.bb b/recipes/memtester/memtester_4.0.5.bb
new file mode 100644
index 0000000000..6a84471cee
--- /dev/null
+++ b/recipes/memtester/memtester_4.0.5.bb
@@ -0,0 +1,22 @@
+SECTION = "console/utils"
+DESCRIPTION = "Utility to test for faulty memory subsystem"
+LICENSE = "GPLv2"
+PR = "r2"
+
+SRC_URI = "http://pyropus.ca/software/memtester/old-versions/memtester-${PV}.tar.gz"
+SRC_URI += "file://Makefile.patch;patch=1"
+
+S = "${WORKDIR}/memtester-${PV}"
+
+do_compile () {
+ echo '${CC} ${CFLAGS} -DPOSIX -c' > conf-cc
+ echo '${CC} ${LDFLAGS}' > conf-ld
+ oe_runmake
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -d ${D}${mandir}/man8
+ install -m 0755 memtester ${D}${bindir}/
+ install -m 0755 memtester.8 ${D}${mandir}/man8/
+}
diff --git a/recipes/memtester/memtester_4.0.6.bb b/recipes/memtester/memtester_4.0.6.bb
new file mode 100644
index 0000000000..1fb4541eb6
--- /dev/null
+++ b/recipes/memtester/memtester_4.0.6.bb
@@ -0,0 +1,22 @@
+SECTION = "console/utils"
+DESCRIPTION = "Utility to test for faulty memory subsystem"
+LICENSE = "GPLv2"
+PR = "r0"
+
+SRC_URI = "http://pyropus.ca/software/memtester/old-versions/memtester-${PV}.tar.gz"
+SRC_URI += "file://Makefile.patch;patch=1"
+
+S = "${WORKDIR}/memtester-${PV}"
+
+do_compile () {
+ echo '${CC} ${CFLAGS} -DPOSIX -c' > conf-cc
+ echo '${CC} ${LDFLAGS}' > conf-ld
+ oe_runmake
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -d ${D}${mandir}/man8
+ install -m 0755 memtester ${D}${bindir}/
+ install -m 0755 memtester.8 ${D}${mandir}/man8/
+}