aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mercurial
diff options
context:
space:
mode:
authorEric Bénard <eric@eukrea.com>2010-09-06 23:15:39 +0200
committerEric Bénard <eric@eukrea.com>2010-09-08 21:26:02 +0200
commit41ee3c4d7c0e72436049c2c0972fe6e3b6311c5f (patch)
tree76c635957c1fb590e808f6b86617e6c4d789c813 /recipes/mercurial
parent8f4400c820def38de9806f10cc20b35dec416ef2 (diff)
downloadopenembedded-41ee3c4d7c0e72436049c2c0972fe6e3b6311c5f.tar.gz
mercurial-native: add recipe
* mercurial is a distributed SCM * having the native recipe inside OpenEmbedded gives the possibility to fetch code from mercurial's repositories without the need to have mercurial installed on the host Signed-off-by: Eric Bénard <eric@eukrea.com>
Diffstat (limited to 'recipes/mercurial')
-rw-r--r--recipes/mercurial/mercurial-native_1.6.3.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/mercurial/mercurial-native_1.6.3.bb b/recipes/mercurial/mercurial-native_1.6.3.bb
new file mode 100644
index 0000000000..717f8f6f9d
--- /dev/null
+++ b/recipes/mercurial/mercurial-native_1.6.3.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "The Mercurial distributed SCM"
+HOMEPAGE = "http://mercurial.selenic.com/"
+SECTION = "console/utils"
+LICENSE = "GPLv2"
+DEPENDS = "python-native"
+PR = "r0"
+
+SRC_URI = "http://mercurial.selenic.com/release/mercurial-${PV}.tar.gz;name=src"
+SRC_URI[src.md5sum] = "fcd61edc488d1b9aa831dde6f14d9a13"
+SRC_URI[src.sha256sum] = "57e5d26d35fbec71206378e3af111193e6eee7bb1dfb6447bbc4b9e03ce937bd"
+
+S = "${WORKDIR}/mercurial-${PV}"
+
+inherit native
+
+EXTRA_OEMAKE = "STAGING_LIBDIR=${STAGING_LIBDIR} STAGING_INCDIR=${STAGING_INCDIR} \
+ BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} PREFIX=${prefix}"
+
+do_install () {
+ oe_runmake -e install DESTDIR=${D} PREFIX=${prefix}
+}