aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mesa/mesa-dri-glsl-native_7.8.2.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-06-22 13:42:36 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-06-25 15:03:24 +0200
commit02fdabdbaffc37a206034e6ee2efd3ab9e908f1d (patch)
tree807bd9e826070cd5298add52c794371a6538a39d /recipes/mesa/mesa-dri-glsl-native_7.8.2.bb
parent8d1b0b92a3a2cde6dc59ed25464af95a0c24280d (diff)
downloadopenembedded-02fdabdbaffc37a206034e6ee2efd3ab9e908f1d.tar.gz
mesa: move 7.8 release to latest minor 7.8.2
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Henning Heinold <heinold@inf.fu-berlin.de> Acked-by: Graeme Gregory <dp@xora.org.uk>
Diffstat (limited to 'recipes/mesa/mesa-dri-glsl-native_7.8.2.bb')
-rw-r--r--recipes/mesa/mesa-dri-glsl-native_7.8.2.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/mesa/mesa-dri-glsl-native_7.8.2.bb b/recipes/mesa/mesa-dri-glsl-native_7.8.2.bb
new file mode 100644
index 0000000000..dd24f164e7
--- /dev/null
+++ b/recipes/mesa/mesa-dri-glsl-native_7.8.2.bb
@@ -0,0 +1,19 @@
+inherit native
+
+DEPENDS = "makedepend-native"
+
+SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/${PV}/MesaLib-${PV}.tar.bz2;name=archive"
+SRC_URI[archive.md5sum] = "6be2d343a0089bfd395ce02aaf8adb57"
+SRC_URI[archive.sha256sum] = "505bf418dceba05837f4ea1b1972b9620c35f8cb94bc4d1e6d573c15f562576d"
+
+S = "${WORKDIR}/Mesa-7.8.2/src/glsl/"
+
+do_configure_prepend() {
+ ln -s ${S}/../../configs/default ${S}/../../configs/current
+}
+
+NATIVE_INSTALL_WORKS = "1"
+do_install() {
+ install -d ${bindir}
+ install -m 755 ${S}/apps/compile ${bindir}/glsl-compile
+}