aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mesa
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-02-19 01:04:12 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2010-02-19 01:04:12 +0100
commit7580c82e1aecdd759e9f2b5cd100ffb14bf1c780 (patch)
tree6a3bed0d4c58a0d41ef6f0cb746e24a1750e0d30 /recipes/mesa
parentb82b1cfa5cb3b3fc367636509b286918943a24e2 (diff)
parent02dedbd2d624c04ff3d80a07008274e2db12fecf (diff)
downloadopenembedded-7580c82e1aecdd759e9f2b5cd100ffb14bf1c780.tar.gz
Merge remote branch 'origin/org.openembedded.dev' into shr/unstable
Conflicts: recipes/dri/libdrm_git.bb recipes/gpe-icons/gpe-theme-neo_git.bb recipes/mesa/mesa-dri_git.bb recipes/shr/e-wm-theme-illume-neo_git.bb recipes/shr/elementary-theme-neo_git.bb recipes/shr/etk-theme-neo_git.bb recipes/shr/gtk-theme-neo_git.bb recipes/shr/icon-theme-neo_git.bb recipes/shr/libframeworkd-phonegui-efl-theme-neo_git.bb recipes/xorg-driver/xf86-video-glamo_git.bb recipes/xorg-xserver/xserver-xorg_git.bb
Diffstat (limited to 'recipes/mesa')
-rw-r--r--recipes/mesa/mesa-dri-glsl-native.bb22
-rw-r--r--recipes/mesa/mesa-dri_git.bb19
2 files changed, 36 insertions, 5 deletions
diff --git a/recipes/mesa/mesa-dri-glsl-native.bb b/recipes/mesa/mesa-dri-glsl-native.bb
new file mode 100644
index 0000000000..511cdcf2f8
--- /dev/null
+++ b/recipes/mesa/mesa-dri-glsl-native.bb
@@ -0,0 +1,22 @@
+inherit native
+
+PV = "7.7.999"
+PR = "0"
+PR_append = "+gitr${SRCREV}"
+
+DEPENDS = "makedepend-native"
+
+SRCREV = "f88b43e8d09bf359e7d5770b133cb433b25f9848"
+
+SRC_URI = "git://anongit.freedesktop.org/git/mesa/mesa;protocol=git"
+
+S = "${WORKDIR}/git/src/glsl/"
+
+do_configure_prepend() {
+ ln -s ${S}/../../configs/default ${S}/../../configs/current
+}
+
+do_stage() {
+ install -d ${bindir}
+ install -m 755 ${S}/apps/compile ${bindir}/glsl-compile
+}
diff --git a/recipes/mesa/mesa-dri_git.bb b/recipes/mesa/mesa-dri_git.bb
index 001b228bfd..4029c1e013 100644
--- a/recipes/mesa/mesa-dri_git.bb
+++ b/recipes/mesa/mesa-dri_git.bb
@@ -3,15 +3,17 @@ include mesa-common.inc
PROTO_DEPS = "xf86driproto glproto dri2proto"
LIB_DEPS = "libdrm virtual/libx11 libxext libxxf86vm libxdamage libxfixes expat"
-DEPENDS = "${PROTO_DEPS} ${LIB_DEPS}"
+DEPENDS = "${PROTO_DEPS} ${LIB_DEPS} makedepend-native mesa-dri-glsl-native"
-PV = "7.6.1+gitr${SRCPV}"
-PR = "${INC_PR}.3"
+PV = "7.7.999"
+PR = "${INC_PR}.0"
+PR_append = "+gitr${SRCPV}"
DEFAULT_PREFERENCE = "-2"
DEFAULT_PREFERENCE_om-gta02 = "2"
-SRCREV_om-gta02 ?= "a8a1c12262998e5fa3a857eebf857c6d3a95f85e"
+SRCREV_pn-mesa-dri ?= "196214bf2b677a83653d49f79d03752f29df44ec"
+SRCREV_pn-mesa-dri_om-gta02 ?= "1ac166895fef47806c9e9286d2a6356b4db8398d"
SRC_URI = "git://anongit.freedesktop.org/git/mesa/mesa;protocol=git"
SRC_URI_om-gta02 = "git://git.bitwiz.org.uk/mesa.git;protocol=git;branch=glamo"
@@ -23,4 +25,11 @@ FILES_${PN} += "${libdir}/dri/*.so"
FILES_${PN}-dbg += "${libdir}/dri/.debug/*"
FILES_mesa-utils = "${bindir}/*"
-EXTRA_OECONF += "--with-driver=dri --disable-glx-tls --disable-gallium-intel --with-dri-drivers=swrast,${MACHINE_DRI_MODULES}"
+EXTRA_OECONF += "--with-driver=dri --disable-glx-tls --with-dri-drivers=swrast,${MACHINE_DRI_MODULES}"
+EXTRA_OECONF_om-gta02 += "--with-driver=dri --disable-glx-tls --disable-gallium --disable-gallium-intel --with-dri-drivers=swrast,${MACHINE_DRI_MODULES}"
+
+# We need glsl-compile built for buildhost arch instead of target (is provided by mesa-dri-glsl-native)"
+do_configure_prepend() {
+ sed -i "s#glsl_compile\[0\].abspath + '#'${STAGING_BINDIR_NATIVE}/glsl-compile#g" ${S}/src/mesa/shader/slang/library/SConscript
+ sed -i "s#^GLSL_CL = .*\$#GLSL_CL = ${STAGING_BINDIR_NATIVE}/glsl-compile#g" ${S}/src/mesa/shader/slang/library/Makefile
+}