aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/meta/meta-toolchain.bb
diff options
context:
space:
mode:
authorTom Rini <trini@embeddedalley.com>2009-04-03 14:34:10 -0700
committerTom Rini <trini@embeddedalley.com>2009-04-06 14:33:26 -0700
commitda82d156d7c2503696ea21cba1e86b261f4a7c92 (patch)
treed6ec93bcc78d99e8546e079483628d439a597a8d /recipes/meta/meta-toolchain.bb
parent439e60b246bcc741e883372f2340fc6ab7af93d3 (diff)
downloadopenembedded-da82d156d7c2503696ea21cba1e86b261f4a7c92.tar.gz
meta-toolchain, canadian-sdk: Move C++ headers into the correct location, bump PR
A gcc that has sysroot support expects that the default C++ headers (iostream, etc) are in <toolchain prefix>/include/c++ while regular C headers are still in <toolchain prefix>/usr/include. Acked-by: Florian Boor <florian.boor@kernelconcepts.de> Acked-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tom Rini <trini@embeddedalley.com>
Diffstat (limited to 'recipes/meta/meta-toolchain.bb')
-rw-r--r--recipes/meta/meta-toolchain.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/recipes/meta/meta-toolchain.bb b/recipes/meta/meta-toolchain.bb
index f892d22fd1..b641be1295 100644
--- a/recipes/meta/meta-toolchain.bb
+++ b/recipes/meta/meta-toolchain.bb
@@ -117,6 +117,12 @@ do_populate_sdk() {
# gcc-cross-sdk get built :( (30/11/07)
ln -sf libgcc_s.so.1 ${SDK_OUTPUT}/${prefix}/${TARGET_SYS}/lib/libgcc_s.so
+ # With sysroot support, gcc expects the default C++ headers to be
+ # in a specific place.
+ install -d ${SDK_OUTPUT}/${prefix}/${TARGET_SYS}/include
+ mv ${SDK_OUTPUT}/${prefix}/${TARGET_SYS}/usr/include/c++ \
+ ${SDK_OUTPUT}/${prefix}/${TARGET_SYS}/include/
+
# Fix or remove broken .la files
for i in `find ${SDK_OUTPUT}/${prefix}/${TARGET_SYS} -name \*.la`; do
sed -i -e "/^dependency_libs=/s,\([[:space:]']\)${layout_base_libdir},\1${prefix}/${TARGET_SYS}${layout_base_libdir},g" \