aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/meta/slugos-native.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/meta/slugos-native.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/meta/slugos-native.bb')
-rw-r--r--recipes/meta/slugos-native.bb102
1 files changed, 102 insertions, 0 deletions
diff --git a/recipes/meta/slugos-native.bb b/recipes/meta/slugos-native.bb
new file mode 100644
index 0000000000..9dae7e8df3
--- /dev/null
+++ b/recipes/meta/slugos-native.bb
@@ -0,0 +1,102 @@
+# SlugOS native build tools
+#
+# For the most part these are generic tools which should work for any
+# SlugOS variant, however there is a dependency on the libc implementation
+#
+DESCRIPTION = "Packages that are required for the SlugOS native build environment"
+LICENSE = "MIT"
+PR = "r7"
+
+INHIBIT_DEFAULT_DEPS = "1"
+EXCLUDE_FROM_WORLD = "1"
+ALLOW_EMPTY = "1"
+PACKAGES = "${PN}"
+
+inherit meta
+
+do_package_write_ipk() {
+}
+
+# Run-time only (RDEPENDS) stuff - no package explicitly provides
+# these targets.
+SLUGOS_NATIVE_RT_prepend_linux = "\
+ glibc-extra-nss glibc-utils glibc \
+ "
+SLUGOS_NATIVE_RT_prepend_linux-uclibc = "\
+ uclibc-dev uclibc-utils \
+ "
+SLUGOS_NATIVE_RT = "\
+ binutils-dev binutils-symlinks \
+ cpp cpp-symlinks \
+ g++ g++-symlinks \
+ gcc gcc-symlinks \
+ gdbm \
+ libstdc++-dev \
+ ncurses-dev ncurses-terminfo \
+ perl perl-modules \
+ python-core python-crypt python-io python-lang python-pickle python-shell python-textutils \
+ readline \
+ "
+
+# Run-time and DEPENDS
+SLUGOS_NATIVE_prepend_linux = "\
+ glibc \
+ "
+SLUGOS_NATIVE_prepend_linux-uclibc = "\
+ libiconv \
+ uclibc \
+ "
+SLUGOS_NATIVE = "\
+ autoconf \
+ automake \
+ bash \
+ binutils \
+ bison \
+ bzip2 \
+ coreutils \
+ cvs \
+ diffstat \
+ file \
+ flex \
+ gawk \
+ gcc \
+ gnu-config \
+ gzip \
+ libtool \
+ lrzsz \
+ m4 \
+ make \
+ ncurses \
+ patch \
+ perl \
+ pkgconfig \
+ quilt \
+ sed \
+ tar \
+ util-linux \
+ wget \
+ ${SLUGOS_NATIVE_THUMB_BROKEN} \
+ "
+
+# If a tool won't build *on thumb libc* add it to the following list.
+# Normally such a tool should be built with the ARM instruction set
+# even on a thumb system (and this can be set in the tool's .bb file),
+# however even this doesn't work for very large programs at present
+# (only monotone!)
+####### *-*-* TEMPORARY: mwester - remove monotone as it wont' build.
+#SLUGOS_NATIVE_THUMB_BROKEN = "\
+# monotone-6 \
+# "
+SLUGOS_NATIVE_THUMB_BROKEN = ""
+###### *-*-*
+
+SLUGOS_NATIVE_THUMB_BROKEN_thumb = ""
+
+# These things are required but are not valid RDEPENDS
+SLUGOS_NATIVE_DP = "\
+ gdbm \
+ python \
+ "
+
+RDEPENDS = '${SLUGOS_NATIVE_RT} ${SLUGOS_NATIVE}'
+DEPENDS = '${SLUGOS_NATIVE_DP} ${SLUGOS_NATIVE}'