aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/meta
diff options
context:
space:
mode:
authorRoman I Khimov <khimov@altell.ru>2009-06-17 23:22:57 +0400
committerRoman I Khimov <khimov@altell.ru>2009-06-19 00:15:08 +0400
commit5f920c841a4d83fb903ccdf9127cb0fb5617eda1 (patch)
tree4adc17a542fc6955efdfc6def65e9c9f48467b0c /recipes/meta
parent68a8be99518c624816d238ee2ebb5e602a4c62ac (diff)
downloadopenembedded-5f920c841a4d83fb903ccdf9127cb0fb5617eda1.tar.gz
Make package_update_index_ipk proper task with locking
Parallel image builds race in package_update_index_ipk, so locking is needed and for a proper lock package_update_index_ipk needs to be a proper task. Acked-by: Tom Rini <trini@embeddedalley.com>
Diffstat (limited to 'recipes/meta')
-rw-r--r--recipes/meta/canadian-sdk.bb3
-rw-r--r--recipes/meta/meta-toolchain.bb3
-rw-r--r--recipes/meta/package-index.bb6
3 files changed, 3 insertions, 9 deletions
diff --git a/recipes/meta/canadian-sdk.bb b/recipes/meta/canadian-sdk.bb
index 809173b42f..86b645bb7f 100644
--- a/recipes/meta/canadian-sdk.bb
+++ b/recipes/meta/canadian-sdk.bb
@@ -56,7 +56,6 @@ do_populate_sdk() {
rm -rf ${SDK_OUTPUT}
mkdir -p ${SDK_OUTPUT}
- package_update_index_ipk
package_generate_ipkg_conf
for arch in ${PACKAGE_ARCHS}; do
@@ -170,5 +169,5 @@ do_populate_sdk() {
}
do_populate_sdk[nostamp] = "1"
-do_populate_sdk[recrdeptask] = "do_package_write"
+addtask package_update_index_ipk before do_populate_sdk
addtask populate_sdk before do_build after do_install
diff --git a/recipes/meta/meta-toolchain.bb b/recipes/meta/meta-toolchain.bb
index b641be1295..b8ed8013a9 100644
--- a/recipes/meta/meta-toolchain.bb
+++ b/recipes/meta/meta-toolchain.bb
@@ -56,7 +56,6 @@ do_populate_sdk() {
rm -rf ${SDK_OUTPUT}
mkdir -p ${SDK_OUTPUT}
- package_update_index_ipk
package_generate_ipkg_conf
for arch in ${PACKAGE_ARCHS}; do
@@ -170,5 +169,5 @@ do_populate_sdk() {
}
do_populate_sdk[nostamp] = "1"
-do_populate_sdk[recrdeptask] = "do_package_write"
+addtask package_update_index_ipk before do_populate_sdk
addtask populate_sdk before do_build after do_install
diff --git a/recipes/meta/package-index.bb b/recipes/meta/package-index.bb
index f52fb6c72b..ce8b999e16 100644
--- a/recipes/meta/package-index.bb
+++ b/recipes/meta/package-index.bb
@@ -23,8 +23,4 @@ do_stage() {
do_build[nostamp] = "1"
do_build[dirs] = "${DEPLOY_DIR_IPK}"
-do_build() {
- set -ex
- package_update_index_ipk
- set +ex
-}
+addtask package_update_index_ipk before do_build