summaryrefslogtreecommitdiffstats
path: root/recipes/mgetty
diff options
context:
space:
mode:
authorwoglinde <woglinde@rhein.zuhause.netz>2009-06-25 21:33:22 +0200
committerwoglinde <woglinde@rhein.zuhause.netz>2009-06-25 22:31:59 +0200
commit8e19e74c7d26b37aacf6d05641487129afe6c4c5 (patch)
treea7c171c947512fa1026ef53fe1e33ae9e5dcf615 /recipes/mgetty
parent7d4e6e08a42f4b2bdb91f2ec7c6e65d3f579a7b2 (diff)
downloadopenembedded-8e19e74c7d26b37aacf6d05641487129afe6c4c5.tar.gz
mgetty: add mgetty-fax to the package and honor our LDLFAGS
Diffstat (limited to 'recipes/mgetty')
-rw-r--r--recipes/mgetty/mgetty-1.1.30/faxqhelper_ldflags.patch13
-rw-r--r--recipes/mgetty/mgetty-1.1.30/newslock_ldflags.patch13
-rw-r--r--recipes/mgetty/mgetty_1.1.30.bb8
3 files changed, 33 insertions, 1 deletions
diff --git a/recipes/mgetty/mgetty-1.1.30/faxqhelper_ldflags.patch b/recipes/mgetty/mgetty-1.1.30/faxqhelper_ldflags.patch
new file mode 100644
index 0000000000..4d3ea24b57
--- /dev/null
+++ b/recipes/mgetty/mgetty-1.1.30/faxqhelper_ldflags.patch
@@ -0,0 +1,13 @@
+Index: mgetty-1.1.30/fax/Makefile
+===================================================================
+--- mgetty-1.1.30.orig/fax/Makefile 2009-05-09 22:00:37.814162343 +0200
++++ mgetty-1.1.30/fax/Makefile 2009-05-09 22:01:04.209581406 +0200
+@@ -36,7 +36,7 @@
+ @cd .. ; $(MAKE) sedscript
+
+ faxq-helper: faxq-helper.o
+- $(CC) $(CFLAGS) -o faxq-helper faxq-helper.o
++ $(CC) $(CFLAGS) $(LDFLAGS) -o faxq-helper faxq-helper.o
+
+ faxq-helper.o: faxq-helper.c
+ $(CC) $(CFLAGS) -DFAX_SPOOL_OUT=\"$(FAX_SPOOL_OUT)\" \
diff --git a/recipes/mgetty/mgetty-1.1.30/newslock_ldflags.patch b/recipes/mgetty/mgetty-1.1.30/newslock_ldflags.patch
new file mode 100644
index 0000000000..a4fc814bd0
--- /dev/null
+++ b/recipes/mgetty/mgetty-1.1.30/newslock_ldflags.patch
@@ -0,0 +1,13 @@
+Index: mgetty-1.1.30/Makefile
+===================================================================
+--- mgetty-1.1.30.orig/Makefile 2009-05-09 21:55:50.072936310 +0200
++++ mgetty-1.1.30/Makefile 2009-05-09 21:56:09.401939481 +0200
+@@ -569,7 +569,7 @@
+ ./sedscript <sendfax.cfg.in >sendfax.config
+
+ newslock: compat/newslock.c
+- $(CC) $(CFLAGS) -o newslock compat/newslock.c
++ $(CC) $(CFLAGS) $(LDFLAGS) -o newslock compat/newslock.c
+
+ # internal: use this to create a "clean" mgetty+sendfax tree
+ bindist: all doc-all sedscript
diff --git a/recipes/mgetty/mgetty_1.1.30.bb b/recipes/mgetty/mgetty_1.1.30.bb
index 375ea90f0d..37a830f5a7 100644
--- a/recipes/mgetty/mgetty_1.1.30.bb
+++ b/recipes/mgetty/mgetty_1.1.30.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "The mgetty package contains an intelligent \
getty for allowing logins over a serial line (such as \
through a modem) and receiving incoming faxes."
LICENSE = "GPL"
-PR ="r3"
+PR ="r4"
# The source can no longer be found at ${DEBIAN_MIRROR}/main/m/mgetty/mgetty_${PV}.orig.tar.gz
# so the nslu2-linux project has mirrored it until someone updates this package to a newer version.
@@ -38,6 +38,8 @@ SRC_URI = "http://nslu.sf.net/downloads/mgetty_1.1.30.orig.tar.gz \
file://51-pending-faxq-time;patch=1 \
file://52-pending-metamail;patch=1 \
file://install.patch;patch=1 \
+ file://newslock_ldflags.patch;patch=1 \
+ file://faxqhelper_ldflags.patch;patch=1 \
file://policy.h \
file://voice-defs.h"
@@ -79,3 +81,7 @@ do_install () {
CONFFILES_${PN} = "${sysconfdir}/mgetty/mgetty.config \
${sysconfdir}/mgetty/login.config ${sysconfdir}/mgetty/sendfax.config"
+
+FILES_${PN} += "${libdir}/mgetty-fax"
+
+FILES_${PN}-dbg += "${libdir}/mgetty-fax/.debug"