summaryrefslogtreecommitdiffstats
path: root/recipes/miau
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/miau
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/miau')
-rw-r--r--recipes/miau/files/miau.init40
-rw-r--r--recipes/miau/files/paths.patch43
-rw-r--r--recipes/miau/miau_0.5.3.bb41
3 files changed, 124 insertions, 0 deletions
diff --git a/recipes/miau/files/miau.init b/recipes/miau/files/miau.init
new file mode 100644
index 0000000000..041d23cda5
--- /dev/null
+++ b/recipes/miau/files/miau.init
@@ -0,0 +1,40 @@
+#! /bin/sh
+#
+# This is an init script for openembedded
+# Copy it to /etc/init.d/miau and type
+# > update-rc.d miau defaults 60
+#
+
+
+test -f /usr/bin/miau || exit 0
+
+test -d /var/spool/miau || mkdir -p /var/spool/miau
+
+case "$1" in
+ start)
+ echo -n "Starting miau daemon: miau"
+ start-stop-daemon --start --quiet --exec /usr/bin/miau
+ echo "."
+ ;;
+ stop)
+ echo -n "Stopping miau daemon: miau"
+ start-stop-daemon --stop --quiet --exec /usr/bin/miau
+ echo "."
+ ;;
+ reload|force-reload)
+ start-stop-daemon --stop --quiet --signal 1 --exec /usr/bin/miau
+ ;;
+ restart)
+ echo -n "Stopping miau daemon: miau"
+ start-stop-daemon --stop --quiet --exec /usr/bin/miau
+ sleep 1
+ echo -n "Starting miau daemon: miau"
+ start-stop-daemon --start --quiet --exec /usr/bin/miau
+ echo "."
+ ;;
+ *)
+ echo "Usage: /etc/init.d/miau {start|stop|reload|restart|force-reload}"
+ exit 1
+esac
+
+exit 0
diff --git a/recipes/miau/files/paths.patch b/recipes/miau/files/paths.patch
new file mode 100644
index 0000000000..244aca0356
--- /dev/null
+++ b/recipes/miau/files/paths.patch
@@ -0,0 +1,43 @@
+--- miau/src/miau.h~ 2005-02-27 22:10:30.000000000 +1030
++++ miau/src/miau.h 2005-02-27 22:11:55.000000000 +1030
+@@ -22,11 +22,11 @@
+
+
+
+-#define MIAURC "miaurc"
+-#define MIAUDIR ".miau/"
++#define MIAURC "/etc/miau.conf"
++#define MIAUDIR "miau/"
+ #define LOGDIR "logs"
+-#define FILE_PID "pid"
+-#define FILE_LOG "log"
++#define FILE_PID "/var/run/miau.pid"
++#define FILE_LOG "/var/log/miau.log"
+ #define FILE_INBOX "inbox"
+
+ #define MIAU_URL "http://miau.sourceforge.net/"
+--- miau/src/miau.c.orig 2004-11-08 23:42:14.000000000 +1030
++++ miau/src/miau.c 2004-11-08 23:47:44.000000000 +1030
+@@ -2348,10 +2348,13 @@
+ }
+
+ else {
++#if 0
+ if (! (s = getenv("HOME"))) {
+ error(MIAU_ERRNOHOME);
+ escape();
+ }
++#endif
++ s = "/var/spool";
+
+ cfg.home = xmalloc(strlen(s) + strlen(MIAUDIR) + 2);
+ xstrcpy(cfg.home, s);
+@@ -2377,7 +2380,7 @@
+ escape();
+ }
+ } else {
+- if (mkdir(LOGDIR, 0700) == -1) {
++ if (mkdir(LOGDIR, 0755) == -1) {
+ error(MIAU_ERRCREATELOGDIR, LOGDIR);
+ escape();
+ }
diff --git a/recipes/miau/miau_0.5.3.bb b/recipes/miau/miau_0.5.3.bb
new file mode 100644
index 0000000000..38faec8448
--- /dev/null
+++ b/recipes/miau/miau_0.5.3.bb
@@ -0,0 +1,41 @@
+DESCRIPTION = "MIAU IRC Bouncer"
+SECTION = "network"
+PRIORITY = "optional"
+HOMEPAGE = "http://sf.net/project/miau/"
+LICENSE = "GPL"
+PR = "r2"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/miau/miau-${PV}.tar.gz \
+ file://paths.patch;patch=1 \
+ file://miau.init"
+S = "${WORKDIR}/miau-${PV}"
+
+inherit autotools update-rc.d
+
+INITSCRIPT_NAME = "miau"
+INITSCRIPT_PARAMS = "defaults 80"
+
+EXTRA_OECONF = "\
+ --enable-dccbounce \
+ --enable-automode \
+ --enable-releasenick \
+ --enable-ctcp-replies \
+ --enable-mkpasswd \
+ --enable-uptime \
+ --enable-chanlog \
+ --enable-privlog \
+ --enable-onconnect \
+ --enable-empty-awaymsg \
+ --enable-enduserdebug \
+ --enable-pingstat \
+ --enable-dumpstatus \
+ "
+
+do_install_append() {
+ install -d ${D}${localstatedir}/spool/miau
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0644 ${S}/misc/miaurc ${D}${sysconfdir}/miau.conf
+ install -m 0755 ${WORKDIR}/miau.init ${D}${sysconfdir}/init.d/miau
+}
+
+CONFFILES_${PN} = "${sysconfdir}/miau.conf"