summaryrefslogtreecommitdiffstats
path: root/recipes/midpath/midpath-demos_0.2+0.3rc2.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/midpath/midpath-demos_0.2+0.3rc2.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/midpath/midpath-demos_0.2+0.3rc2.bb')
-rw-r--r--recipes/midpath/midpath-demos_0.2+0.3rc2.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/recipes/midpath/midpath-demos_0.2+0.3rc2.bb b/recipes/midpath/midpath-demos_0.2+0.3rc2.bb
new file mode 100644
index 0000000000..ebf260d7fe
--- /dev/null
+++ b/recipes/midpath/midpath-demos_0.2+0.3rc2.bb
@@ -0,0 +1,53 @@
+require midpath-common.inc
+
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/midpath/midpath-0.3rc2.tar.gz"
+
+S = "${WORKDIR}/midpath-0.3rc2"
+
+DEPENDS = "midpath-core midpath-location midpath-messaging midpath-svg midpath-opengles midpath-m3g"
+RDEPENDS = "midpath midpath-location midpath-messaging midpath-svg-midp midpath-opengles midpath-m3g"
+
+DESCRIPTION = "Demonstration programs of the MIDPath library"
+
+JAR = "midpath-demos.jar"
+
+do_compile() {
+ # Only Demos enabled.
+ midpath_build \
+ --disable-midpath \
+ --disable-cldc \
+ --disable-sdljava-cldc \
+ --disable-escher-cldc \
+ --disable-jlayerme-cldc \
+ --disable-jorbis-cldc \
+ --disable-avetanabt-cldc \
+ --disable-jgl-cldc \
+ --disable-web_services-api \
+ --disable-messaging-api \
+ --disable-svg-api \
+ --disable-opengl-api \
+ --disable-m3g-api \
+ --with-location-jar=${STAGING_DATADIR}/midpath/jsr179-location.jar \
+ --with-messaging-jar=${STAGING_DATADIR}/midpath/jsr205-messaging.jar \
+ --with-svg-core-jar=${STAGING_DATADIR}/midpath/jsr226-svg-core.jar \
+ --with-opengles-core-jar=${STAGING_DATADIR}/midpath/jsr239-opengles-core.jar \
+ --with-opengles-nio-jar=${STAGING_DATADIR}/midpath/jsr239-opengles-nio.jar \
+ --with-m3g-jar=${STAGING_DATADIR}/midpath/jsr184-m3g.jar \
+ --with-avetanabt-cldc-jar=${STAGING_DATADIR}/midpath/avetanabt-cldc.jar
+}
+
+do_install() {
+ install -d ${D}${datadir}/midpath/repository
+ install -m 0644 dist/${JAR} ${D}${datadir}/midpath/repository
+}
+
+do_stage() {
+ install -d ${STAGING_DATADIR}/midpath/repository
+ install -m 0644 dist/${JAR} ${STAGING_DATADIR}/midpath/repository
+}
+
+PACKAGES = "${PN}"
+
+FILES_${PN} = "${datadir}/midpath/repository/${JAR}"