aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/minicom
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/minicom
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/minicom')
-rw-r--r--recipes/minicom/minicom-2.1/configure.patch25
-rw-r--r--recipes/minicom/minicom-2.1/gcc4-scope.patch44
-rw-r--r--recipes/minicom/minicom-2.1/gcc4-scope2.patch112
-rw-r--r--recipes/minicom/minicom_2.1.bb13
-rw-r--r--recipes/minicom/minicom_2.3.bb11
5 files changed, 205 insertions, 0 deletions
diff --git a/recipes/minicom/minicom-2.1/configure.patch b/recipes/minicom/minicom-2.1/configure.patch
new file mode 100644
index 0000000000..4db47fb3d8
--- /dev/null
+++ b/recipes/minicom/minicom-2.1/configure.patch
@@ -0,0 +1,25 @@
+Index: minicom-2.1/configure.in
+===================================================================
+--- minicom-2.1.orig/configure.in 2003-04-29 21:08:25.000000000 +0000
++++ minicom-2.1/configure.in 2005-07-04 19:03:32.000000000 +0000
+@@ -231,9 +231,9 @@
+ AC_HEADER_STAT
+ AC_HEADER_TIME
+
+-AM_SYS_POSIX_TERMIOS
++AC_SYS_POSIX_TERMIOS
+ AM_HEADER_TIOCGWINSZ_NEEDS_SYS_IOCTL
+-if test $am_cv_sys_posix_termios = yes; then
++if test $ac_cv_sys_posix_termios = yes; then
+ AC_DEFINE(POSIX_TERMIOS)
+ fi
+
+@@ -253,7 +253,7 @@
+
+ dnl Checks for library functions.
+ AC_TYPE_SIGNAL
+-AM_FUNC_ERROR_AT_LINE
++AC_FUNC_ERROR_AT_LINE
+ AC_FUNC_CLOSEDIR_VOID
+ AM_WITH_DMALLOC
+ AC_CHECK_FUNCS(getcwd getwd strerror strstr vsnprintf vprintf)
diff --git a/recipes/minicom/minicom-2.1/gcc4-scope.patch b/recipes/minicom/minicom-2.1/gcc4-scope.patch
new file mode 100644
index 0000000000..5bd47bd354
--- /dev/null
+++ b/recipes/minicom/minicom-2.1/gcc4-scope.patch
@@ -0,0 +1,44 @@
+--- minicom-2.1/src/window.c.orig 2006-06-14 17:49:53.000000000 +0200
++++ minicom-2.1/src/window.c 2006-06-14 17:50:14.000000000 +0200
+@@ -62,7 +62,7 @@
+ static char *CS, *SF, *SR, *VB, *BL;
+ static char *VE, *VI, *KS, *KE;
+ static char *CD, *CL, *IC, *DC;
+-static char *BC, *CR, *NL;
++static char *mcBC, *CR, *NL;
+ #if ST_LINE
+ static char *TS, *FS, *DS;
+ #endif
+@@ -322,8 +322,8 @@
+ else if (NL != CNULL && x == 0 && x == curx && y == cury + 1)
+ outstr(NL);
+ #endif
+- else if (BC != CNULL && y == cury && x == curx - 1)
+- outstr(BC);
++ else if (mcBC != CNULL && y == cury && x == curx - 1)
++ outstr(mcBC);
+ else
+ outstr(tgoto(CM, x, y));
+ curx = x;
+@@ -1918,7 +1918,7 @@
+ CL = tgetstr("cl", &_tptr);
+ IC = tgetstr("ic", &_tptr);
+ DC = tgetstr("dc", &_tptr);
+- BC = tgetstr("bc", &_tptr);
++ mcBC = tgetstr("bc", &_tptr);
+ CR = tgetstr("cr", &_tptr);
+ NL = tgetstr("nl", &_tptr);
+ AC = tgetstr("ac", &_tptr);
+@@ -1967,10 +1967,10 @@
+ _has_am = tgetflag("am");
+ _mv_standout = tgetflag("ms");
+ if (tgetflag("bs")) {
+- if (BC == CNULL) BC = "\b";
++ if (mcBC == CNULL) mcBC = "\b";
+ }
+ else
+- BC = CNULL;
++ mcBC = CNULL;
+
+ /* Special IBM box-drawing characters */
+ D_UL = 201;
diff --git a/recipes/minicom/minicom-2.1/gcc4-scope2.patch b/recipes/minicom/minicom-2.1/gcc4-scope2.patch
new file mode 100644
index 0000000000..9cefca10fd
--- /dev/null
+++ b/recipes/minicom/minicom-2.1/gcc4-scope2.patch
@@ -0,0 +1,112 @@
+Index: minicom-2.1/src/minicom.c
+===================================================================
+--- minicom-2.1.orig/src/minicom.c 2003-05-16 20:33:19.000000000 +0000
++++ minicom-2.1/src/minicom.c 2008-10-12 23:55:35.000000000 +0000
+@@ -153,7 +153,7 @@
+
+ #if _HISTORY
+ /* Get a line from either window or scroll back buffer. */
+-static ELM *getline(w, no)
++static ELM *mcgetline(w, no)
+ WIN *w;
+ int no;
+ {
+@@ -194,7 +194,7 @@
+
+ w->direct = 0;
+ for(f = 0; f < w->ys; f++)
+- wdrawelm(w, f, getline(w, y++));
++ wdrawelm(w, f, mcgetline(w, y++));
+ if (r) wredraw(w, 1);
+ w->direct = 1;
+ }
+@@ -222,7 +222,7 @@
+ w->direct = 0;
+ for (f = 0; f < w->ys; f++)
+ {
+- tmp_e = getline(w, y++);
++ tmp_e = mcgetline(w, y++);
+
+ /* First we "accumulate" the line into a variable */
+ wdrawelm_var(w, tmp_e, tmp_line);
+@@ -321,7 +321,7 @@
+ for (next_line = hit_line; next_line <= all_lines; next_line++)
+ {
+ /* we do 'something' here... :-) */
+- tmp_e = getline(w_hist, next_line);
++ tmp_e = mcgetline(w_hist, next_line);
+
+ /*
+ * First we "accumulate" the line into a variable.
+@@ -390,9 +390,9 @@
+ int end;
+ {
+ if (y+citey >= start && y+citey <= end)
+- wdrawelm_inverse(w, y, getline(w, y+citey));
++ wdrawelm_inverse(w, y, mcgetline(w, y+citey));
+ else
+- wdrawelm(w, y, getline(w, y+citey));
++ wdrawelm(w, y, mcgetline(w, y+citey));
+ }
+
+ static void drawcite_whole(w, y, start, end)
+@@ -416,7 +416,7 @@
+ for (y=start; y<=end; y++) {
+ vt_send('>');
+ vt_send(' ');
+- tmp_e = getline(w, y);
++ tmp_e = mcgetline(w, y);
+ wdrawelm_var(w, tmp_e, tmp_line);
+ tmp_line[w->xs]=0;
+ for (x=w->xs-1; x>=0; x--){
+@@ -599,7 +599,7 @@
+ inverse =
+ (y+cite_y >= cite_ystart && y+cite_y <= cite_yend);
+ } else {
+- tmp_e = getline(b_us, y);
++ tmp_e = mcgetline(b_us, y);
+ if (strlen(look_for) > 1)
+ {
+ /* quick scan for pattern match */
+@@ -618,8 +618,8 @@
+ inverse = 0;
+ }
+ #endif /*_SEARCH_HISTORY*/
+- if (inverse) wdrawelm_inverse(b_us, 0, getline(b_us, y));
+- else wdrawelm(b_us, 0, getline(b_us, y));
++ if (inverse) wdrawelm_inverse(b_us, 0, mcgetline(b_us, y));
++ else wdrawelm(b_us, 0, mcgetline(b_us, y));
+ if (citemode) wlocate(b_us, 0, cite_y);
+ wflush();
+ break;
+@@ -652,7 +652,7 @@
+ inverse =
+ (y+cite_y >= cite_ystart && y+cite_y <= cite_yend);
+ } else {
+- tmp_e = getline(b_us, y + b_us->ys - 1);
++ tmp_e = mcgetline(b_us, y + b_us->ys - 1);
+ if (strlen(look_for) > 1)
+ {
+ /* quick scan for pattern match */
+@@ -673,10 +673,10 @@
+ #endif /*_SEARCH_HISTORY*/
+ if (inverse)
+ wdrawelm_inverse(b_us, b_us->ys - 1,
+- getline(b_us, y + b_us->ys - 1));
++ mcgetline(b_us, y + b_us->ys - 1));
+ else
+ wdrawelm(b_us, b_us->ys - 1,
+- getline(b_us, y + b_us->ys - 1));
++ mcgetline(b_us, y + b_us->ys - 1));
+ if (citemode) wlocate(b_us, 0, cite_y);
+ wflush();
+ break;
+@@ -760,7 +760,7 @@
+ wlocate(b_st, 0, 0);
+ wprintf(b_st, hline);
+ wredraw(b_st, 1);
+- wdrawelm_inverse(b_us, cite_y, getline(b_us, cite_ystart));
++ wdrawelm_inverse(b_us, cite_y, mcgetline(b_us, cite_ystart));
+ wlocate(b_us, 0, cite_y);
+ break;
+ case K_ESC:
diff --git a/recipes/minicom/minicom_2.1.bb b/recipes/minicom/minicom_2.1.bb
new file mode 100644
index 0000000000..c6915c5f7a
--- /dev/null
+++ b/recipes/minicom/minicom_2.1.bb
@@ -0,0 +1,13 @@
+SECTION = "console/network"
+DEPENDS = "ncurses"
+LICENSE = "GPL"
+SRC_URI = "http://alioth.debian.org/download.php/123/minicom-${PV}.tar.gz \
+ file://configure.patch;patch=1 \
+ file://gcc4-scope.patch;patch=1 \
+ file://gcc4-scope2.patch;patch=1"
+
+inherit autotools gettext
+
+do_install() {
+ for d in doc extras man intl lib src; do make -C $d DESTDIR=${D} install; done
+}
diff --git a/recipes/minicom/minicom_2.3.bb b/recipes/minicom/minicom_2.3.bb
new file mode 100644
index 0000000000..5b32401b1e
--- /dev/null
+++ b/recipes/minicom/minicom_2.3.bb
@@ -0,0 +1,11 @@
+SECTION = "console/network"
+DEPENDS = "ncurses"
+LICENSE = "GPL"
+SRC_URI = "http://alioth.debian.org/frs/download.php/2332/minicom-${PV}.tar.gz \
+ "
+
+inherit autotools gettext
+
+do_install() {
+ for d in doc extras man lib src; do make -C $d DESTDIR=${D} install; done
+}