aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/misc-binary-only/prism2-firmware-update_1.7.4.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/misc-binary-only/prism2-firmware-update_1.7.4.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/misc-binary-only/prism2-firmware-update_1.7.4.bb')
-rw-r--r--recipes/misc-binary-only/prism2-firmware-update_1.7.4.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/recipes/misc-binary-only/prism2-firmware-update_1.7.4.bb b/recipes/misc-binary-only/prism2-firmware-update_1.7.4.bb
new file mode 100644
index 0000000000..e37cfd6562
--- /dev/null
+++ b/recipes/misc-binary-only/prism2-firmware-update_1.7.4.bb
@@ -0,0 +1,45 @@
+DESCRIPTION = "one-time install package to upgrade the firmware of all installed prism2 based cards."
+RDEPENDS = "hostap-modules-pci hostap-utils"
+SECTION = "base"
+PRIORITY = "optional"
+LICENSE = "unknown"
+
+SRC_URI = "http://www.red-bean.com/~proski/firmware/${PV}.tar.bz2"
+
+INHIBIT_PACKAGE_STRIP = "1"
+
+do_install() {
+ install -d ${D}tmp
+ install ${WORKDIR}/${PV}/pk010101.hex ${D}tmp
+ install ${WORKDIR}/${PV}/sf010704.hex ${D}tmp
+}
+
+pkg_postinst() {
+if test "x$D" != "x"; then
+ exit 1
+else
+ FW_VERSION="v${PV}";
+
+ fw_upgrade() {
+ IF=$1;
+ echo "firmware upgrade on $IF"
+ if [ ! `iwconfig $IF | grep "No such device"` ]; then
+ echo -n " - current firmware version: ";
+ echo `hostap_diag $IF | grep STAID | awk '{print $3}'`;
+ if [[ `hostap_diag $IF | grep STAID | awk '{print $3}'` < $FW_VERSION ]]; then
+ echo " - upgrading to version $FW_VERSION"
+ prism2_srec -f $IF /tmp/sf010704.hex /tmp/pk010101.hex
+ else
+ echo " - upgrade not necessary"
+ fi
+ fi
+ echo "done".
+ }
+
+ for i in `ls /proc/net/hostap`; do
+ fw_upgrade $i;
+ done;
+fi
+}
+
+FILES_${PN} += "/tmp"