aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mktemp
diff options
context:
space:
mode:
authorMartyn Welch <martyn.welch@ge.com>2010-03-15 03:35:08 +0000
committerKhem Raj <raj.khem@gmail.com>2010-03-28 00:33:43 -0700
commit1715eb524b26f109b22c3c05b248575e7df562a1 (patch)
tree0f3eef4fe179c2b3250e0a1061a1baee93a4dcce /recipes/mktemp
parent2e551bcaf420a55759df977b5bcc1d6c06cece25 (diff)
downloadopenembedded-1715eb524b26f109b22c3c05b248575e7df562a1.tar.gz
mktemp_1.6.bb: use update-alternatives
* As suggested in the original version, this patch makes mktemp use update-alternatives. Signed-off-by: Martyn Welch <martyn.welch@ge.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/mktemp')
-rw-r--r--recipes/mktemp/mktemp_1.6.bb15
1 files changed, 11 insertions, 4 deletions
diff --git a/recipes/mktemp/mktemp_1.6.bb b/recipes/mktemp/mktemp_1.6.bb
index bd9c4caa7d..33c1cf132c 100644
--- a/recipes/mktemp/mktemp_1.6.bb
+++ b/recipes/mktemp/mktemp_1.6.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.mktemp.org/"
SECTION = "console/utils"
LICENSE = "GPLv2 BSD"
-inherit autotools
+inherit autotools update-alternatives
EXTRA_OECONF = "--with-libc"
@@ -12,6 +12,13 @@ SRC_URI = "\
file://add_destdir.patch;patch=1 \
file://disable-strip.patch;patch=1 \
"
-
-# FIXME should rather use update-alternatives
-RCONFLICTS_${PN} = "coreutils"
+
+do_install_append () {
+ mkdir ${D}${base_bindir}
+ mv ${D}${bindir}/mktemp ${D}${base_bindir}/mktemp.${PN}
+}
+
+ALTERNATIVE_NAME = "mktemp"
+ALTERNATIVE_LINK = "${base_bindir}/mktemp"
+ALTERNATIVE_PATH = "${base_bindir}/mktemp.${PN}"
+ALTERNATIVE_PRIORITY = "100"