aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/moblin
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-05-31 16:51:24 +0200
committerKoen Kooi <koen@openembedded.org>2009-05-31 16:51:24 +0200
commitf5cce792caabab9975b50215835003f066a0f3e8 (patch)
tree79079ef8a4d45a3e787764c722b981990014f000 /recipes/moblin
parent9d1ba2a95bf1b77a4503beede2ccb7250749c9b2 (diff)
downloadopenembedded-f5cce792caabab9975b50215835003f066a0f3e8.tar.gz
moblin: add recipes from poky 'meta-moblin' overlay
* the juicy parts depend on clutter and clutter-gst
Diffstat (limited to 'recipes/moblin')
-rw-r--r--recipes/moblin/bickley_git.bb19
-rw-r--r--recipes/moblin/json-glib_0.6.2.bb7
-rw-r--r--recipes/moblin/json-glib_git.bb16
-rw-r--r--recipes/moblin/libccss_git.bb14
-rw-r--r--recipes/moblin/librest_git.bb14
-rw-r--r--recipes/moblin/moblin-menus/configurefix.patch13
-rw-r--r--recipes/moblin/moblin-menus_git.bb11
-rw-r--r--recipes/moblin/mojito_git.bb29
-rw-r--r--recipes/moblin/twitter-glib_git.bb16
9 files changed, 139 insertions, 0 deletions
diff --git a/recipes/moblin/bickley_git.bb b/recipes/moblin/bickley_git.bb
new file mode 100644
index 0000000000..26bf40d32e
--- /dev/null
+++ b/recipes/moblin/bickley_git.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "A meta data manager API and framework (including Media)"
+SRC_URI = "git://git.moblin.org/${PN}.git;protocol=git"
+PV = "0.0"
+PR_append = "+git${SRCREV}"
+PR = "r3"
+
+DEPENDS = "redland gtk+ dbus-glib clutter-gst libexif taglib gupnp gupnp-av samba"
+RDEPENDS = "xdg-user-dirs"
+
+S = "${WORKDIR}/git"
+
+FILES_${PN} =+ "${datadir}/dbus-1/services/"
+
+inherit autotools_stage
+
+do_compile_prepend() {
+ sed -i -e '/# warn /d' src/bkl-investigator.c
+}
+
diff --git a/recipes/moblin/json-glib_0.6.2.bb b/recipes/moblin/json-glib_0.6.2.bb
new file mode 100644
index 0000000000..822ddad7e5
--- /dev/null
+++ b/recipes/moblin/json-glib_0.6.2.bb
@@ -0,0 +1,7 @@
+
+SRC_URI = "http://folks.o-hand.com/~ebassi/sources/json-glib-0.6.2.tar.gz"
+PR = "r0"
+
+DEPENDS = "glib-2.0"
+
+inherit autotools_stage
diff --git a/recipes/moblin/json-glib_git.bb b/recipes/moblin/json-glib_git.bb
new file mode 100644
index 0000000000..0522df1f1f
--- /dev/null
+++ b/recipes/moblin/json-glib_git.bb
@@ -0,0 +1,16 @@
+HOMEPAGE = "http://live.gnome.org/JsonGlib"
+SRC_URI = "git://github.com/ebassi/${PN}.git;protocol=git"
+PV = "0.6.2+git${SRCREV}"
+PR = "r0"
+
+S = "${WORKDIR}/git"
+
+DEPENDS = "glib-2.0"
+
+inherit autotools_stage
+
+acpaths = "-I ${S}/build/autotools "
+
+do_configure_prepend () {
+ touch ${S}/gtk-doc.make
+} \ No newline at end of file
diff --git a/recipes/moblin/libccss_git.bb b/recipes/moblin/libccss_git.bb
new file mode 100644
index 0000000000..e622d9f9bf
--- /dev/null
+++ b/recipes/moblin/libccss_git.bb
@@ -0,0 +1,14 @@
+SRC_URI = "git://anongit.freedesktop.org/git/ccss.git;protocol=git"
+PV = "0.0+git${SRCREV}"
+PR = "r0"
+
+DEPENDS = "glib-2.0 cairo librsvg libsoup-2.4"
+
+S = "${WORKDIR}/git"
+
+inherit autotools_stage
+
+do_configure_prepend () {
+ echo "EXTRA_DIST=" > ${S}/gtk-doc.make
+ echo "CLEANFILES=" >> ${S}/gtk-doc.make
+}
diff --git a/recipes/moblin/librest_git.bb b/recipes/moblin/librest_git.bb
new file mode 100644
index 0000000000..ec2d676fd5
--- /dev/null
+++ b/recipes/moblin/librest_git.bb
@@ -0,0 +1,14 @@
+
+SRC_URI = "git://git.moblin.org/${PN}.git;protocol=git"
+PV = "0.0+git${SRCREV}"
+PR = "r0"
+
+DEPENDS = "libsoup-2.4"
+
+S = "${WORKDIR}/git"
+
+inherit autotools_stage
+
+do_configure_prepend () {
+ echo "EXTRA_DIST=" > ${S}/gtk-doc.make
+}
diff --git a/recipes/moblin/moblin-menus/configurefix.patch b/recipes/moblin/moblin-menus/configurefix.patch
new file mode 100644
index 0000000000..288746aa66
--- /dev/null
+++ b/recipes/moblin/moblin-menus/configurefix.patch
@@ -0,0 +1,13 @@
+Index: git/configure.in
+===================================================================
+--- git.orig/configure.in 2009-01-17 18:57:24.000000000 +0000
++++ git/configure.in 2009-01-17 18:57:29.000000000 +0000
+@@ -11,8 +11,6 @@
+
+ AM_MAINTAINER_MODE
+
+-AM_DISABLE_STATIC
+-
+ changequote(,)dnl
+ if test "x$GCC" = "xyes"; then
+ case " $CFLAGS " in
diff --git a/recipes/moblin/moblin-menus_git.bb b/recipes/moblin/moblin-menus_git.bb
new file mode 100644
index 0000000000..ae60573649
--- /dev/null
+++ b/recipes/moblin/moblin-menus_git.bb
@@ -0,0 +1,11 @@
+
+SRC_URI = "git://git.moblin.org/${PN}.git;protocol=git \
+ file://configurefix.patch;patch=1"
+PV = "0.0+git${SRCREV}"
+PR = "r1"
+
+S = "${WORKDIR}/git"
+
+FILES_${PN} += "${datadir}/desktop-directories/*"
+
+inherit autotools_stage
diff --git a/recipes/moblin/mojito_git.bb b/recipes/moblin/mojito_git.bb
new file mode 100644
index 0000000000..b29aaed33d
--- /dev/null
+++ b/recipes/moblin/mojito_git.bb
@@ -0,0 +1,29 @@
+
+SRC_URI = "git://git.moblin.org/${PN}.git;protocol=git"
+PV = "0.0+git${SRCREV}"
+PR = "r2"
+
+DEPENDS = "libsoup-2.4 gconf-dbus librest glib-2.0 twitter-glib sqlite3 gnome-keyring"
+
+S = "${WORKDIR}/git"
+
+inherit autotools_stage
+
+FILES_${PN} += "${datadir}/dbus-1/services"
+FILES_${PN}-dbg += "${libdir}/mojito/sources/.debug/* ${libdir}/mojito/services/.debug/"
+
+PARALLEL_MAKE = ""
+
+pkg_postinst_${PN} () {
+#!/bin/sh -e
+if [ "x$D" != "x" ]; then
+ exit 1
+fi
+
+. ${sysconfdir}/init.d/functions
+
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string -s /apps/mojito/sources/flickr/user 34402200@N07
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.default --direct --type string -s /apps/mojito/sources/twitter/user ross@linux.intel.com
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string -s /apps/mojito/sources/twitter/password password
+
+}
diff --git a/recipes/moblin/twitter-glib_git.bb b/recipes/moblin/twitter-glib_git.bb
new file mode 100644
index 0000000000..791cace092
--- /dev/null
+++ b/recipes/moblin/twitter-glib_git.bb
@@ -0,0 +1,16 @@
+HOMEPAGE = "http://live.gnome.org/TwitterGlib"
+SRC_URI = "git://github.com/ebassi/${PN}.git;protocol=git"
+PV = "0.0+git${SRCREV}"
+PR = "r0"
+
+DEPENDS = "glib-2.0 gtk+ json-glib"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OECONF = "--disable-shave --disable-introspection"
+
+inherit autotools_stage
+
+do_configure_prepend () {
+ echo "EXTRA_DIST=" > ${S}/gtk-doc.make
+} \ No newline at end of file