summaryrefslogtreecommitdiffstats
path: root/recipes/module-init-tools
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/module-init-tools
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/module-init-tools')
-rw-r--r--recipes/module-init-tools/files/ignore_arch_directory24
-rw-r--r--recipes/module-init-tools/files/manpagesopt41
-rw-r--r--recipes/module-init-tools/files/module-init-tools-remove-index.patch14
-rw-r--r--recipes/module-init-tools/files/modutils_extension55
-rw-r--r--recipes/module-init-tools/files/no_man_rebuild12
-rw-r--r--recipes/module-init-tools/module-init-tools-cross_3.2.2.bb20
-rw-r--r--recipes/module-init-tools/module-init-tools_3.2.1.bb63
-rw-r--r--recipes/module-init-tools/module-init-tools_3.2.2.bb64
-rw-r--r--recipes/module-init-tools/module-init-tools_3.4.bb66
9 files changed, 359 insertions, 0 deletions
diff --git a/recipes/module-init-tools/files/ignore_arch_directory b/recipes/module-init-tools/files/ignore_arch_directory
new file mode 100644
index 0000000000..185ea7a3a5
--- /dev/null
+++ b/recipes/module-init-tools/files/ignore_arch_directory
@@ -0,0 +1,24 @@
+diff -ruN module-init-tools-3.1-pre6.orig/modprobe.8 module-init-tools-3.1-pre6/modprobe.8
+--- module-init-tools-3.2-pre7/modprobe.8.orig 2005-07-05 13:52:32.000000000 +0200
++++ module-init-tools-3.2-pre7/modprobe.8 2005-07-05 13:52:42.000000000 +0200
+@@ -31,6 +31,7 @@
+ \fI/etc/modprobe.conf\fR configuration file and
+ \fI/etc/modprobe.d\fR directory
+ (see \fBmodprobe.conf\fR(5)).
++All files in the \fI/etc/modprobe.d/arch/\fR directory are ignored.
+ .PP
+ Note that this version of \fBmodprobe\fR does not
+ do anything to the module itself: the work of resolving symbols
+--- module-init-tools-3.2-pre7/modprobe.c.orig 2005-07-05 13:50:00.000000000 +0200
++++ module-init-tools-3.2-pre7/modprobe.c 2005-07-05 13:50:15.000000000 +0200
+@@ -1158,6 +1158,10 @@
+ DIR *dir;
+ int ret = 0;
+
++ /* ignore everything in this directory */
++ if (streq(filename, "/etc/modprobe.d/arch"))
++ return 1;
++
+ /* Reiser4 has file/directory duality: treat it as both. */
+ dir = opendir(filename);
+ if (dir) {
diff --git a/recipes/module-init-tools/files/manpagesopt b/recipes/module-init-tools/files/manpagesopt
new file mode 100644
index 0000000000..5d5cac609e
--- /dev/null
+++ b/recipes/module-init-tools/files/manpagesopt
@@ -0,0 +1,41 @@
+Index: module-init-tools-3.2-pre9/configure.in
+===================================================================
+--- module-init-tools-3.2-pre9.orig/configure.in 2005-08-09 04:31:26.000000000 +0000
++++ module-init-tools-3.2-pre9/configure.in 2005-09-20 22:06:10.000000000 +0000
+@@ -41,5 +41,14 @@
+ fi])
+ AC_SUBST(MODULE_DIR)
+
+-AC_OUTPUT([Makefile])
++AC_ARG_ENABLE(manpages,
++[ --disable-manpages Disable man page generation.],
++[if test x"$enableval" != x"no"; then
++ enable_manpages=yes
++else
++ enable_manpages=no
++fi],
++[enable_manpages=yes])
++AM_CONDITIONAL([MANPAGES], test x"$enable_manpages" = x"yes")
+
++AC_OUTPUT([Makefile])
+Index: module-init-tools-3.2-pre9/Makefile.am
+===================================================================
+--- module-init-tools-3.2-pre9.orig/Makefile.am 2005-08-09 04:54:28.000000000 +0000
++++ module-init-tools-3.2-pre9/Makefile.am 2005-09-20 22:09:03.000000000 +0000
+@@ -21,13 +21,14 @@
+ MAN5 = modprobe.conf.5 modules.dep.5
+ MAN8 = depmod.8 insmod.8 lsmod.8 rmmod.8 modprobe.8 modinfo.8
+ SGML = $(addprefix doc/, $(MAN5:%.5=%.sgml) $(MAN8:%.8=%.sgml))
+-man_MANS = $(MAN5) $(MAN8)
+ # If they haven't overridden mandir, fix it (never /man!)
+ mandir =$(shell if [ @mandir@ = $(prefix)/man ]; then if [ $(prefix) = / ]; then echo /usr/share/man; else echo $(prefix)/share/man; fi; else echo @mandir@; fi)
+
+ TESTSUITE := $(shell find tests -type f ! -name '*~') tests/vg-suppressions
+
+-EXTRA_DIST = generate-modprobe.conf modprobe.devfs FAQ CODING stress_modules.sh install-with-care $(SGML) $(man_MANS) $(TESTSUITE)
++if MANPAGES
++man_MANS = $(MAN5) $(MAN8)
++endif
+
+ sbin_PROGRAMS = insmod modprobe rmmod depmod modinfo insmod.static
+ bin_PROGRAMS = lsmod
diff --git a/recipes/module-init-tools/files/module-init-tools-remove-index.patch b/recipes/module-init-tools/files/module-init-tools-remove-index.patch
new file mode 100644
index 0000000000..c56532e007
--- /dev/null
+++ b/recipes/module-init-tools/files/module-init-tools-remove-index.patch
@@ -0,0 +1,14 @@
+http://uclibc.org/cgi-bin/viewcvs.cgi/trunk/buildroot/package/module-init-tools/module-init-tools-remove-index.patch?rev=16782&view=auto
+
+diff -ur module-init-tools-3.2.2/modprobe.c module-init-tools-3.2.2-patched/modprobe.c
+--- module-init-tools-3.2.2/modprobe.c 2005-12-01 17:42:09.000000000 -0600
++++ module-init-tools-3.2.2-patched/modprobe.c 2006-12-04 19:50:50.353237649 -0600
+@@ -270,7 +270,7 @@
+ char *modname;
+
+ /* Ignore lines without : or which start with a # */
+- ptr = index(line, ':');
++ ptr = strchr(line, ':');
+ if (ptr == NULL || line[strspn(line, "\t ")] == '#')
+ return 0;
+
diff --git a/recipes/module-init-tools/files/modutils_extension b/recipes/module-init-tools/files/modutils_extension
new file mode 100644
index 0000000000..fd84ca2550
--- /dev/null
+++ b/recipes/module-init-tools/files/modutils_extension
@@ -0,0 +1,55 @@
+--- module-init-tools-3.0-pre10.orig/depmod.c
++++ module-init-tools-3.0-pre10/depmod.c
+@@ -217,13 +217,13 @@
+ {
+ char *sep;
+ char pathname[strlen(argv[0])+1];
+- char oldname[strlen("depmod") + strlen(argv[0]) + sizeof(".old")];
++ char oldname[strlen("depmod") + strlen(argv[0]) + sizeof(".24")];
+
+ memset(pathname, 0, strlen(argv[0])+1);
+ sep = strrchr(argv[0], '/');
+ if (sep)
+ memcpy(pathname, argv[0], sep - argv[0]+1);
+- sprintf(oldname, "%s%s.old", pathname, "depmod");
++ sprintf(oldname, "%s%s.24", pathname, "depmod");
+
+ /* Recursion detection: we need an env var since we can't
+ change argv[0] (as older modutils uses it to determine
+--- module-init-tools-3.0-pre10.orig/backwards_compat.c
++++ module-init-tools-3.0-pre10/backwards_compat.c
+@@ -21,13 +21,13 @@
+ pid_t pid;
+ char ascii_pid[32];
+ char pathname[strlen(argv[0])+1];
+- char oldname[strlen(progname) + strlen(argv[0]) + sizeof(".old")];
++ char oldname[strlen(progname) + strlen(argv[0]) + sizeof(".24")];
+
+ memset(pathname, 0, strlen(argv[0])+1);
+ sep = strrchr(argv[0], '/');
+ if (sep)
+ memcpy(pathname, argv[0], sep - argv[0]+1);
+- sprintf(oldname, "%s%s.old", pathname, progname);
++ sprintf(oldname, "%s%s.24", pathname, progname);
+
+ /* Recursion detection: we need an env var since we can't
+ change argv[0] (as older modutils uses it to determine
+--- module-init-tools-3.0-pre10.orig/generate-modprobe.conf
++++ module-init-tools-3.0-pre10/generate-modprobe.conf
+@@ -26,12 +26,12 @@
+ cp $TESTING_MODPROBE_CONF $MODPROBECONF
+ elif [ "$STDIN" = "1" ]; then
+ cat > $MODPROBECONF
+-elif [ -x /sbin/modprobe.old ]; then
++elif [ -x /sbin/modprobe.24 ]; then
+ # In sbin.
+- /sbin/modprobe.old -c > $MODPROBECONF
+-elif modprobe.old -c >/dev/null 2>&1; then
++ /sbin/modprobe.24 -c > $MODPROBECONF
++elif modprobe.24 -c >/dev/null 2>&1; then
+ # Somewhere in path.
+- modprobe.old -c > $MODPROBECONF
++ modprobe.24 -c > $MODPROBECONF
+ elif /sbin/modprobe -V 2>/dev/null | grep -q 'modprobe version'; then
+ # Running /sbin/modprobe gives old version.
+ /sbin/modprobe -c > $MODPROBECONF
diff --git a/recipes/module-init-tools/files/no_man_rebuild b/recipes/module-init-tools/files/no_man_rebuild
new file mode 100644
index 0000000000..d38866aece
--- /dev/null
+++ b/recipes/module-init-tools/files/no_man_rebuild
@@ -0,0 +1,12 @@
+diff -ruN module-init-tools-3.1.orig/Makefile.in module-init-tools-3.1/Makefile.in
+--- module-init-tools-3.1.orig/Makefile.in 2004-11-15 01:59:48.000000000 +0100
++++ module-init-tools-3.1/Makefile.in 2004-11-21 02:18:58.000000000 +0100
+@@ -613,7 +613,7 @@
+ check-am: all-am
+ $(MAKE) $(AM_MAKEFLAGS) check-TESTS
+ check: check-am
+-all-am: Makefile $(PROGRAMS) $(SCRIPTS) $(MANS)
++all-am: Makefile $(PROGRAMS) $(SCRIPTS) #$(MANS)
+
+ installdirs:
+ $(mkinstalldirs) $(DESTDIR)$(bindir) $(DESTDIR)$(sbindir) $(DESTDIR)$(sbindir) $(DESTDIR)$(man5dir) $(DESTDIR)$(man8dir)
diff --git a/recipes/module-init-tools/module-init-tools-cross_3.2.2.bb b/recipes/module-init-tools/module-init-tools-cross_3.2.2.bb
new file mode 100644
index 0000000000..eb2027b384
--- /dev/null
+++ b/recipes/module-init-tools/module-init-tools-cross_3.2.2.bb
@@ -0,0 +1,20 @@
+LICENSE = "GPL"
+require module-init-tools_${PV}.bb
+inherit cross
+DEFAULT_PREFERENCE = "0"
+PROVIDES += "virtual/${TARGET_PREFIX}depmod virtual/${TARGET_PREFIX}depmod-2.6"
+
+# Remove the RDEPENDS we picked up from the "require";
+# it's simply extraneous for the cross package
+RDEPENDS_${PN} = ""
+
+EXTRA_OECONF_append = " --program-prefix=${TARGET_PREFIX}"
+
+do_stage () {
+ oe_runmake install
+ mv ${bindir}/${TARGET_PREFIX}depmod ${bindir}/${TARGET_PREFIX}depmod-2.6
+}
+
+do_install () {
+ :
+}
diff --git a/recipes/module-init-tools/module-init-tools_3.2.1.bb b/recipes/module-init-tools/module-init-tools_3.2.1.bb
new file mode 100644
index 0000000000..91c0efcd64
--- /dev/null
+++ b/recipes/module-init-tools/module-init-tools_3.2.1.bb
@@ -0,0 +1,63 @@
+DESCRIPTION = "This package contains a set of programs for loading, inserting, and \
+removing kernel modules for Linux (versions 2.5.48 and above). It serves \
+the same function that the modutils package serves for Linux 2.4."
+LICENSE = "GPL"
+SECTION = "base"
+PR = "r1"
+
+PACKAGES =+ "module-init-tools-insmod-static module-init-tools-depmod"
+RDEPENDS_${PN} += "module-init-tools-depmod"
+
+FILES_module-init-tools-depmod = "${sbindir}/depmod.26"
+FILES_module-init-tools-insmod-static = "${sbindir}/insmod.static"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/kernel/module-init-tools/module-init-tools-${PV}.tar.bz2 \
+ file://ignore_arch_directory;patch=1 \
+ file://modutils_extension;patch=1 \
+ file://no_man_rebuild;patch=1 \
+ file://manpagesopt;patch=1 "
+S = "${WORKDIR}/module-init-tools-${PV}"
+
+EXTRA_OECONF = "--disable-manpages"
+
+bindir = "/bin"
+sbindir = "/sbin"
+
+inherit autotools
+
+do_install() {
+ autotools_do_install
+ for f in bin/lsmod sbin/insmod sbin/rmmod sbin/modprobe sbin/modinfo sbin/depmod; do
+ mv ${D}/$f ${D}/$f.26
+ done
+}
+
+pkg_postinst_module-init-tools() {
+#!/bin/sh
+for f in sbin/insmod sbin/modprobe sbin/rmmod sbin/depmod sbin/modinfo; do
+bn=`basename $f`
+ update-alternatives --install /$f $bn /$f.26 60
+done
+update-alternatives --install /bin/lsmod bin-lsmod /bin/lsmod.26 60
+update-alternatives --install /sbin/lsmod lsmod /bin/lsmod.26 60
+}
+
+pkg_prerm_module-init-tools() {
+#!/bin/sh
+for f in sbin/insmod sbin/modprobe sbin/rmmod sbin/depmod sbin/modinfo; do
+bn=`basename $f`
+ update-alternatives --remove $bn /$f.26
+done
+update-alternatives --remove bin-lsmod /bin/lsmod.26
+update-alternatives --remove lsmod /bin/lsmod.26
+}
+
+pkg_postinst_module-init-tools-depmod() {
+#!/bin/sh
+update-alternatives --install /sbin/depmod depmod /sbin/depmod.26 60
+}
+
+pkg_prerm_module-init-tools() {
+#!/bin/sh
+update-alternatives --remove depmod /sbin/depmod.26
+}
diff --git a/recipes/module-init-tools/module-init-tools_3.2.2.bb b/recipes/module-init-tools/module-init-tools_3.2.2.bb
new file mode 100644
index 0000000000..a56bac7a82
--- /dev/null
+++ b/recipes/module-init-tools/module-init-tools_3.2.2.bb
@@ -0,0 +1,64 @@
+DESCRIPTION = "This package contains a set of programs for loading, inserting, and \
+removing kernel modules for Linux (versions 2.5.48 and above). It serves \
+the same function that the modutils package serves for Linux 2.4."
+LICENSE = "GPL"
+SECTION = "base"
+PR = "r5"
+
+PACKAGES =+ "module-init-tools-insmod-static module-init-tools-depmod"
+RDEPENDS_${PN} += "module-init-tools-depmod"
+
+FILES_module-init-tools-depmod = "${sbindir}/depmod.26"
+FILES_module-init-tools-insmod-static = "${sbindir}/insmod.static"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/kernel/module-init-tools/module-init-tools-${PV}.tar.bz2 \
+ file://ignore_arch_directory;patch=1 \
+ file://modutils_extension;patch=1 \
+ file://no_man_rebuild;patch=1 \
+ file://manpagesopt;patch=1 \
+ file://module-init-tools-remove-index.patch;patch=1 "
+S = "${WORKDIR}/module-init-tools-${PV}"
+
+EXTRA_OECONF = "--disable-manpages"
+
+bindir = "/bin"
+sbindir = "/sbin"
+
+inherit autotools
+
+do_install() {
+ autotools_do_install
+ for f in bin/lsmod sbin/insmod sbin/rmmod sbin/modprobe sbin/modinfo sbin/depmod; do
+ mv ${D}/$f ${D}/$f.26
+ done
+}
+
+pkg_postinst_module-init-tools() {
+#!/bin/sh
+for f in sbin/insmod sbin/modprobe sbin/rmmod sbin/modinfo; do
+bn=`basename $f`
+ update-alternatives --install /$f $bn /$f.26 60
+done
+update-alternatives --install /bin/lsmod bin-lsmod /bin/lsmod.26 60
+update-alternatives --install /sbin/lsmod lsmod /bin/lsmod.26 60
+}
+
+pkg_prerm_module-init-tools() {
+#!/bin/sh
+for f in sbin/insmod sbin/modprobe sbin/rmmod sbin/modinfo; do
+bn=`basename $f`
+ update-alternatives --remove $bn /$f.26
+done
+update-alternatives --remove bin-lsmod /bin/lsmod.26
+update-alternatives --remove lsmod /bin/lsmod.26
+}
+
+pkg_postinst_module-init-tools-depmod() {
+#!/bin/sh
+update-alternatives --install /sbin/depmod depmod /sbin/depmod.26 60
+}
+
+pkg_prerm_module-init-tools-depmod() {
+#!/bin/sh
+update-alternatives --remove depmod /sbin/depmod.26
+}
diff --git a/recipes/module-init-tools/module-init-tools_3.4.bb b/recipes/module-init-tools/module-init-tools_3.4.bb
new file mode 100644
index 0000000000..caea00d194
--- /dev/null
+++ b/recipes/module-init-tools/module-init-tools_3.4.bb
@@ -0,0 +1,66 @@
+DESCRIPTION = "This package contains a set of programs for loading, inserting, and \
+removing kernel modules for Linux (versions 2.5.48 and above). It serves \
+the same function that the modutils package serves for Linux 2.4."
+LICENSE = "GPL"
+SECTION = "base"
+
+PR = "r1"
+
+PACKAGES =+ "module-init-tools-insmod-static module-init-tools-depmod"
+RDEPENDS_${PN} += "module-init-tools-depmod"
+
+FILES_module-init-tools-depmod = "${sbindir}/depmod.26"
+FILES_module-init-tools-insmod-static = "${sbindir}/insmod.static"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/kernel/module-init-tools/module-init-tools-${PV}.tar.bz2 \
+ file://modutils_extension;patch=1 \
+"
+S = "${WORKDIR}/module-init-tools-${PV}"
+
+EXTRA_OECONF = "--disable-manpages"
+
+bindir = "/bin"
+sbindir = "/sbin"
+
+inherit autotools
+
+do_configure_prepend() {
+ sed -i -e /MAN5\ =/d -e /MAN8\ =/d Makefile.am
+}
+
+do_install() {
+ autotools_do_install
+ for f in bin/lsmod sbin/insmod sbin/rmmod sbin/modprobe sbin/modinfo sbin/depmod; do
+ mv ${D}/$f ${D}/$f.26
+ done
+}
+
+pkg_postinst_module-init-tools() {
+#!/bin/sh
+for f in sbin/insmod sbin/modprobe sbin/rmmod sbin/modinfo; do
+bn=`basename $f`
+ update-alternatives --install /$f $bn /$f.26 60
+done
+update-alternatives --install /bin/lsmod bin-lsmod /bin/lsmod.26 60
+update-alternatives --install /sbin/lsmod lsmod /bin/lsmod.26 60
+}
+
+pkg_prerm_module-init-tools() {
+#!/bin/sh
+for f in sbin/insmod sbin/modprobe sbin/rmmod sbin/modinfo; do
+bn=`basename $f`
+ update-alternatives --remove $bn /$f.26
+done
+update-alternatives --remove bin-lsmod /bin/lsmod.26
+update-alternatives --remove lsmod /bin/lsmod.26
+}
+
+pkg_postinst_module-init-tools-depmod() {
+#!/bin/sh
+update-alternatives --install /sbin/depmod depmod /sbin/depmod.26 60
+}
+
+pkg_prerm_module-init-tools-depmod() {
+#!/bin/sh
+update-alternatives --remove depmod /sbin/depmod.26
+}