aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mono/mono-native_1.9.1+2.2-rc1.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/mono/mono-native_1.9.1+2.2-rc1.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/mono/mono-native_1.9.1+2.2-rc1.bb')
-rw-r--r--recipes/mono/mono-native_1.9.1+2.2-rc1.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/mono/mono-native_1.9.1+2.2-rc1.bb b/recipes/mono/mono-native_1.9.1+2.2-rc1.bb
new file mode 100644
index 0000000000..3eeb2eb03b
--- /dev/null
+++ b/recipes/mono/mono-native_1.9.1+2.2-rc1.bb
@@ -0,0 +1,25 @@
+require mono_2.2.0.inc
+PR = "r3"
+DEPENDS = "glib-2.0-native perl-native"
+
+DEFAULT_PREFERENCE = "-1"
+
+#SRC_URI += "file://mono-fix-libdir-path.patch;patch=1 \
+# file://libgc_cppflags.patch;patch=1 \
+# "
+
+inherit native
+
+do_stage_prepend() {
+ install -m 755 ${S}/mono/monoburg/monoburg ${STAGING_BINDIR}
+}
+
+do_fix_libtool_name() {
+ # inherit native will make that all native tools that are being
+ # built are prefixed with something like "i686-linux-",
+ # including libtool. Fix up some hardcoded libtool names:
+ for i in "${S}"/runtime/*-wrapper.in; do
+ sed -e "s/libtool/${BUILD_SYS}-libtool/" -i "${i}"
+ done
+}
+addtask fix_libtool_name after do_patch before do_configure