aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/monotone
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-05-24 13:01:00 -0700
committerChris Larson <chris_larson@mentor.com>2010-05-25 12:54:52 -0700
commit6fe7cef27069415f2eba36bc640cf59013d4979b (patch)
treeb0cb8845ddc6b8bcffc50e08a2eeae98e049be98 /recipes/monotone
parentbf7d0467a0788a7fcc1c96e0dc35a25ae09278a0 (diff)
downloadopenembedded-6fe7cef27069415f2eba36bc640cf59013d4979b.tar.gz
Make the do_patch apply=yes param implicit if extension is .diff/.patch
For .diff/.patch you need to apply manually, you can specify apply=no. Signed-off-by: Chris Larson <chris_larson@mentor.com> Acked-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/monotone')
-rw-r--r--recipes/monotone/monotone-5_0.25.2.bb6
-rw-r--r--recipes/monotone/monotone-6_0.27.bb6
-rw-r--r--recipes/monotone/monotone-6_0.31.bb6
-rw-r--r--recipes/monotone/monotone-6_0.33.bb6
-rw-r--r--recipes/monotone/monotone-6_0.34.bb6
-rw-r--r--recipes/monotone/monotone-6_0.37.bb6
6 files changed, 18 insertions, 18 deletions
diff --git a/recipes/monotone/monotone-5_0.25.2.bb b/recipes/monotone/monotone-5_0.25.2.bb
index e31f77dec1..c06759001e 100644
--- a/recipes/monotone/monotone-5_0.25.2.bb
+++ b/recipes/monotone/monotone-5_0.25.2.bb
@@ -8,9 +8,9 @@ require monotone.inc
PR = "r0"
SRC_URI = "http://venge.net/monotone/downloads/monotone-${PV}.tar.gz \
- file://txt2c-cross-post-0.22.patch;apply=yes \
- file://uclibc.database.hh.stdarg.patch;apply=yes \
- file://configure.ac-no-sync-with-stdio-0.25.patch;apply=yes \
+ file://txt2c-cross-post-0.22.patch \
+ file://uclibc.database.hh.stdarg.patch \
+ file://configure.ac-no-sync-with-stdio-0.25.patch \
"
ALTERNATIVE_PRIORITY = "50"
diff --git a/recipes/monotone/monotone-6_0.27.bb b/recipes/monotone/monotone-6_0.27.bb
index 2a75b39bde..27d81f9e57 100644
--- a/recipes/monotone/monotone-6_0.27.bb
+++ b/recipes/monotone/monotone-6_0.27.bb
@@ -25,9 +25,9 @@ ARM_INSTRUCTION_SET = "arm"
PR = "r0"
SRC_URI = "http://venge.net/monotone/downloads/monotone-${PV}.tar.gz \
- file://txt2c-cross-post-0.22.patch;apply=yes \
- file://uclibc.database.hh.stdarg.patch;apply=yes \
- file://configure.ac-no-sync-with-stdio-0.26.patch;apply=yes \
+ file://txt2c-cross-post-0.22.patch \
+ file://uclibc.database.hh.stdarg.patch \
+ file://configure.ac-no-sync-with-stdio-0.26.patch \
"
# This makes the testsuite as a package and renames the monotone executable
# to include the netsync suffix.
diff --git a/recipes/monotone/monotone-6_0.31.bb b/recipes/monotone/monotone-6_0.31.bb
index 5447a5284f..10ddf4d43e 100644
--- a/recipes/monotone/monotone-6_0.31.bb
+++ b/recipes/monotone/monotone-6_0.31.bb
@@ -25,9 +25,9 @@ ARM_INSTRUCTION_SET = "arm"
PR = "r0"
SRC_URI = "http://venge.net/monotone/downloads/monotone-${PV}.tar.gz \
- file://txt2c-cross-post-0.22.patch;apply=yes \
- file://uclibc.database.hh.stdarg.patch;apply=yes \
- file://configure.ac-no-sync-with-stdio-0.31.patch;apply=yes \
+ file://txt2c-cross-post-0.22.patch \
+ file://uclibc.database.hh.stdarg.patch \
+ file://configure.ac-no-sync-with-stdio-0.31.patch \
"
do_compile_append() {
touch testsuite
diff --git a/recipes/monotone/monotone-6_0.33.bb b/recipes/monotone/monotone-6_0.33.bb
index 71ff753c69..8bc24f24d3 100644
--- a/recipes/monotone/monotone-6_0.33.bb
+++ b/recipes/monotone/monotone-6_0.33.bb
@@ -28,9 +28,9 @@ ARM_INSTRUCTION_SET = "arm"
PR = "r1"
SRC_URI = "http://monotone.ca/downloads/${PV}/monotone-${PV}.tar.gz \
- file://txt2c-cross-post-0.22.patch;apply=yes \
- file://uclibc.database.hh.stdarg.patch;apply=yes \
- file://configure.ac-no-sync-with-stdio-0.31.patch;apply=yes \
+ file://txt2c-cross-post-0.22.patch \
+ file://uclibc.database.hh.stdarg.patch \
+ file://configure.ac-no-sync-with-stdio-0.31.patch \
"
do_compile_append() {
touch testsuite
diff --git a/recipes/monotone/monotone-6_0.34.bb b/recipes/monotone/monotone-6_0.34.bb
index 3a9af2c0f4..9a6695237f 100644
--- a/recipes/monotone/monotone-6_0.34.bb
+++ b/recipes/monotone/monotone-6_0.34.bb
@@ -28,9 +28,9 @@ ARM_INSTRUCTION_SET = "arm"
PR = "r0"
SRC_URI = "http://monotone.ca/downloads/${PV}/monotone-${PV}.tar.gz \
- file://txt2c-cross-post-0.22.patch;apply=yes \
- file://uclibc.database.hh.stdarg.patch;apply=yes \
- file://configure.ac-no-sync-with-stdio-0.31.patch;apply=yes \
+ file://txt2c-cross-post-0.22.patch \
+ file://uclibc.database.hh.stdarg.patch \
+ file://configure.ac-no-sync-with-stdio-0.31.patch \
"
do_compile_append() {
touch testsuite
diff --git a/recipes/monotone/monotone-6_0.37.bb b/recipes/monotone/monotone-6_0.37.bb
index 3e61c7ee7b..716a26b5bc 100644
--- a/recipes/monotone/monotone-6_0.37.bb
+++ b/recipes/monotone/monotone-6_0.37.bb
@@ -28,9 +28,9 @@ ARM_INSTRUCTION_SET = "arm"
PR = "r0"
SRC_URI = "http://monotone.ca/downloads/${PV}/monotone-${PV}.tar.gz \
- file://txt2c-cross-post-0.22.patch;apply=yes \
-# file://uclibc.database.hh.stdarg.patch;apply=yes \
- file://configure.ac-no-sync-with-stdio-0.31.patch;apply=yes \
+ file://txt2c-cross-post-0.22.patch \
+# file://uclibc.database.hh.stdarg.patch \
+ file://configure.ac-no-sync-with-stdio-0.31.patch \
"
do_compile_append() {
touch testsuite