aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/motion
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/motion
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/motion')
-rw-r--r--recipes/motion/motion-3.2.11/ffmpeg-0.4.9.15594svn-20081010.diff14
-rw-r--r--recipes/motion/motion_3.2.11.bb21
2 files changed, 35 insertions, 0 deletions
diff --git a/recipes/motion/motion-3.2.11/ffmpeg-0.4.9.15594svn-20081010.diff b/recipes/motion/motion-3.2.11/ffmpeg-0.4.9.15594svn-20081010.diff
new file mode 100644
index 0000000000..af85599f20
--- /dev/null
+++ b/recipes/motion/motion-3.2.11/ffmpeg-0.4.9.15594svn-20081010.diff
@@ -0,0 +1,14 @@
+Index: ffmpeg.c
+===================================================================
+--- trunk/ffmpeg.c (revision 434)
++++ trunk/ffmpeg.c (working copy)
+@@ -164,7 +164,8 @@
+ return write(fd, buf, size);
+ }
+
+-static offset_t file_seek(URLContext *h, offset_t pos, int whence)
++
++static int64_t file_seek(URLContext *h, int64_t pos, int whence)
+ {
+ int fd = (size_t)h->priv_data;
+ return lseek(fd, pos, whence);
diff --git a/recipes/motion/motion_3.2.11.bb b/recipes/motion/motion_3.2.11.bb
new file mode 100644
index 0000000000..999a0ab6bd
--- /dev/null
+++ b/recipes/motion/motion_3.2.11.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Motion - a motion detection program"
+HOMEPAGE = "http://www.lavrsen.dk/twiki/bin/view/Motion/WebHome"
+AUTHOR = "Kenneth Lavrsen motion-user@lists.sourceforge.net"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "jpeg ffmpeg mysql postgresql"
+
+RSUGGESTS = "mysql-client postgresql-client"
+
+PR = "r1"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/${PN}/${PN}-${PV}.tar.gz \
+ file://ffmpeg-0.4.9.15594svn-20081010.diff;patch=1 "
+
+inherit autotools
+
+EXTRA_OECONF = " --with-ffmpeg=${STAGING_LIBDIR}/../ \
+ --with-mysql-lib=${STAGING_LIBDIR} \
+ --with-mysql-include=${STAGING_INCDIR}/mysql \
+ --with-pgsql-lib=${STAGING_LIBDIR} \
+ --with-pgsql-include=${STAGING_INCDIR} "