aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mozilla/firefox_3.5b4.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-11-02 11:22:10 +0100
committerKoen Kooi <koen@openembedded.org>2009-11-02 13:17:13 +0100
commitb1b029537f885bb27314552f21a159d6b75895d4 (patch)
treee295ee0eb9072cd2d2bf2b4b3ce91bc471983a3f /recipes/mozilla/firefox_3.5b4.bb
parent7e6ad01cd018c8603677712fa082f664d1122734 (diff)
downloadopenembedded-b1b029537f885bb27314552f21a159d6b75895d4.tar.gz
firefox: add 3.5.4
Diffstat (limited to 'recipes/mozilla/firefox_3.5b4.bb')
-rw-r--r--recipes/mozilla/firefox_3.5b4.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/recipes/mozilla/firefox_3.5b4.bb b/recipes/mozilla/firefox_3.5b4.bb
new file mode 100644
index 0000000000..149ee3cbdf
--- /dev/null
+++ b/recipes/mozilla/firefox_3.5b4.bb
@@ -0,0 +1,46 @@
+DEPENDS += "cairo"
+
+PV = "3.0.1+3.5b4"
+MOZPV = "3.5b4"
+PR = "r1"
+
+SRC_URI = "http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/${MOZPV}-candidates/build1/source/firefox-${MOZPV}-source.tar.bz2 \
+ file://jsautocfg.h \
+ file://jsautocfg-dontoverwrite.patch;patch=1 \
+"
+
+S = "${WORKDIR}/mozilla-1.9.1"
+
+DEFAULT_PREFERENCE = "-10"
+
+inherit mozilla
+require firefox.inc
+
+export HOST_LIBIDL_CONFIG = "${STAGING_BINDIR_NATIVE}/libIDL-config-2"
+FULL_OPTIMIZATION = "-fexpensive-optimizations -fomit-frame-pointer -frename-registers -O2"
+
+do_configure_prepend() {
+ sed -i -e s:'head -1':'head -n1':g client.mk
+ oe_runmake -f client.mk CONFIGURE_ARGS="${EXTRA_OECONF}" configure
+}
+
+do_compile_prepend() {
+ cp ${WORKDIR}/jsautocfg.h ${S}/js/src/
+ sed -i -e "s|CPU_ARCH =|CPU_ARCH = ${TARGET_ARCH}|" \
+ -e s:'$(OS_TEST)':${TARGET_ARCH}:g \
+ ${S}/security/coreconf/Linux.mk
+}
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/firefox-${MOZPV}
+ cd dist/sdk/include
+ rm -rf obsolete
+ headers=`find . -name "*.h"`
+ for f in $headers
+ do
+ install -D -m 0644 $f ${STAGING_INCDIR}/firefox-${MOZPV}/
+ done
+ # removes 2 lines that call absent headers
+ sed -e '178,179d' ${STAGING_INCDIR}/firefox-${MOZPV}/nsIServiceManager.h
+}
+