aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mozilla/firefox_3.6.8.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-09-07 12:10:38 +0200
committerKoen Kooi <koen@openembedded.org>2010-09-07 13:43:36 +0200
commitc13e53be1acaabf21e57a13365c60c90e0ce6a97 (patch)
treeb4c9ba005f447ca1edaa335bb36abc3892bc5f04 /recipes/mozilla/firefox_3.6.8.bb
parentd70dc036b73dd71332e5ff662280bbd8f3401c3b (diff)
downloadopenembedded-c13e53be1acaabf21e57a13365c60c90e0ce6a97.tar.gz
firefox: update to 3.6.8
Diffstat (limited to 'recipes/mozilla/firefox_3.6.8.bb')
-rw-r--r--recipes/mozilla/firefox_3.6.8.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes/mozilla/firefox_3.6.8.bb b/recipes/mozilla/firefox_3.6.8.bb
new file mode 100644
index 0000000000..63638524d5
--- /dev/null
+++ b/recipes/mozilla/firefox_3.6.8.bb
@@ -0,0 +1,36 @@
+DEPENDS += "cairo sqlite3 libnotify"
+
+# The .pc files below have "3.6" hardcoded, fix that before using them in a newer FF version!
+SRC_URI = "ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${PV}/source/firefox-${PV}.source.tar.bz2;name=archive \
+ file://jsautocfg.h \
+ file://security-cross.patch \
+ file://Bug339782.additional.fix.diff \
+ file://Bug385583.nspr.jmp_buf.eabi.diff \
+ file://Bug405992.atomic.nspr.diff \
+ file://jemalloc-tls.patch \
+ file://0001-Remove-Werror-from-build.patch \
+ file://0002-Fix-security-cross-compile-cpu-detection-error.patch \
+ file://plugins-dir.patch \
+ file://firefox-plugin.pc \
+ file://firefox-xpcom.pc \
+ file://nspr.pc \
+"
+
+SRC_URI[archive.md5sum] = "0ee5f14fd8be07513d16131027ebcb61"
+SRC_URI[archive.sha256sum] = "fc609cc6a0ddaa2a9ebd8511ec39ae4a404e1107a12e07b233e2afca51d9a10e"
+
+S = "${WORKDIR}/mozilla-1.9.2"
+
+inherit mozilla
+require firefox.inc
+
+EXTRA_OECONF += " --enable-official-branding --disable-crashreporter"
+
+
+FULL_OPTIMIZATION = "-fexpensive-optimizations -fomit-frame-pointer -frename-registers -O2"
+
+do_compile_prepend() {
+ cp ${WORKDIR}/jsautocfg.h ${S}/js/src/
+ sed -i "s|CPU_ARCH =|CPU_ARCH = ${TARGET_ARCH}|" security/coreconf/Linux.mk
+}
+