aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mozilla/rhino_1.7r1.bb
diff options
context:
space:
mode:
authorRobert Schuster <robertschuster@fsfe.org>2009-09-18 14:24:59 +0200
committerRobert Schuster <robertschuster@fsfe.org>2009-09-18 14:24:59 +0200
commit544342567663c18e802dcfdbdcb12fc1d75bf803 (patch)
treedd8c6b24736aab2d7e405f9a66572d9be4cf96d1 /recipes/mozilla/rhino_1.7r1.bb
parent8987e7ad7ddb8175029361a993b816b9a7cc9fdb (diff)
downloadopenembedded-544342567663c18e802dcfdbdcb12fc1d75bf803.tar.gz
rhino 1.7r1: New recipe (from Jalimo SVN).
rhino-native 1.7r1: Dito.
Diffstat (limited to 'recipes/mozilla/rhino_1.7r1.bb')
-rw-r--r--recipes/mozilla/rhino_1.7r1.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/recipes/mozilla/rhino_1.7r1.bb b/recipes/mozilla/rhino_1.7r1.bb
new file mode 100644
index 0000000000..e9268704d9
--- /dev/null
+++ b/recipes/mozilla/rhino_1.7r1.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "Lexical analyzer generator for Java"
+
+LICENSE = "GPL MPL"
+
+DEPENDS = "fastjar-native"
+
+inherit java-library
+
+SRC_URI = "\
+ ftp://ftp.mozilla.org/pub/mozilla.org/js/rhino1_7R1.zip \
+ file://rhino \
+ file://rhino-jsc \
+ "
+
+S = "${WORKDIR}/rhino1_7R1"
+
+PACKAGES = "${JPN} rhino"
+
+FILES_${PN} = "${bindir}/rhino ${bindir}/rhino-jsc"
+RDEPENDS_${PN} = "java2-runtime ${JPN}"
+
+do_compile() {
+ mkdir -p build
+
+ # Compatibility fix for jamvm which has non-genericised
+ # java.lang classes. :(
+ bcp_arg="-bootclasspath ${STAGING_DATADIR_NATIVE}/classpath/glibj.zip"
+
+ javac $bcp_arg -source 1.5 -sourcepath src -d build `find src -name "*.java"`
+
+ mkdir -p build/org/mozilla/javascript/resources
+ cp src/org/mozilla/javascript/resources/*.properties build/org/mozilla/javascript/resources
+
+ fastjar -m ${S}/src/manifest -C build -c -f ${JARFILENAME} .
+}
+
+do_install_append() {
+ install -d ${D}${bindir}
+
+ install -m 0755 ${WORKDIR}/rhino ${D}${bindir}
+ install -m 0755 ${WORKDIR}/rhino-jsc ${D}${bindir}
+}