aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mozilla
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-06-02 15:04:25 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-06-03 07:33:27 +0200
commitd4276bed389b7db06db58c7acebb83f92bff86a5 (patch)
tree2386574b6ab0c36a58a314a24d31f6b5c9291a65 /recipes/mozilla
parent823aa270059259ca619e21a5d9b22e86afb12f3b (diff)
downloadopenembedded-d4276bed389b7db06db58c7acebb83f92bff86a5.tar.gz
recipes: conform to OE packaging guidelines with RDEPENDS/RRECOMMENDS
* there is probably very few cases when it's needed without _${PN}, if you find one in attached patch, please enlighten me * usually we want those only for ${PN} not for all ${PACKAGES} ie ${PN}-dev, ${PN)-doc etc * there is a check for this in recipe-sanity.bclass * there is maybe few possible fixes also in bbclasses cpan-base.bbclass:RDEPENDS += "${@["perl", ""][(bb.data.inherits_class('native', d))]}" distutils-base.bbclass:RDEPENDS += "python-core" gtk-icon-cache.bbclass:RDEPENDS += "hicolor-icon-theme" image.bbclass:RDEPENDS += "${IMAGE_INSTALL} ${IMAGE_BOOT}" module.bbclass:RDEPENDS += "kernel (${KERNEL_VERSION}) update-modules" ?opie_i18n.bbclass: rdepends = bb.data.getVar("RDEPENDS", d, 1) ?opie_i18n.bbclass: bb.data.setVar('RDEPENDS_%s' % x[0].lower(), pn, d) ?opie_i18n.bbclass: bb.data.setVar('RDEPENDS', rdepends, d) rubyextension.bbclass:RDEPENDS += "ruby" Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <k-kooi@ti.com>
Diffstat (limited to 'recipes/mozilla')
-rw-r--r--recipes/mozilla/firefox-addon.inc2
-rw-r--r--recipes/mozilla/firefox-l10n.inc2
-rw-r--r--recipes/mozilla/thunderbird_1.0.7.bb2
3 files changed, 3 insertions, 3 deletions
diff --git a/recipes/mozilla/firefox-addon.inc b/recipes/mozilla/firefox-addon.inc
index fa0eca6d48..427dce5da5 100644
--- a/recipes/mozilla/firefox-addon.inc
+++ b/recipes/mozilla/firefox-addon.inc
@@ -2,7 +2,7 @@
# Released under the MIT license (see packages/COPYING)
DEPENDS = "unzip-native"
-RDEPENDS = "firefox"
+RDEPENDS_${PN} = "firefox"
S = "${WORKDIR}"
FIREFOX_VERSION = "3.0.4"
diff --git a/recipes/mozilla/firefox-l10n.inc b/recipes/mozilla/firefox-l10n.inc
index 31555e3d0d..640981e402 100644
--- a/recipes/mozilla/firefox-l10n.inc
+++ b/recipes/mozilla/firefox-l10n.inc
@@ -12,7 +12,7 @@ def get_language_name(package):
return lang
DEPENDS = "unzip-native"
-RDEPENDS = "firefox"
+RDEPENDS_${PN} = "firefox"
LANGUAGE = "${@get_language_name('${PN}')}"
SRC_URI = "http://releases.mozilla.org/pub/mozilla.org/firefox/releases/${PV}/linux-i686/xpi/${LANGUAGE}.xpi"
diff --git a/recipes/mozilla/thunderbird_1.0.7.bb b/recipes/mozilla/thunderbird_1.0.7.bb
index e7f4d37c8e..7665012e0f 100644
--- a/recipes/mozilla/thunderbird_1.0.7.bb
+++ b/recipes/mozilla/thunderbird_1.0.7.bb
@@ -1,6 +1,6 @@
SECTION = "x11/utils"
DEPENDS += "gnupg"
-RRECOMMENDS += "gnupg"
+RRECOMMENDS_${PN} += "gnupg"
PR = "r1"
EMVER="0.92.0"