aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mplayer
diff options
context:
space:
mode:
authorDmitry Eremin-Solenikov <dbaryshkov@gmail.com>2009-11-11 22:27:21 +0300
committerDmitry Eremin-Solenikov <dbaryshkov@gmail.com>2009-11-11 22:27:21 +0300
commitd8b110fcf31557cc403f618e81c6db79ef407cb4 (patch)
tree19c2a9a80d28560225eb7e23cfebbf4bcc5fb94f /recipes/mplayer
parent1f951c59c5218d9a4a0cf43e082365110af1b94d (diff)
downloadopenembedded-d8b110fcf31557cc403f618e81c6db79ef407cb4.tar.gz
mplayer-svn: fix building for armv4t, arm-oabi, collie
* refresh disable-executable-stack-test.patch * lavc: replace 'bx lr' with 'mov pc, lr' if no thumb interworking is enabled * libmpeg2: disable usage of pld insn if !HAVE_PLD Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com>
Diffstat (limited to 'recipes/mplayer')
-rw-r--r--recipes/mplayer/files/disable-executable-stack-test.patch6
-rw-r--r--recipes/mplayer/files/mplayer-arm-pld.patch18
-rw-r--r--recipes/mplayer/files/mplayer-lavc-arm.patch17
-rw-r--r--recipes/mplayer/mplayer_svn.bb2
4 files changed, 40 insertions, 3 deletions
diff --git a/recipes/mplayer/files/disable-executable-stack-test.patch b/recipes/mplayer/files/disable-executable-stack-test.patch
index dc8871b6ae..466e62cc8d 100644
--- a/recipes/mplayer/files/disable-executable-stack-test.patch
+++ b/recipes/mplayer/files/disable-executable-stack-test.patch
@@ -19,12 +19,12 @@ at runtime.
-int main(void) { return 0; }
-EOF
-if cc_check -Wl,-z,noexecstack ; then
-- _ld_extra="-Wl,-z,noexecstack $_ld_extra"
+- extra_ldflags="-Wl,-z,noexecstack $extra_ldflags"
- echores "yes"
-else
- echores "no"
-fi
+echores "no"
- echocheck "ftello()"
- # if we don't have ftello use the osdep/ compatibility module
+ # Dynamic linking flags
+ # (FIXME: 'echocheck "dynamic linking"' above and modify here accordingly)
diff --git a/recipes/mplayer/files/mplayer-arm-pld.patch b/recipes/mplayer/files/mplayer-arm-pld.patch
new file mode 100644
index 0000000000..b10117e4b3
--- /dev/null
+++ b/recipes/mplayer/files/mplayer-arm-pld.patch
@@ -0,0 +1,18 @@
+Index: trunk/libmpeg2/motion_comp_arm_s.S
+===================================================================
+--- trunk.orig/libmpeg2/motion_comp_arm_s.S 2009-11-11 20:49:15.376079099 +0300
++++ trunk/libmpeg2/motion_comp_arm_s.S 2009-11-11 20:51:46.468064654 +0300
+@@ -18,6 +18,13 @@
+ @ along with mpeg2dec; if not, write to the Free Software
+ @ Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+
++#include "../config.h"
++
++#if !HAVE_PLD
++.macro pld reg
++.endm
++#endif
++
+
+ .text
+
diff --git a/recipes/mplayer/files/mplayer-lavc-arm.patch b/recipes/mplayer/files/mplayer-lavc-arm.patch
new file mode 100644
index 0000000000..8c2c832ab3
--- /dev/null
+++ b/recipes/mplayer/files/mplayer-lavc-arm.patch
@@ -0,0 +1,17 @@
+Index: trunk/libavcodec/arm/dsputil_arm.S
+===================================================================
+--- trunk.orig/libavcodec/arm/dsputil_arm.S 2009-11-11 22:16:37.216062301 +0300
++++ trunk/libavcodec/arm/dsputil_arm.S 2009-11-11 22:22:00.908058155 +0300
+@@ -29,6 +29,12 @@
+ .endm
+ #endif
+
++#ifndef __THUMB_INTERWORK__
++.macro bx reg
++ mov pc, \reg
++.endm
++#endif
++
+ #if HAVE_ARMV5TE
+ function ff_prefetch_arm, export=1
+ subs r2, r2, #1
diff --git a/recipes/mplayer/mplayer_svn.bb b/recipes/mplayer/mplayer_svn.bb
index 7d2f27aa3a..f9bad67a43 100644
--- a/recipes/mplayer/mplayer_svn.bb
+++ b/recipes/mplayer/mplayer_svn.bb
@@ -9,6 +9,8 @@ RDEPENDS = "mplayer-common"
LICENSE = "GPL"
SRC_URI = "svn://svn.mplayerhq.hu/mplayer;module=trunk \
file://makefile-nostrip-svn.patch;patch=1 \
+ file://mplayer-arm-pld.patch;patch=1 \
+ file://mplayer-lavc-arm.patch;patch=1 \
"
SRCREV = "29789"